plastimatch_1.6.2+dfsg-3ubuntu1_amd64.deb


Advertisement

Description

plastimatch - medical image reconstruction and registration

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name plastimatch
Package version 1.6.2+dfsg
Package release 3ubuntu1
Package architecture amd64
Package type deb
Installed size 14.92 KB
Download size 2.69 MB
Official Mirror archive.ubuntu.com
Plastimatch is an open source software for deformable image
registration. It is designed for high-performance volumetric
registration of medical images, such as X-ray computed tomography (CT),
magnetic resonance imaging (MRI), and positron emission tomography(PET).
Software features include:
* B-spline method for deformable image registration (GPU and multicore
accelerated), including support for image masking, landmark penalties,
and regularization
* Demons method for deformable image registration (GPU accelerated)
* Multi-atlas segmentation
* ITK-based algorithms for translation, rigid, affine, multiple demons
methods, and B-spline registration
* Pipelined, multi-stage registration framework with seamless conversion
between most algorithms and transform types
* Landmark-based deformable registration using thinplate splines for
global registration
* Landmark-based deformable registration using radial basis functions
for local corrections
* Broad support for 3D image file formats (using ITK), including DICOM,
Nifti, NRRD, MetaImage, and Analyze
* Extensive toolchain for radiotherapy research, including support for
DICOM, DICOM-RT, DICOM SRO, XiO file format, gamma analysis, contour
manipulation, contour overlap analysis, and vector field analysis
Plastimatch also features two handy utilities which are not directly
related to image registration:
* FDK cone-beam CT reconstruction (GPU and multicore accelerated)
* Digitally reconstructed radiograph (DRR) generation (GPU and multicore
accelerated)

Alternatives

Package Version Architecture Repository
plastimatch_1.6.2+dfsg-3ubuntu1_i386.deb 1.6.2+dfsg i386 Ubuntu Universe
plastimatch - - -

Requires

Name Value
libc6 >= 2.14
libdcmtk5 -
libfftw3-double3 -
libgcc1 >= 1:4.0
libgdcm2.6 -
libgomp1 >= 4.9
libinsighttoolkit4.9 -
libstdc++6 >= 5.2

Download

Type URL
Binary Package plastimatch_1.6.2+dfsg-3ubuntu1_amd64.deb
Source Package plastimatch

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install plastimatch deb package:
    # sudo apt-get install plastimatch

Files

Path
/usr/bin/drr
/usr/bin/fdk
/usr/bin/landmark_warp
/usr/bin/plastimatch
/usr/lib/libplmbase.so
/usr/lib/libplmbase.so.1.6
/usr/lib/libplmdose.so
/usr/lib/libplmdose.so.1.6
/usr/lib/libplmreconstruct.so
/usr/lib/libplmreconstruct.so.1.6
/usr/lib/libplmregister.so
/usr/lib/libplmregister.so.1.6
/usr/lib/libplmsegment.so
/usr/lib/libplmsegment.so.1.6
/usr/lib/libplmsys.so
/usr/lib/libplmsys.so.1.6
/usr/lib/libplmutil.so
/usr/lib/libplmutil.so.1.6
/usr/share/doc/plastimatch/COPYRIGHT.TXT
/usr/share/doc/plastimatch/README.TXT
/usr/share/doc/plastimatch/changelog.Debian.gz
/usr/share/doc/plastimatch/copyright
/usr/share/lintian/overrides/plastimatch
/usr/share/man/man1/drr.1.gz
/usr/share/man/man1/fdk.1.gz
/usr/share/man/man1/landmark_warp.1.gz
/usr/share/man/man1/plastimatch.1.gz

Changelog

2016-03-29 - Artur Rona <ari-tczew@ubuntu.com>
plastimatch (1.6.2+dfsg-3ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/control:
+ Build using insighttoolkit4 on any architecture.
2016-03-27 - Andreas Tille <tille@debian.org>
plastimatch (1.6.2+dfsg-3) unstable; urgency=medium
[ Gregory C. Sharp ]
* debian/control: fix i386 build and
prevent build on architectures without libinsighttoolkit4-dev
Closes: #819316
[ Andreas Tille ]
* Add missing Build-Depends: libgdcm2-dev
Closes: #808401
* cme fix dpkg-control
* better hardening
2016-02-26 - Gianfranco Costamagna <locutusofborg@debian.org>
plastimatch (1.6.2+dfsg-2ubuntu3) xenial; urgency=medium
* Rebuild against libinsighttoolkit4.9.
2015-12-15 - Dimitri John Ledkov <xnox@ubuntu.com>
plastimatch (1.6.2+dfsg-2ubuntu2) xenial; urgency=high
* No change rebuild against gdcm2.6.
2015-11-19 - Steve Langasek <steve.langasek@ubuntu.com>
plastimatch (1.6.2+dfsg-2ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Build using insighttoolkit4 on any architecture.
2015-11-09 - Andreas Tille <tille@debian.org>
plastimatch (1.6.2+dfsg-2) unstable; urgency=medium
* Move repository from SVN to Git
* Build-Depends: libdcmtk-dev instead of libdcmtk2-dev
Closes: #804573
2015-11-12 - Steve Langasek <steve.langasek@ubuntu.com>
plastimatch (1.6.2+dfsg-1ubuntu2) xenial; urgency=medium
* No-change rebuild against libdcmtk4v5
2015-10-04 - Matthias Klose <doko@ubuntu.com>
plastimatch (1.6.2+dfsg-1ubuntu1) wily; urgency=medium
* Build using insighttoolkit4 on any architecture.
2015-08-12 - Martin Pitt <martin.pitt@ubuntu.com>
plastimatch (1.6.2+dfsg-1build1) wily; urgency=medium
* No-change rebuild against libdcmtk2v5
2015-07-24 - Gregory C. Sharp <gregsharp.geo@yahoo.com>
plastimatch (1.6.2+dfsg-1) unstable; urgency=medium
* New upstream release
* Fix FTBFS on several platforms
* debian/copyright: remove copyright sections for upstream removed
third party libraries
* Review GCC 5.0 issues, they are all now resolved
Closes: #778066
Closes: #793272

See Also

Package Description
playitslowly_1.5.0-0.1_all.deb Plays back audio files at a different speed or pitch
playmidi_2.4debian-10build1_amd64.deb MIDI player
plee-the-bear-data_0.6.0-3.1build1_all.deb data for Plee the Bear
plee-the-bear_0.6.0-3.1build1_amd64.deb 2D platform game
pleiades_1.6.0-3_all.deb Japanese translation plug-in for Eclipse using dynamic AOP
plink1.9_1.90~b3.31-160203-1_amd64.deb whole-genome association analysis toolset
plink_1.07-6_amd64.deb whole-genome association analysis toolset
plinth_0.8.1-1_all.deb web front end for administering every aspect of a FreedomBox
plm_2.6+repack-2_all.deb Programming exerciser in Java, Python, Scala and others
ploop_1.14.1-1_amd64.deb tools to work with ploop devices and images
plopfolio.app_0.1.0-6build4_amd64.deb Personal dashboard for GNUstep
plotdrop_0.5.2-3ubuntu1_amd64.deb A minimal GNOME frontend to GNUPlot
ploticus_2.42-3_amd64.deb script driven business graphics package
plotnetcfg_0.4.1-1_amd64.deb local networking configuration diagram plotter
plotutils_2.6-3ubuntu1_amd64.deb GNU plotutils command line tools based on libplot
Advertisement
Advertisement