pktstat_1.8.5-4build1_amd64.deb


Advertisement

Description

pktstat - top-like utility for network connections usage

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pktstat
Package version 1.8.5
Package release 4build1
Package architecture amd64
Package type deb
Installed size 82 B
Download size 28.33 KB
Official Mirror archive.ubuntu.com
pktstat displays a real-time list of active connections seen on a
network interface, and how much bandwidth is being used by what.
It partially decodes HTTP and FTP protocols to show what filename is
being transferred, as well as X11 application names. Entries hang
around on the screen for a few seconds so you can see what just
happened.
It also accepts BPF expressions.

Alternatives

Package Version Architecture Repository
pktstat_1.8.5-4build1_i386.deb 1.8.5 i386 Ubuntu Universe
pktstat - - -

Requires

Name Value
libc6 >= 2.16
libncurses5 >= 6
libpcap0.8 >= 0.9.8
libtinfo5 >= 6

Download

Type URL
Binary Package pktstat_1.8.5-4build1_amd64.deb
Source Package pktstat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pktstat deb package:
    # sudo apt-get install pktstat

Files

Path
/usr/sbin/pktstat
/usr/share/doc/pktstat/README
/usr/share/doc/pktstat/TODO
/usr/share/doc/pktstat/changelog.Debian.gz
/usr/share/doc/pktstat/copyright
/usr/share/man/man1/pktstat.1.gz

Changelog

2016-02-07 - Matthias Klose <doko@ubuntu.com>
pktstat (1.8.5-4build1) xenial; urgency=medium
* No-change rebuild for ncurses6 transition.
2014-02-21 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.5-4) unstable; urgency=low
* debian/control
- (Standards-Version): Update to 3.9.5.
- (Homepage): Delete. Dead upstream.
- (Vcs-*): Update to anonscm.debian.org.
* debian/copyright
- (Source): Empyy.
- (Comment): Mention no longer valid URLs.
2013-02-23 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.5-3) unstable; urgency=low
* debian/control
- (Standards-Version): Update to 3.9.4
* debian/copyright
- Update year.
* debian/patches
- (10): New. Do now write log to /tmp (CVE-2013-0350; Closes: #701211).
2012-03-23 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.5-2) unstable; urgency=low
* debian/control
- (Standards-Version): Update to 3.9.3.1.
* debian/rules
- Enable all hardening flags.
- (override_dh_auto_build): Delete; not needed.
2012-03-04 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.5-1) unstable; urgency=low
* New upstream release.
* debian/control
- (Build-Depends): rm dpkg-dev 1.16.1; buildflags.mk no longer used.
- (Standards-Version): Update to 3.9.3.
* debian/copyright
- DEP5 1.0
* debian/patches
- Remove. All accepted upstream.
* debian/rules
- Rm buildflags.mk; not needed with debhelper 9.
- Change to DEB_*_MAINT_APPEND variables.
2012-02-16 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.4-6) unstable; urgency=low
* debian/compat
- Update to 9
* debian/control
- (Build-Depends): update to debhelper 9, dpkg-dev 1.16.1.
- (Standards-Version): Update to 3.9.2.
* debian/copyright
- Update to DEP5.
* debian/patches
- (20): New. Fix hardened gcc errors.
* debian/rules
- Delete unnecessary rules.
- Use hardened CFLAGS.
http://wiki.debian.org/ReleaseGoals/SecurityHardeningBuildFlags
2010-04-11 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.4-5) unstable; urgency=low
* debian/rules
- (CFLAGS_DEBIAN): Change -D__FAVOR_BSD
to -D_BSD_SOURCE. Fix thanks to Petr Salinger
<Petr.Salinger@seznam.cz>
(reopened FTBFS on kfreebsd; Closes: #575328).
2010-03-25 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.4-4) unstable; urgency=low
* debian/rules
- (override_dh_auto_build): New. Add -D__FAVOR_BSD.
(FTBFS on kfreebsd; Closes: #575328).
2010-03-21 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.4-3) unstable; urgency=medium
* debian/control
- (Vcs-*): new fields.
* debian/rules
- (override_dh_auto_install): New. Converted from an old target.
- (.PHONY): Remove 'install', which prevents installing the binary.
(Closes: #574773).
2010-03-17 - Jari Aalto <jari.aalto@cante.net>
pktstat (1.8.4-2) unstable; urgency=low
* New maintainer (Closes: #569183).
- Move to packaging format "3.0 (quilt)".
* debian/clean
- Mew file.
* debian/compat
- Update to 7.
* debian/control
- (Build-Depends): update to debhelper 7.1.
- (Depends): add ${misc:Depends}.
- (Standards-Version): update to 3.8.4.
- (Homepage): update to Freshmeat.
* debian/copyright
- Update layout.
* debian/rules
- Update to dh(1).
* debian/source/format
- New file
* debian/watch
- New file.

See Also

Package Description
pkwalify_1.22-2_all.deb perl kwalify validator
placnet_1.03-2_all.deb Plasmid Constellation Network project
plainbox-insecure-policy_0.25-1_all.deb policykit policy required to use plainbox (insecure version)
plainbox_0.25-1_all.deb toolkit for software and hardware integration testing
plait_1.6.2-1ubuntu1_all.deb command-line jukebox
plan_1.10.1-5_amd64.deb X/Motif day planner
planarity_1.0+svn6432-0ubuntu2_all.deb multitouch adaption of the popular game Planarity, aka Untangle
planet-venus_0~git9de2109-4_all.deb aggregate feed generator
planetfilter_0.7.0-1ubuntu1_all.deb filter for blog aggregators
planets_0.1.13-16_all.deb Gravitation simulation of planetary bodies
planfacile_2.0.070523-0ubuntu4_amd64.deb Generate a document from a mindmap
plank_0.11.1-1_amd64.deb Elegant, simple, clean dock
planner-data_0.14.6-4_all.deb Data files for planner
planner-dev_0.14.6-4_amd64.deb Planner development library
planner-doc_0.14.6-4_all.deb Documentation for planner
Advertisement
Advertisement