pki-tools_10.2.6+git20160317-1_amd64.deb


Advertisement

Description

pki-tools - Certificate System - PKI Tools

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pki-tools
Package version 10.2.6+git20160317
Package release 1
Package architecture amd64
Package type deb
Installed size 918 B
Download size 488.45 KB
Official Mirror archive.ubuntu.com
This package contains PKI executables that can be used to help make
Certificate System into a more complete and robust PKI solution.
This package is a part of the PKI Core used by the Certificate System.

Alternatives

Package Version Architecture Repository
pki-tools_10.2.6+git20160317-1_i386.deb 10.2.6+git20160317 i386 Ubuntu Universe
pki-tools - - -

Requires

Name Value
ldap-utils -
libc6 >= 2.14
libjackson2-annotations-java -
libldap-2.4-2 >= 2.4.7
libnspr4 >= 2:4.9-2~
libnspr4-0d >= 1.8.0.10
libnss3 >= 2:3.13.4-2~
libnss3-1d >= 3.12.0~1.9b1
libnss3-tools -
pki-base = 10.2.6+git20160317-1
python:any -

Conflicts

Name Value
strongswan-pki -
strongswan-starter -

Download

Type URL
Binary Package pki-tools_10.2.6+git20160317-1_amd64.deb
Source Package dogtag-pki

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pki-tools deb package:
    # sudo apt-get install pki-tools

Files

Path
/usr/bin/AtoB
/usr/bin/AuditVerify
/usr/bin/BtoA
/usr/bin/CMCEnroll
/usr/bin/CMCRequest
/usr/bin/CMCResponse
/usr/bin/CMCRevoke
/usr/bin/CRMFPopClient
/usr/bin/DRMTool
/usr/bin/ExtJoiner
/usr/bin/GenExtKeyUsage
/usr/bin/GenIssuerAltNameExt
/usr/bin/GenSubjectAltNameExt
/usr/bin/HttpClient
/usr/bin/OCSPClient
/usr/bin/PKCS10Client
/usr/bin/PKCS12Export
/usr/bin/PrettyPrintCert
/usr/bin/PrettyPrintCrl
/usr/bin/TokenInfo
/usr/bin/p7tool
/usr/bin/pki
/usr/bin/revoker
/usr/bin/setpin
/usr/bin/sslget
/usr/bin/tkstool
/usr/share/doc/pki-tools/README
/usr/share/doc/pki-tools/changelog.Debian.gz
/usr/share/doc/pki-tools/copyright
/usr/share/java/pki/pki-tools.jar
/usr/share/lintian/overrides/pki-tools
/usr/share/man/man1/pki-audit.1.gz
/usr/share/man/man1/pki-ca-profile.1.gz
/usr/share/man/man1/pki-cert.1.gz
/usr/share/man/man1/pki-client.1.gz
/usr/share/man/man1/pki-group-member.1.gz
/usr/share/man/man1/pki-group.1.gz
/usr/share/man/man1/pki-key.1.gz
/usr/share/man/man1/pki-securitydomain.1.gz
/usr/share/man/man1/pki-tps-profile.1.gz
/usr/share/man/man1/pki-user-cert.1.gz
/usr/share/man/man1/pki-user-membership.1.gz
/usr/share/man/man1/pki-user.1.gz
/usr/share/man/man1/pki.1.gz
/usr/share/pki/java-tools/DRMTool.cfg
/usr/share/pki/native-tools/setpin.conf

Changelog

2016-04-05 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6+git20160317-1) unstable; urgency=medium
* update to current 10_2_6_BRANCH.
- refresh patches
- add pki-user-membership.1 to pki-tools
- tomcat7-build-fix.diff: Dropped, upstream.
* rules: Mark systemd units disabled by default.
* use-usr-bin.diff: Updated.
* use-root-homedir.diff: Force home_dir to be /root, so that ipa works
right.
* control: Add conflicts on strongswan-pki.
* pki-server: Remove default.cfg, logs on purge. (Closes: #814636)
* pki-base: Remove pki.conf on purge. (Closes: #804312)
2016-01-08 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-3) unstable; urgency=medium
* pki-base.postrm: Remove upgrade logs on purge. (Closes: #801139)
* use-usr-bin.diff: Fix paths to binaries to use /usr/bin instead of
/bin.
2015-10-01 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-2) unstable; urgency=medium
* pki-server.dirs: Add pki-tomcatd-nuxwdog.target.wants.
* base.postrm: No need to remove /etc/pki here.
* debian-support.diff: Drop /etc/default/tomcat8, was a leftover from
t8 testing. (Closes: #800558)
* debian-support.diff: Import /lib/lsb/init-functions in
scripts/operations. (Closes: #800559)
2015-09-23 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-1) unstable; urgency=medium
* New upstream release based on DOGTAG_10_2_6_FEDORA_22_23_20150718 tag.
* Refresh patches, drop upstreamed ones.
* control: Drop libcrypt-ssleay-perl and libxml-perl from depends.
* pki-tools.install: Add pki-ca-profile manpage.
* control: Add python-sphinx to build-depends.
* fix-jackson-paths.diff: Dropped, obsolete. Refresh other patches
to drop unused jackson includes.
* pki-server.install: Add sbin/pki-server.
* control: strongswan-starter didn't rename it's 'pki' as planned, so
add an unversioned Conflicts to pki-tools. (Closes: #767561)
* control: Update vcs-git location (-> dogtag-pki.git).
* Update patches.
* control, pki-server.install: Clean up perl stuff, drop pki-setup-
proxy which is gone.
* control: Add libnuxwdog-java to build-depends, and pki-server depends.
* install: Added new manpages, nuxwdog support, html docs to pki-base.
* debian-support.diff: Fix nuxwdog paths.
* debian-support.diff: Don't try to manage rc3.d/* symlinks.
* rules: Symlink jars under subsystem WEB-INF.
* pki-server.postinst, pki-base.post{inst,rm}: Add pki-upgrade/pki-
server-upgrade snippets.
* rules, patches: Explicitly build using tomcat7, and add a dummy
method. (Closes: #789138)
* use-dot-instead-of-source.diff: Fix bashisms.
* debian-support.diff: Fix JNI_JAR_DIR.
2014-11-07 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-4) unstable; urgency=medium
* control: Add python-selinux to pki-server depends.
2014-11-05 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-3) unstable; urgency=medium
* control: Add Breaks/Replaces on strongswan-starter to pki-tools.
(Closes: #767561)
2014-10-24 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-2) unstable; urgency=medium
* patches: Fix servlet jar name, and paths to jss4.jar and symkey.jar.
2014-10-10 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-1) unstable; urgency=low
* Initial release (Closes: #653606)

See Also

Package Description
pki-tps-client_10.2.6+git20160317-1_amd64.deb Certificate System - Token Processing System client
pki-tps_10.2.6+git20160317-1_all.deb Certificate System - Token Processing System
pkpgcounter_3.50-7.1_all.deb computes number of pages or quantity of ink needed to print documents
pktools-dev_2.6.6-1_amd64.deb GDAL add-on tools to perform useful raster processing - development files
pktools_2.6.6-1_amd64.deb GDAL add-on tools to perform useful raster processing
pktstat_1.8.5-4build1_amd64.deb top-like utility for network connections usage
pkwalify_1.22-2_all.deb perl kwalify validator
placnet_1.03-2_all.deb Plasmid Constellation Network project
plainbox-insecure-policy_0.25-1_all.deb policykit policy required to use plainbox (insecure version)
plainbox_0.25-1_all.deb toolkit for software and hardware integration testing
plait_1.6.2-1ubuntu1_all.deb command-line jukebox
plan_1.10.1-5_amd64.deb X/Motif day planner
planarity_1.0+svn6432-0ubuntu2_all.deb multitouch adaption of the popular game Planarity, aka Untangle
planet-venus_0~git9de2109-4_all.deb aggregate feed generator
planetfilter_0.7.0-1ubuntu1_all.deb filter for blog aggregators
Advertisement
Advertisement