pki-base_10.2.6+git20160317-1_amd64.deb


Advertisement

Description

pki-base - Certificate System - PKI Framework

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pki-base
Package version 10.2.6+git20160317
Package release 1
Package architecture amd64
Package type deb
Installed size 1.88 KB
Download size 1.11 MB
Official Mirror archive.ubuntu.com
The PKI Framework contains the common and client libraries and utilities.
This package is a part of the PKI Core used by the Certificate System.

Alternatives

Package Version Architecture Repository
pki-base_10.2.6+git20160317-1_i386.deb 10.2.6+git20160317 i386 Ubuntu Universe
pki-base - - -

Requires

Name Value
libcommons-cli-java -
libcommons-codec-java -
libcommons-io-java -
libcommons-lang-java -
libcommons-logging-java -
libjavassist-java -
libjettison-java -
libjss-java -
libldap-java -
libresteasy-java -
libservlet3.0-java -
libxalan2-java -
libxerces2-java -
libxml-commons-external-java -
libxml-commons-resolver1.1-java -
python << 2.8
python >= 2.7
python-ldap -
python-lxml -
python-requests -

Download

Type URL
Binary Package pki-base_10.2.6+git20160317-1_amd64.deb
Source Package dogtag-pki

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pki-base deb package:
    # sudo apt-get install pki-base

Files

Path
/etc/pki/pki.conf
/usr/lib/python2.7/dist-packages/pki/__init__.py
/usr/lib/python2.7/dist-packages/pki/account.py
/usr/lib/python2.7/dist-packages/pki/cert.py
/usr/lib/python2.7/dist-packages/pki/cli.py
/usr/lib/python2.7/dist-packages/pki/client.py
/usr/lib/python2.7/dist-packages/pki/crypto.py
/usr/lib/python2.7/dist-packages/pki/encoder.py
/usr/lib/python2.7/dist-packages/pki/key.py
/usr/lib/python2.7/dist-packages/pki/kra.py
/usr/lib/python2.7/dist-packages/pki/nssdb.py
/usr/lib/python2.7/dist-packages/pki/profile.py
/usr/lib/python2.7/dist-packages/pki/system.py
/usr/lib/python2.7/dist-packages/pki/systemcert.py
/usr/lib/python2.7/dist-packages/pki/upgrade.py
/usr/lib/python2.7/dist-packages/pki/util.py
/usr/sbin/pki-upgrade
/usr/share/doc/pki-base/changelog.Debian.gz
/usr/share/doc/pki-base/copyright
/usr/share/doc/pki-base/html/genindex.html
/usr/share/doc/pki-base/html/index.html
/usr/share/doc/pki-base/html/objects.inv
/usr/share/doc/pki-base/html/pki.html
/usr/share/doc/pki-base/html/search.html
/usr/share/doc/pki-base/html/searchindex.js
/usr/share/doc/pki-base/html/_sources/index.txt
/usr/share/doc/pki-base/html/_sources/pki.txt
/usr/share/doc/pki-base/html/_static/ajax-loader.gif
/usr/share/doc/pki-base/html/_static/basic.css
/usr/share/doc/pki-base/html/_static/classic.css
/usr/share/doc/pki-base/html/_static/comment-bright.png
/usr/share/doc/pki-base/html/_static/comment-close.png
/usr/share/doc/pki-base/html/_static/comment.png
/usr/share/doc/pki-base/html/_static/default.css
/usr/share/doc/pki-base/html/_static/doctools.js
/usr/share/doc/pki-base/html/_static/down-pressed.png
/usr/share/doc/pki-base/html/_static/down.png
/usr/share/doc/pki-base/html/_static/file.png
/usr/share/doc/pki-base/html/_static/jquery.js
/usr/share/doc/pki-base/html/_static/minus.png
/usr/share/doc/pki-base/html/_static/plus.png
/usr/share/doc/pki-base/html/_static/pygments.css
/usr/share/doc/pki-base/html/_static/searchtools.js
/usr/share/doc/pki-base/html/_static/sidebar.js
/usr/share/doc/pki-base/html/_static/underscore.js
/usr/share/doc/pki-base/html/_static/up-pressed.png
/usr/share/doc/pki-base/html/_static/up.png
/usr/share/doc/pki-base/html/_static/websupport.js
/usr/share/java/pki/pki-certsrv.jar
/usr/share/java/pki/pki-cmsutil.jar
/usr/share/java/pki/pki-nsutil.jar
/usr/share/lintian/overrides/pki-base
/usr/share/man/man1/pki-python-client.1.gz
/usr/share/man/man8/pki-upgrade.8.gz
/usr/share/pki/VERSION
/usr/share/pki/etc/pki.conf
/usr/share/pki/key/templates/archiveKey.xml
/usr/share/pki/key/templates/generateKey.xml
/usr/share/pki/key/templates/retrieveKey.xml
/usr/share/pki/upgrade/10.0.1/01-AddJniJarDir
/usr/share/pki/upgrade/10.0.3/01-RemoveJniJarDir

Changelog

2016-04-05 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6+git20160317-1) unstable; urgency=medium
* update to current 10_2_6_BRANCH.
- refresh patches
- add pki-user-membership.1 to pki-tools
- tomcat7-build-fix.diff: Dropped, upstream.
* rules: Mark systemd units disabled by default.
* use-usr-bin.diff: Updated.
* use-root-homedir.diff: Force home_dir to be /root, so that ipa works
right.
* control: Add conflicts on strongswan-pki.
* pki-server: Remove default.cfg, logs on purge. (Closes: #814636)
* pki-base: Remove pki.conf on purge. (Closes: #804312)
2016-01-08 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-3) unstable; urgency=medium
* pki-base.postrm: Remove upgrade logs on purge. (Closes: #801139)
* use-usr-bin.diff: Fix paths to binaries to use /usr/bin instead of
/bin.
2015-10-01 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-2) unstable; urgency=medium
* pki-server.dirs: Add pki-tomcatd-nuxwdog.target.wants.
* base.postrm: No need to remove /etc/pki here.
* debian-support.diff: Drop /etc/default/tomcat8, was a leftover from
t8 testing. (Closes: #800558)
* debian-support.diff: Import /lib/lsb/init-functions in
scripts/operations. (Closes: #800559)
2015-09-23 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.6-1) unstable; urgency=medium
* New upstream release based on DOGTAG_10_2_6_FEDORA_22_23_20150718 tag.
* Refresh patches, drop upstreamed ones.
* control: Drop libcrypt-ssleay-perl and libxml-perl from depends.
* pki-tools.install: Add pki-ca-profile manpage.
* control: Add python-sphinx to build-depends.
* fix-jackson-paths.diff: Dropped, obsolete. Refresh other patches
to drop unused jackson includes.
* pki-server.install: Add sbin/pki-server.
* control: strongswan-starter didn't rename it's 'pki' as planned, so
add an unversioned Conflicts to pki-tools. (Closes: #767561)
* control: Update vcs-git location (-> dogtag-pki.git).
* Update patches.
* control, pki-server.install: Clean up perl stuff, drop pki-setup-
proxy which is gone.
* control: Add libnuxwdog-java to build-depends, and pki-server depends.
* install: Added new manpages, nuxwdog support, html docs to pki-base.
* debian-support.diff: Fix nuxwdog paths.
* debian-support.diff: Don't try to manage rc3.d/* symlinks.
* rules: Symlink jars under subsystem WEB-INF.
* pki-server.postinst, pki-base.post{inst,rm}: Add pki-upgrade/pki-
server-upgrade snippets.
* rules, patches: Explicitly build using tomcat7, and add a dummy
method. (Closes: #789138)
* use-dot-instead-of-source.diff: Fix bashisms.
* debian-support.diff: Fix JNI_JAR_DIR.
2014-11-07 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-4) unstable; urgency=medium
* control: Add python-selinux to pki-server depends.
2014-11-05 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-3) unstable; urgency=medium
* control: Add Breaks/Replaces on strongswan-starter to pki-tools.
(Closes: #767561)
2014-10-24 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-2) unstable; urgency=medium
* patches: Fix servlet jar name, and paths to jss4.jar and symkey.jar.
2014-10-10 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.2.0-1) unstable; urgency=low
* Initial release (Closes: #653606)

See Also

Package Description
pki-ca_10.2.6+git20160317-1_all.deb Certificate System - Certificate Authority
pki-console_10.2.6+git20160317-1_all.deb Certificate System - PKI Console
pki-javadoc_10.2.6+git20160317-1_all.deb Certificate System - PKI Framework Javadocs
pki-kra_10.2.6+git20160317-1_all.deb Certificate System - Data Recovery Manager
pki-ocsp_10.2.6+git20160317-1_all.deb Certificate System - Online Certificate Status Protocol Manager
pki-server_10.2.6+git20160317-1_amd64.deb Certificate System - PKI Server Framework
pki-tks_10.2.6+git20160317-1_all.deb Certificate System - Token Key Service
pki-tools_10.2.6+git20160317-1_amd64.deb Certificate System - PKI Tools
pki-tps-client_10.2.6+git20160317-1_amd64.deb Certificate System - Token Processing System client
pki-tps_10.2.6+git20160317-1_all.deb Certificate System - Token Processing System
pkpgcounter_3.50-7.1_all.deb computes number of pages or quantity of ink needed to print documents
pktools-dev_2.6.6-1_amd64.deb GDAL add-on tools to perform useful raster processing - development files
pktools_2.6.6-1_amd64.deb GDAL add-on tools to perform useful raster processing
pktstat_1.8.5-4build1_amd64.deb top-like utility for network connections usage
pkwalify_1.22-2_all.deb perl kwalify validator
Advertisement
Advertisement