pioneers_15.3-1_amd64.deb


Advertisement

Description

pioneers - Settlers of Catan board game

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pioneers
Package version: 15.3
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 925 B
Download size: 225.02 KB
Official Mirror: archive.ubuntu.com
Pioneers is a computer implementation of the Settlers of Catan board game. It can be played over the internet. The game includes a server, a client, a computer player, an editor and (in a separate package) a metaserver (for locating running servers).

Alternatives

    Download

    Binary package: pioneers_15.3-1_amd64.deb
    Source package: pioneers

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pioneers deb package:
      # sudo apt-get install pioneers

    Files

    • /usr/games/pioneers
    • /usr/games/pioneers-editor
    • /usr/games/pioneers-server-gtk
    • /usr/share/applications/pioneers-editor.desktop
    • /usr/share/applications/pioneers-server.desktop
    • /usr/share/applications/pioneers.desktop
    • /usr/share/doc/pioneers/changelog.Debian.gz
    • /usr/share/doc/pioneers/copyright
    • /usr/share/man/man6/pioneers-editor.6.gz
    • /usr/share/man/man6/pioneers-server-gtk.6.gz
    • /usr/share/man/man6/pioneers.6.gz
    • /usr/share/menu/pioneers
    • /usr/share/pixmaps/pioneers-client.xpm
    • /usr/share/pixmaps/pioneers-editor.xpm
    • /usr/share/pixmaps/pioneers-server.xpm

    Changelog

    2014-10-26 - Roland Clobus <rclobus@rclobus.nl> pioneers (15.3-1) unstable; urgency=medium * New upstream release. * Updated copyright which clarifies the license for the images. (closes: #765319) * Applied 'wrap-and-sort' to all debian/* files.

    2014-10-13 - Bas Wijnen <wijnen@debian.org> pioneers (15.2-1) unstable; urgency=medium * New upstream release. * Upgrade dependencies to Gtk 3. * Upgrade standards version to 3.9.6. (No changes needed.)

    2013-12-08 - Roland Clobus <rclobus@rclobus.nl> pioneers (15.1-1) unstable; urgency=low * New upstream release. (closes: #551341) * Removed translation patches for 14.1-2. * Spelling correction: Renamed meta[- ]server to metaserver. * Migration of the settings for the metaserver. * Added debconf-updatepo in the clean target. * Updated the explanation for the extra arguments for the metaserver. * Cleanup of Provides:-section for packaging before Debian 6. * Cleanup of /etc/default/pioneers-console and /etc/init.d/pioneers-console (when the installation has been upgraded from 0.11.3 or older) * Added dependency on librsvg2-common for the rendering of the icons. * Added recommends on beep. * Added pioneers-builddep, for use with equivs-build. * Explicitly set the path to the server in the metaserver init script. * Cleanup of /etc/init.d/pioneers-meta-server. * Updated Vcs-* fields to point to the repository that moved on SourceForge. * Added Depends on initscripts (>= 2.88dsf-13.3) to ensure /run is usable. * Updated standards version to 3.9.4, no changes required. * Changed compat level to 9, so hardening is enabled without additional code.

    2013-01-25 - Roland Clobus <rclobus@rclobus.nl> pioneers (14.1-2) unstable; urgency=low * Debian-only i18n-release during freeze. * Applied translation patches from the upstream repository. * pioneers-console.preinst: Removed. The migration rules are no longer required in the current stable version. * Use 'set -e' in pioneers-meta-server scripts to remove the lintian warnings. * copyright: Updated information and removed extra link to the GPL licenses.

    2012-05-29 - Roland Clobus <rclobus@rclobus.nl> pioneers (14.1-1) unstable; urgency=low * New upstream release. * Switched to simple debhelper script. * Enabled hardening. (closes: #657829) * Added large icons for the GNOME3 desktop. * Fixed duplicate-short-description lintian warning for the data packages. * Removed Conflicts: en Replaces: for pre-oldstable versions to remove the last lintian warnings. * Used rsvg-convert instead of rsvg, together with netpbm to render the xpm icons. ImageMagick is not needed anymore as build dependency. (closes: #666480) * Added xfonts-scalable in Build-Depends: for Bitstream Charter in the svg files. * Added Brazilian Portuguese debconf translations. (closes: #661263) * Updated standards version to 3.9.3. (No changes needed.) * Use lsb-base for coloured messages during startup of the daemon.

    2011-10-30 - Roland Clobus <rclobus@rclobus.nl> pioneers (0.12.5-1) unstable; urgency=low * New upstream release. * Added libnotify support. * Fix for placing pirate when the rules do not support pirates. (closes: #643994) * Fix for assert after winning with road building card (LP:#767435) * Added -Wl,--as-needed for the Debian build.

    2011-08-18 - Roland Clobus <rclobus@rclobus.nl> pioneers (0.12.4-1) unstable; urgency=low * New upstream release. * Added Avahi support. * Numbers on the board are visible again. (closes: #574549) (LP:#530988) * Add Danish debconf translation. (closes: #633905) * Fix for lintian warning: debian-rules-missing-recommended-target

    Advertisement
    Advertisement