pike7.8-kerberos_7.8.866-5build1_amd64.deb


Advertisement

Description

pike7.8-kerberos - Kerberos and GSSAPI modules for Pike

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pike7.8-kerberos
Package version: 7.8.866
Package release: 5build1
Package architecture: amd64
Package type: deb
Installed size: 22 B
Download size: 2.53 KB
Official Mirror: archive.ubuntu.com
This package contains the Kerberos and GSSAPI Pike modules (although GSSAPI is a generic API; Kerberos is the most common mechanism), providing bindings to the Heimdal libraries. Pike is an interpreted programming language, for more information see the description of the pike7.8-core package.

Alternatives

Replaces

  • pike7.8-core << 7.8.866-2~

    Download

    Source package: pike7.8

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pike7.8-kerberos deb package:
      # sudo apt-get install pike7.8-kerberos

    Files

    • /usr/lib/pike7.8/modules/GSSAPI.so
    • /usr/lib/pike7.8/modules/Kerberos.so
    • /usr/share/doc/pike7.8-kerberos

    Changelog

    2016-04-05 - Robie Basak <robie.basak@ubuntu.com> pike7.8 (7.8.866-5build1) xenial; urgency=medium * Rebuild against libmysqlclient20.

    2015-11-21 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.866-5) unstable; urgency=low * clang_inline.patch: Fix FTBFS on i386 (probably due to changed meaning of inline with GCC 5). * Adjust debian/watch.

    2015-09-20 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.866-4) unstable; urgency=medium * Update Homepage URL to http://pike.lysator.liu.se. * freetype_2.6_typeof.patch (new): Fix FTBFS with Freetype 2.6. * smartlink_rpath.patch: Match all Linux versions. Skip patching smartlink.c since we've disabled it with --disable-smartlink_binary. * Replace dh_clean -k with dh_prep. * Bump Standards-Version to 3.9.6.

    2014-08-04 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.866-3) unstable; urgency=low * debian/copyright: Delete paragraph about repacked upstream tarball, which hasn't been the case since 7.8.700-1. * debian/copyright: Update from COPYRIGHT. * debian/copyright: Add reference to COMMITTERS. * Add libgtksourceview2.0-dev as a build dependency to enable the GTK2.SourceView module. * Add heimdal-dev as a build dependency to enable the Kerberos and GSSAPI modules. Move said modules to a new pike7.8-kerberos package. * smartlink_verbose.patch: Make the smartlink script print the build commands it's executing to allow build log checks.

    2014-08-02 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.866-2) unstable; urgency=low * Upload to unstable. * Correct watch URL. * Correct Vcs-Svn URI again; should use anonscm.debian.org. * bad_size_t_redef.patch: Fix undefined behaviour/buffer overruns in module _Image_JPEG on 64-bit architectures due to broken redefinition of size_t (Closes: #750430). * Use dh_installdocs --link-doc to create doc symlinks in module packages. * Replace GPL and LGPL license texts used by Tools.Legal.License with symlinks to corresponding files in /usr/share/common-licenses. Override remaining Lintian warnings about GPL.pmod and LGPL.pmod, which do not include the license texts themselves.

    2014-06-07 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.866-1) experimental; urgency=low * New upstream beta version. * debian/control: Correct Vcs-Svn URI.

    2014-04-22 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.852-1) experimental; urgency=low * New upstream beta version. * Drop reg_enum_conflict.patch and nettle_crypt_md5_buffer_size.patch; incorporated upstream. Refresh remaining patches. * Bump Standards-Version to 3.9.5.

    2013-06-08 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.700-7) unstable; urgency=low * Correct the Replaces and Breaks declarations related to moving Tools.PV (Closes: #711593). * Also move compatibility Image module to pike7.8-image. * Modify package descriptions noting what modules are in each package and that the Postgres module is deprecated. * Update Vcs-Browser URL. * Actually apply undefined_htons.patch.

    2013-06-08 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.700-6) unstable; urgency=low * hurd.patch: Add mach/message.h to one more place in src/configure and add HAVE_MACH_MESSAGE_H to src/machine.h.in. * nettle_crypt_md5_buffer_size.patch (new): Nette.MD5: passwd array was too small. * pcre_info_obsolete.patch (new): Stop using the long-obsolete pcre_info(), which was just recently removed from the headers but remains in the library. * undefined_htons.patch (mew): Include the necessary header file declaring htons() in Protocols.DNS_SD.

    2013-06-06 - Magnus Holmgren <holmgren@debian.org> pike7.8 (7.8.700-5) unstable; urgency=low * Build-depend on libtiff-dev rather than libtiff4-dev (Closes: #708365). * Move Tools.PV from -core to -gtk and make -gtk depend on -image, since Tools.PV requires both but is too small to make its own package (Closes: #711060). * hurd.patch (new): Make Pike build on Debian GNU/Hurd.

    Advertisement
    Advertisement