libkf5globalaccel-dev_5.18.0-0ubuntu1_amd64.deb


Advertisement

Description

libkf5globalaccel-dev - development files for kglobalaccel

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package filename libkf5globalaccel-dev_5.18.0-0ubuntu1_amd64.deb
Package name libkf5globalaccel-dev
Package version 5.18.0
Package release 0ubuntu1
Package architecture amd64
Package type deb
Category universe/libdevel
Homepage https://projects.kde.org/projects/frameworks/kglobalaccel
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.24 KB
Installed size 78.00 KB
KGlobalAccel allows you to have global accelerators that are
independent of the focused window. Unlike regular shortcuts,
the application's window does not need focus for them to be
activated.
Contains development files for kglobalaccel.

Alternatives

Package Version Architecture Repository
libkf5globalaccel-dev_5.36.0-0ubuntu1~ubuntu16.04~ppa1_i386.deb 5.36.0 i386 Kubuntu Backports
libkf5globalaccel-dev_5.36.0-0ubuntu1~ubuntu16.04~ppa1_amd64.deb 5.36.0 amd64 Kubuntu Backports
libkf5globalaccel-dev_5.18.0-0ubuntu1_i386.deb 5.18.0 i386 Ubuntu Universe
libkf5globalaccel-dev - - -

Requires

Name Value
libkf5globalaccel5 = 5.18.0-0ubuntu1
libkf5globalaccelprivate5 = 5.18.0-0ubuntu1
qtbase5-dev >= 5.4

Replaces

Name Value
libkf5globalaccel5 <= 4.100.0-0ubuntu1~ubuntu14.10~ppa3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libkf5globalaccel-dev_5.18.0-0ubuntu1_amd64.deb
Source Package kglobalaccel

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5globalaccel-dev deb package:
    # sudo apt-get install libkf5globalaccel-dev

Files

Path
/usr/include/KF5/kglobalaccel_version.h
/usr/include/KF5/KGlobalAccel/KGlobalAccel
/usr/include/KF5/KGlobalAccel/KGlobalShortcutInfo
/usr/include/KF5/KGlobalAccel/kglobalaccel.h
/usr/include/KF5/KGlobalAccel/kglobalaccel_export.h
/usr/include/KF5/KGlobalAccel/kglobalshortcutinfo.h
/usr/include/KF5/KGlobalAccel/private/kf5globalaccelprivate_export.h
/usr/include/KF5/KGlobalAccel/private/kglobalaccel_interface.h
/usr/include/KF5/KGlobalAccel/private/kglobalacceld.h
/usr/lib/x86_64-linux-gnu/libKF5GlobalAccel.so
/usr/lib/x86_64-linux-gnu/cmake/KF5GlobalAccel/KF5GlobalAccelConfig.cmake
/usr/lib/x86_64-linux-gnu/cmake/KF5GlobalAccel/KF5GlobalAccelConfigVersion.cmake
/usr/lib/x86_64-linux-gnu/cmake/KF5GlobalAccel/KF5GlobalAccelTargets-debian.cmake
/usr/lib/x86_64-linux-gnu/cmake/KF5GlobalAccel/KF5GlobalAccelTargets.cmake
/usr/lib/x86_64-linux-gnu/qt5/mkspecs/modules/qt_KGlobalAccel.pri
/usr/share/dbus-1/interfaces/kf5_org.kde.KGlobalAccel.xml
/usr/share/dbus-1/interfaces/kf5_org.kde.kglobalaccel.Component.xml
/usr/share/doc/libkf5globalaccel-dev/changelog.Debian.gz
/usr/share/doc/libkf5globalaccel-dev/copyright

Changelog

2016-03-07 - Philip Muškovac <yofel@kubuntu.org>
kglobalaccel (5.18.0-0ubuntu1) xenial; urgency=medium
[ Scarlett Clark ]
* New upstream release Xenial
[ Philip Muškovac ]
* New upstream release
2015-11-30 - Maximiliano Curia <maxy@debian.org>
kglobalaccel (5.16.0-1) unstable; urgency=medium
* New upstream release (5.16.0).
2015-10-09 - Maximiliano Curia <maxy@debian.org>
kglobalaccel (5.15.0-1) unstable; urgency=medium
* New upstream release (5.15.0).
2015-11-03 - Philip Muškovac <yofel@kubuntu.org>
kglobalaccel (5.15.0-0ubuntu2) xenial; urgency=medium
* Fix autopackagetests by adding allow-stderr to the requirements.
2015-10-07 - Jonathan Riddell <jriddell@ubuntu.com>
kglobalaccel (5.15.0-0ubuntu1) wily; urgency=medium
[ Scarlett Clark ]
* Vivid backport
[ Jonathan Riddell ]
* new upstream release
2015-09-15 - Maximiliano Curia <maxy@debian.org>
kglobalaccel (5.14.0-1) unstable; urgency=medium
* New upstream release (5.14.0).
* Update install files, private library is no longer shipped.
2015-09-17 - Clive Johnston <clivejo@aol.com>
kglobalaccel (5.14.0-0ubuntu1) wily; urgency=medium
* new upstream release
2015-09-01 - Maximiliano Curia <maxy@debian.org>
kglobalaccel (5.13.0-2) unstable; urgency=medium
* Bump build dependencies versions.
2015-08-30 - Maximiliano Curia <maxy@debian.org>
kglobalaccel (5.13.0-1) unstable; urgency=medium
* New upstream release (5.13.0).
2015-08-10 - Jonathan Riddell <jriddell@ubuntu.com>
kglobalaccel (5.13.0-0ubuntu1) wily; urgency=medium
* new upstream release

See Also

Package Description
libkf5globalaccel5_5.18.0-0ubuntu1_amd64.deb Configurable global shortcut support
libkf5globalaccelprivate5_5.18.0-0ubuntu1_amd64.deb Configurable global shortcut support - private runtime library
libkf5gpgmepp-dev_15.12.3-0ubuntu1_amd64.deb c++ wrapper library for gpgme - development files
libkf5gpgmepp-pthread5_15.12.3-0ubuntu1_amd64.deb c++ wrapper library for gpgme
libkf5gpgmepp5_15.12.3-0ubuntu1_amd64.deb c++ wrapper library for gpgme
libkf5gravatar5_15.12.3-0ubuntu1_amd64.deb gravatar library
libkf5guiaddons-dev_5.18.0-0ubuntu1_amd64.deb development headers for the kguiaddons framework
libkf5guiaddons5_5.18.0-0ubuntu1_amd64.deb additional addons for QtGui
libkf5holidays-data_15.12.3-0ubuntu2_all.deb holidays calculation library
libkf5holidays-dev_15.12.3-0ubuntu2_amd64.deb holidays calculation library - development files
libkf5holidays5_15.12.3-0ubuntu2_amd64.deb holidays calculation library
libkf5i18n-data_5.18.0-0ubuntu1_all.deb Advanced internationalization framework
libkf5i18n-dev_5.18.0-0ubuntu1_amd64.deb Advanced internationalization framework
libkf5i18n5_5.18.0-0ubuntu1_amd64.deb Advanced internationalization framework
libkf5iconthemes-bin_5.18.0-0ubuntu1_amd64.deb Support for icon themes
Advertisement
Advertisement