gnustep-back0.24_0.24.0-4_all.deb


Advertisement

Description

gnustep-back0.24 - GNUstep GUI Backend

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package filename gnustep-back0.24_0.24.0-4_all.deb
Package name gnustep-back0.24
Package version 0.24.0
Package release 4
Package architecture all
Package type deb
Category universe/libs
Homepage http://gnustep.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 10.50 KB
Installed size 106.00 KB
It is a backend component for the GNUstep GUI Library.
The implementation of the GNUstep GUI Library is designed in two parts.
The first part is the front-end component which is independent of platform
and display system.  This front-end is combined with a back-end
component which handles all of the display system dependent such as
specific calls to the X Window System.
This is an empty package that depends on the various backends.

Alternatives

Package Version Architecture Repository
gnustep-back0.24_0.24.0-4_all.deb 0.24.0 all Ubuntu Universe
gnustep-back0.24 - - -

Requires

Name Value
gnustep-back0.24-alt -
gnustep-back0.24-cairo -
gnustep-fslayout-fhs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gnustep-back0.24_0.24.0-4_all.deb
Source Package gnustep-back

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnustep-back0.24 deb package:
    # sudo apt-get install gnustep-back0.24

Files

Path
/usr/share/doc/gnustep-back0.24/ANNOUNCE
/usr/share/doc/gnustep-back0.24/NEWS.gz
/usr/share/doc/gnustep-back0.24/README
/usr/share/doc/gnustep-back0.24/README.Debian
/usr/share/doc/gnustep-back0.24/changelog.Debian.gz
/usr/share/doc/gnustep-back0.24/copyright

Changelog

2014-11-19 - Yavor Doganov <yavor@gnu.org>
gnustep-back (0.24.0-4) unstable; urgency=medium
* debian/patches/cairo-scrolling.patch: New; fix scrolling with
cairo/1.14.0 (Closes: #770141).
* debian/patches/series: Update.
2014-10-28 - Yavor Doganov <yavor@gnu.org>
gnustep-back (0.24.0-3) unstable; urgency=medium
* debian/gnustep-back-common.postinst: Ignore errors from mv which lead
to failure when font directories do not contain spaces, thanks Thomas
Zell (Closes: #764695).
* debian/gnustep-back-common.prerm: Revert bogus change introduced in
0.24.0-1 (finally closes: #663388).
* debian/control.m4 (Standards-Version): Bump to 3.9.6; no changes
needed.
* debian/control: Regenerate.
2014-07-07 - Yavor Doganov <yavor@gnu.org>
gnustep-back (0.24.0-2) unstable; urgency=medium
* Upload to unstable; should finally fix the piuparts issue once
mknfonts.tool is binNMUed (Closes: #663388).
* debian/compat: Bump to 9 to get .build-id debugging symbols.
* debian/control.m4 (Build-Depends): Require debhlper >= 9.
(Description): Mention that the art backend is deprecated.
(Suggests): Remove fonts-freefont-ttf as -common depends on it.
* debian/control: Regenerate.
* debian/rules (confflags): Define conditionally and pass --host to
configure only if cross-compiling.
2014-05-28 - Yavor Doganov <yavor@gnu.org>
gnustep-back (0.24.0-1) experimental; urgency=low
* New major upstream release.
* Ack NMU, thanks gregor herrmann.
* debian/rules (build-arch, build-indep): Remove dependency on
$(QUILT_STAMPFN).
(v_gui): Bump to 0.24.
(p_gpbs, d_gpbs): Remove.
(install-art): Move gpbs to -common.
(binary-arch): Install the manpage in -common.  Bump alternatives
priority of cairo to make it the default.
(install-indep): Do not create Developer symlink.
* debian/patches/cairo-fc.patch: Delete, not needed anymore.
* debian/patches/fontconfig-libs.patch: New, fixes FTBFS with
-Wl,--no-undefined.
* debian/patches/autoreconf.patch: Regenerate.
* debian/patches/series: Update.
* debian/control.m4 (gnustep-gpbs): Remove, it seems unnecessary kludge
to have it as an extra package.
(gnustep-back`'SOV_BACK) <Depends>: Replace art with cairo.
(gnustep-back-common) <Architecture>: Set to "any".
<Depends>: Add ${shlibs:Depends}.  Remove version requirement for
mknfonts.tool.
<Breaks, Replaces>: Add gnustep-gpbs.
(gnustep-back-dbg) <Depends>: Replace gnustep-gpbs with
gnustep-back-common.
<Recommends>: Replace libgnustep-gui0.22-dbg with
libgnustep-gui0.24-dbg.
(Suggests): Replace ttf-dejavu with fonts-dejavu.
(Vcs-Git): Use the canonical URI.
(Standards-Version): Bump to 3.9.5 (no changes needed).
* debian/control: Regenerate.
* debian/gnustep-back-common.postinst: In case of failure, inform about
/var/log/gnustep-back-common.log.
* debian/gnustep-back-common.prerm: Delete gnustep-back-common.log only
on purge.
* debian/copyright: Update copyright years, add more copyright holders
and licenses.  Clarify that gpbs's license is GPLv3+.
2012-11-15 - gregor herrmann <gregoa@debian.org>
gnustep-back (0.20.1-2.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS: build-arch problems with patch applying and installation
of files generated only in build-indep target":
- debian/rules: make build-arch and build-indep depend on quilt patch
target, thanks Ralf Treinen
- debian/rules: don't install documentation in binary-arch target, only
built for binary-indep packages
(Closes: #666334)

See Also

Package Description
gnustep-base-common_1.24.7-1build2_all.deb GNUstep Base library - common files
gnustep-base-doc_1.24.7-1build2_all.deb Documentation for the GNUstep Base Library
gnustep-base-examples_1.24.7-1build2_all.deb Examples using the GNUstep Base Library
gnustep-base-runtime_1.24.7-1build2_amd64.deb GNUstep Base library - daemons and tools
gnustep-common_2.6.6-3_amd64.deb Common files for the core GNUstep environment
gnustep-core-devel_7.8_all.deb GNUstep Development Environment -- core libraries
gnustep-core-doc_7.8_all.deb GNUstep Development Environment -- core documentation
gnustep-devel_7.8_all.deb GNUstep Development Environment -- development tools
gnustep-dl2-postgresql-adaptor_0.12.0-13_amd64.deb gnustep-dl2 adaptor to connect to PostgreSQL
gnustep-dl2-sqlite-adaptor_0.12.0-13_amd64.deb gnustep-dl2 adaptor to connect to SQLite
gnustep-dl2_0.12.0-13_amd64.deb Objective-C Classes needed for Database Access
gnustep-examples_1.4.0-1_amd64.deb GNUstep example applications
gnustep-games_7.8_all.deb GNUstep games
gnustep-gui-common_0.24.0-3.1_all.deb GNUstep GUI Library - common files
gnustep-gui-doc_0.24.0-3.1_all.deb Documentation for the GNUstep GUI Library
Advertisement
Advertisement