geany_1.27-1_amd64.deb


Advertisement

Description

geany - fast and lightweight IDE

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package filename geany_1.27-1_amd64.deb
Package name geany
Package version 1.27
Package release 1
Package architecture amd64
Package type deb
Category universe/devel
Homepage http://www.geany.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 954.33 KB
Installed size 2.82 MB
Geany is a small and lightweight integrated development environment.
It was developed to provide a small and fast IDE, which has only a
few dependencies from other packages. It is using only the GTK2 toolkit
and therefore you need only the GTK2 runtime libraries to run Geany.
The basic features of Geany are:
- syntax highlighting
- code completion
- auto completion of constructs like if, for and while, XML and HTML
- call tips
- folding
- many supported filetypes like C, Java, PHP, HTML, Python, Perl, Pascal
- symbol lists
- embedded terminal emulation

Alternatives

Package Version Architecture Repository
geany_1.27-1_i386.deb 1.27 i386 Ubuntu Universe
geany - - -

Requires

Name Value
geany-common = 1.27-1
libc6 >= 2.15
libcairo2 >= 1.8.0
libgcc1 >= 1:3.0
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.41.1
libgtk2.0-0 >= 2.22.0
libpango-1.0-0 >= 1.18.0
libpangocairo-1.0-0 >= 1.14.0
libstdc++6 >= 5.2

Provides

Name Value
geany-abi-71 -
geany-api-228 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package geany_1.27-1_amd64.deb
Source Package geany

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install geany deb package:
    # sudo apt-get install geany

Files

Path
/usr/bin/geany
/usr/lib/x86_64-linux-gnu/libgeany.so
/usr/lib/x86_64-linux-gnu/libgeany.so.0
/usr/lib/x86_64-linux-gnu/libgeany.so.0.0.0
/usr/lib/x86_64-linux-gnu/geany/classbuilder.so
/usr/lib/x86_64-linux-gnu/geany/export.so
/usr/lib/x86_64-linux-gnu/geany/filebrowser.so
/usr/lib/x86_64-linux-gnu/geany/htmlchars.so
/usr/lib/x86_64-linux-gnu/geany/saveactions.so
/usr/lib/x86_64-linux-gnu/geany/splitwindow.so
/usr/lib/x86_64-linux-gnu/pkgconfig/geany.pc
/usr/share/applications/geany.desktop
/usr/share/doc/geany/NEWS.Debian.gz
/usr/share/doc/geany/NEWS.gz
/usr/share/doc/geany/README
/usr/share/doc/geany/TODO
/usr/share/doc/geany/changelog.Debian.gz
/usr/share/doc/geany/copyright
/usr/share/man/man1/geany.1.gz
/usr/share/pixmaps/geany.xpm

Changelog

2016-03-13 - Chow Loong Jin <hyperair@debian.org>
geany (1.27-1) unstable; urgency=medium
* [3d76fe6] Imported Upstream version 1.27
* [e4625fe] Drop Files-Excluded line from d/copyright
waf has been dropped upstream
2015-11-24 - Chow Loong Jin <hyperair@debian.org>
geany (1.26+dfsg-1) unstable; urgency=medium
* [15f8c2e] Update upstream signing key
* [138bf6e] Switch to copyright-format 1.0
* [6e780b0] Add repacksuffix to debian/watch
* [79ec94c] Drop get-orig-source bits.
We're using Files-Excluded now.
* [d7db5d9] Imported Upstream version 1.26+dfsg
2015-11-18 - Chow Loong Jin <hyperair@debian.org>
geany (1.26-1) UNRELEASED; urgency=medium
[ Evgeni Golov ]
* [c628bb0] Imported Upstream version 1.26~git20151108+dfsg
* [aab78c7] update 20_add_debian_specific_filetypes.patch
* [577b467] update 20_use_sensible_browser.patch
* [1c2175b] update 20_load_plugins_from_all_paths.patch
[ Chow Loong Jin ]
* [fac7562] Imported Upstream version 1.26
* [9772408] Drop geany.menu.
We're migrating away from the menu system as per
https://lists.debian.org/debian-devel-announce/2015/09/msg00000.htmla
2015-07-12 - Evgeni Golov <evgeni@debian.org>
geany (1.25+dfsg-1) unstable; urgency=medium
* [f081631] Imported Upstream version 1.25+dfsg
2015-07-05 - Evgeni Golov <evgeni@debian.org>
geany (1.25~20150705git6ebf90a+dfsg-1) experimental; urgency=medium
* [43e8700] Imported Upstream version 1.25~20150705git6ebf90a+dfsg
* [3de0503] make generation of dfsg tarballs more robust
* [2991f3b] drop versioned depends from libgtk2.0-dev, we have old
enough versions
* [39efbfd] refresh patches against Geany 1.25
* [14e42ba] Standards-Version: 3.9.6
* [6e86814] do not install libgeany.la
2014-04-19 - Evgeni Golov <evgeni@debian.org>
geany (1.24.1+dfsg-1) unstable; urgency=medium
* [b5fa158] Imported Upstream version 1.24+dfsg
* [e675c2e] Imported Upstream version 1.24.1+dfsg
* [2dcf5a3] refresh 20_add_debian_specific_filetypes.patch against 1.24
* [2c30296] Standards-Version: 3.9.5
* [38a6aaa] add a lintian override for the templates which contain license texts
* [55e5423] add signature check for downloads
2013-05-20 - Chow Loong Jin <hyperair@debian.org>
geany (1.23.1+dfsg-1) unstable; urgency=low
* [3b1ced4] Imported Upstream version 1.23.1+dfsg
* [b418909] Update debian-branch in gbp.conf
2013-05-10 - Chow Loong Jin <hyperair@debian.org>
geany (1.23+dfsg-2) unstable; urgency=low
* Upload to unstable, fixes FTBFS (Closes: #707368)
* [a472a80] Enable parallel builds
* [17a6378] No-change bump of Standards-Version to 3.9.4
* [ea78f31] Add README.source describing git branch structure
2013-03-13 - Evgeni Golov <evgeni@debian.org>
geany (1.23+dfsg-1) experimental; urgency=low
* [eead8ee] Imported Upstream version 1.23+dfsg
* [6d56635] use debian-branch = experimental
* [d555dec] refresh patches against 1.23
2012-06-20 - Chow Loong Jin <hyperair@debian.org>
geany (1.22+dfsg-2) unstable; urgency=low
* [dd3393d] Bump geany-plugins-common breaks version.
0.21 was the version in which the use of geany-abi-$ABI was added to both
packages.

See Also

Package Description
gearhead-data_1.100-3_all.deb data files for gearhead
gearhead2-data_0.628-1ubuntu1_all.deb data files for gearhead2
gearhead2_0.628-1ubuntu1_amd64.deb roguelike mecha role playing game in space
gearhead_1.100-3_amd64.deb roguelike mecha role playing game
gearman-job-server_1.0.6-5.1build2_amd64.deb Job server for the Gearman distributed job queue
gearman-server_1.12-1_all.deb Gearman distributed job server and Perl interface
gearman-tools_1.0.6-5.1build2_amd64.deb Tools for the Gearman distributed job queue
gearman_1.0.6-5.1build2_all.deb Distributed job queue
geary_0.10.0-1ubuntu1_amd64.deb lightweight email client designed for the GNOME desktop
gebabbel_0.4+repack-0ubuntu3_amd64.deb GPS file conversion and transfer from/to GPS units
geda-doc_1.8.2-5_all.deb GPL EDA -- Electronics design software (documentation)
geda-examples_1.8.2-5_all.deb GPL EDA -- Electronics design software (example designs)
geda-gattrib_1.8.2-5_amd64.deb GPL EDA -- Electronics design software (attribute editor)
geda-gnetlist_1.8.2-5_amd64.deb GPL EDA -- Electronics design software (netlister)
geda-gschem_1.8.2-5_amd64.deb GPL EDA -- Electronics design software (schematic editor)
Advertisement
Advertisement