cobbler_2.4.1-0ubuntu2_all.deb


Advertisement

Description

cobbler - Install server

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name cobbler
Package version 2.4.1
Package release 0ubuntu2
Package architecture all
Package type deb
Installed size 285 B
Download size 59.96 KB
Official Mirror archive.ubuntu.com
Cobbler is a network install server. Cobbler supports PXE, virtualized
installs, and reinstalling existing Linux machines. The last two modes
use a helper tool, 'koan', that integrates with cobbler. Cobbler's
advanced features include importing distributions from DVDs and rsync
mirrors, kickstart templating, integrated yum mirroring, and built-in
DHCP/DNS Management. Cobbler has a Python and XMLRPC API for
integration with other applications. There is also a web interface.

Alternatives

Package Version Architecture Repository
cobbler_2.4.1-0ubuntu2_all.deb 2.4.1 all Ubuntu Universe
cobbler - - -

Requires

Name Value
apache2 -
cobbler-common = 2.4.1-0ubuntu2
debconf >= 0.5
debconf-2.0 -
distro-info -
file-rc >= 0.8.16
hardlink -
libapache2-mod-python -
libapache2-mod-wsgi -
libjs-jquery -
lsb-release -
openssl -
python -
python-twisted -
rsync -
syslinux -
syslinux-common -
sysv-rc >= 2.88dsf-24

Replaces

Name Value
cobbler-common << 2.4.0-1

Download

Type URL
Binary Package cobbler_2.4.1-0ubuntu2_all.deb
Source Package cobbler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cobbler deb package:
    # sudo apt-get install cobbler

Files

Path
/etc/cobbler/cobbler-ubuntu-import.conf
/etc/cobbler/ubuntu-server.preseed
/etc/init/cobbler.conf
/etc/init.d/cobbler
/usr/bin/cobbler
/usr/bin/cobbler-ext-nodes
/usr/bin/cobbler-ubuntu-import
/usr/bin/cobblerd
/usr/bin/ovz-install
/usr/sbin/tftpd
/usr/share/doc/cobbler/README
/usr/share/doc/cobbler/README.Debian
/usr/share/doc/cobbler/changelog.Debian.gz
/usr/share/doc/cobbler/copyright
/usr/share/lintian/overrides/cobbler
/usr/share/man/man1/cobbler-ext-nodes.1.gz
/usr/share/man/man1/cobbler.1.gz
/usr/share/man/man1/cobblerd.1.gz
/usr/share/man/man1/tftpd.1.gz
/var/lib/cobbler/kickstarts/ubuntu-server-arm.seed
/var/lib/cobbler/kickstarts/ubuntu-server.preseed
/var/lib/cobbler/webroot/cobbler/aux/anamon
/var/lib/cobbler/webroot/cobbler/aux/anamon.init
/var/lib/cobbler/webroot/cobbler/svc/services.py

Changelog

2014-02-20 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.1-0ubuntu2) trusty; urgency=medium
* add-trusty.diff: Fix a typo.
2014-02-13 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.1-0ubuntu1) trusty; urgency=medium
* Merge from unreleased debian git
- new upstream release (LP: #1278898)
2012-11-22 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.1-1) UNRELEASED; urgency=low
* New upstream release.
- works with python-django 1.4 and up (LP: #1076290)
- cobbler system edit emits an error on failure (LP: #1015678)
- rework power commands to not allow command injection (LP: #978999)
* Dropped patches:
- 12_fix_dhcp_restart.patch: obsolete.
- 21_cobbler_use_netboot.patch: obsolete
- 34_fix_apache_wont_start.patch: obsolete
- 39_cw_remove_vhost.patch: obsolete
- 42_fix_repomirror_create_sync.patch: upstream
- 43_fix_reposync_env_variable.patch: upstream
- 45_add_gpxe_support.patch: implemented differently upstream
- 46_valid_hostname_for_dns.patch: upstream
- 47_ubuntu_add_codenames.patch: obsolete
- 48_ubuntu_mini_iso_autodetect.patch: obsolete
- 51_koan_grub2_instead_of_grubby.patch: upstream
- 53_sample_preseed_kopts_postinst.patch: upstream
- 54_koan_fix_tree_when_ksmeta.patch: upstream
- 56_ubuntu_arm_generate_pxe_files.patch: upstream
- 57_ubuntu_dnsmasq_domain.patch: obsolete
- 58_fix_egg_cache.patch: upstream
- 60_yaml_safe_load.patch: upstream
- 62_profile_hostname_no_underscore.patch: upstream
- 63_fix_arch_in_mirror_path.patch: upstream
- 64_ubuntu_cobbler_check_disable_loaders.patch: ubuntuism
- 67_ubuntu_online_doc_link.patch: ubuntuism
- 69_issue93_fix_trace_in_write_pxe_file.patch: upstream
- 72-BUGFIX-issue-117-incorrect-permissions-on-files-in-v.patch:
upstream
* rules: Replace the old get-orig-source target with gentarball, which
generates the tarball from the upstream git branch.
* cobbler-common.install: Install the correct gpxe template.
* cobbler.postinst: Enable mod_rewrite.
* Refresh patches.
* rules: Use --list-missing for dh_install.
* Migrate /usr/share/cobbler/webroot to /var/lib/cobbler/webroot.
* rules, cobbler-common.install: Remove some files from the tmpdir that
are not needed in the package(s), and let cobbler-common include
everything left in etc/cobbler.
* control: Bump policy to 3.9.5, no changes.
* cobbler.install, control: Install cobbler(1) with the binary, replace old
cobbler-common.
* cobbler.install: Include ovz-install.
* cobbler-common.install, 65_ubuntu_disable_pxe_snippet.patch: Replace
the patch with snippet/disable_pxe, which is included in cobbler-common.
* python-cobbler.install: Install egg-info.
* cobbler-web.postinst: Generate a random key for SECURITY_KEY in settings.py.
* cobbler{,-web}.post{inst,rm}: Migrate to Apache 2.4. (LP: #1224006)
* cobbler-web: Depend on apache2-utils because postinst uses htpasswd.
* control, copyright: Update upstream url.
* control: Update maintainer.
* compat, control: Bump compat to 9.
* use-django-conf-urls.diff: Backport a fix for new django.
* control, rules: Drop embedded jquery.min.js, depend on the packaged one.
* cobbler.init: Include an initscript.
* add-trusty.diff: Add signature for trusty tahr.
* control: Add Vcs headers.
2013-09-13 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.0-0ubuntu4) saucy; urgency=low
* cobbler-web: Depend on apache2-utils. (LP: #1224887)
2013-09-12 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.0-0ubuntu3) saucy; urgency=low
* cobbler{,-web}.post{inst,rm}: Migrate to Apache 2.4. (LP: #1224006)
2013-08-29 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.0-0ubuntu2) saucy; urgency=low
* cobbler-web.postinst: Generate a random key for SECURITY_KEY in settings.py.
2013-08-29 - Timo Aaltonen <tjaalton@ubuntu.com>
cobbler (2.4.0-0ubuntu1) saucy; urgency=low
* Merge from unreleased debian git.

See Also

Package Description
cobertura_1.9.4.1+dfsg-4_all.deb java tool that calculates the percentage of code accessed by tests
cobra_0.0~git20160117.0.8e91712-1_amd64.deb Tool to generate Cobra-based modern Go CLI application
coccinella_0.96.20-7_all.deb Communication tool (XMPP/Jabber) with a built-in whiteboard
coccinelle-doc_1.0.4.deb-2_all.deb documentation for coccinelle
coccinelle_1.0.4.deb-2_amd64.deb semantic patching tool for C
coco-cpp_20120102-1_amd64.deb Coco/R Compiler Generator (C++ Version)
coco-cs_20110419-5.1_all.deb Coco/R Compiler Generator (C-Sharp Version)
coco-doc_20060919-2_all.deb Documentation for the Coco/R Compiler Generator
coco-java_20110419-3.1_all.deb Coco/R Compiler Generator (Java Version)
code-aster-gui_1.13.1-2_all.deb Graphical user interface for Code_Aster - client
code-aster-mpi-engine_11.5.0+dfsg2-4_amd64.deb Code_Aster finite element program - parallel binary
code-aster-run_1.13.1-2_all.deb Graphical user interface for Code_Aster - server
code-aster-test_11.5.0+dfsg2-4_all.deb Code_Aster finite element program - test files and examples
code-aster_11.5.0+dfsg2-4_amd64.deb Code_Aster finite element program - metapackage
code-of-conduct-signing-assistant_0.3-0ubuntu3_all.deb sign the Ubuntu Code of Conduct easily
Advertisement
Advertisement