chntpw_1.0-1_amd64.deb


Advertisement

Description

chntpw - NT SAM password recovery utility

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: chntpw
Package version: 1.0
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 387 B
Download size: 81.00 KB
Official Mirror: archive.ubuntu.com
This little program provides a way to view information and change user passwords in a Windows NT/2000 user database file. Old passwords need not be known since they are overwritten. In addition it also contains a simple registry editor (same size data writes) and an hex-editor which enables you to fiddle around with bits and bytes in the file as you wish. If you want GNU/Linux bootdisks for offline password recovery you can add this utility to custom image disks or use those provided at the tools homepage.

Alternatives

Requires

    Download

    Binary package: chntpw_1.0-1_amd64.deb
    Source package: chntpw

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install chntpw deb package:
      # sudo apt-get install chntpw

    Files

    • /usr/sbin/chntpw
    • /usr/sbin/reged
    • /usr/sbin/sampasswd
    • /usr/sbin/samusrgrp
    • /usr/share/doc/chntpw/README.txt.gz
    • /usr/share/doc/chntpw/changelog.Debian.gz
    • /usr/share/doc/chntpw/copyright
    • /usr/share/doc/chntpw/regedit.txt.gz
    • /usr/share/man/man8/chntpw.8.gz
    • /usr/share/man/man8/reged.8.gz
    • /usr/share/man/man8/sampasswd.8.gz
    • /usr/share/man/man8/samusrgrp.8.gz

    Changelog

    2014-08-06 - Javier Fernández-Sanguino Peña <jfs@debian.org> chntpw (1.0-1) unstable; urgency=low * Update to latest upstream release, published in 2014-02-01 * debian/rules: Provide also the other binaries built in the sources: reged (Simple Registry Edit Utility for Windows registry hives), sampasswd (SAM database, add or remove user in a group), samusrgrp (SAM database, add or remove user in a group) * debian/samusrgrp.8 debian/reged.8 debian/sampasswd.8: Write manpages for all of the other programs built and included now in the package * debian/chntpw.8: Update the manpage contents based on the program's current -h output. * debian/patches/01_port_to_gcrypt.patch: Update patch since in this release upstream author uses a new define (DOCRYPTO) that enables cryptographic code. This code, that enabled users to change the password, is not enabled by default anymore since it does not work with Windows XP (and later) systems. * debian/patches/11_improve_documentation: Add a new patch to improve the English (by a non-native speaker oh! the irony!) of the HISTORY.txt and MANUAL.txt files, fixing grammar and spelling mistakes, as well as some typos. * debian/changelog: Fix typo and add reference to Ubuntu closed bug * debian/control: - Require debhelp version 5, as per debian/compat * debian/rules: - Update definitions to adapt to this version and upstream's numbering (140201) * Lintian fixes: - Remove statically compiled files from sources (Fixes: source-is-missing) - debian/copyright: point to the versioned license files, not the symlinks since the source does not allow the use of later GPL versions (Fixes: copyright-refers-to-versionless-license-file) - debian/chntpw.8: Fix manpage error (Fixes: manpage-has-errors-from-man) - debian/rules: + Added missing targets build-indep and build-arch (fixes: debian-rules-missing-recommended-target) + Include buildflags.mk provided by dpkg-dev (fixes: hardening-no-relro) - debian/control: + Added ${misc:Depends} (fixes: debhelper-but-no-misc-depends) + Use UTF-8 version of maintainer's second surname (i.e. 'ñ' instead of 'n~') this prevents tools from thinking the uploads are a NMU when they are not (fixes: changelog-should-mention-nmu) + Update Standards Version to 3.9.5, no changes needed (fixes: ancient-standards-version) - debian/docs: Remove HISTORY.txt, it is included as a changelog already (fixes: duplicate-changelog-files)

    2014-01-29 - Javier Fernández-Sanguino Peña <jfs@debian.org> chntpw (0.99.6.110511-1) unstable; urgency=medium * Update to latest upstream release, published in 2011-05-09 (Closes: #615965) (LP: #637623) * Change Build-Dep to use 'libgcrypt11-dev | libgcrypt-dev' instead of 'libgcrypt11-dev | libssl-dev' (Closes: #639350) * debian/patches: - Refreshed patches - Remove patches that do not apply anymore, some of these were incorporated upstream. - Fix 09_improve_robustness, the length of the input call was not being properly calculated, resulting in chntpwd not clearing the password properly. This was fixed in Fedora's patches see: http://pkgs.fedoraproject.org/cgit/chntpw.git/commit/?id=13bf89e14642a0da681384de5b6360178c3f8d57 (Closes: #705292)

    Advertisement
    Advertisement