ampliconnoise_1.29-5build1_amd64.deb


Advertisement

Description

ampliconnoise - removal of noise from 454 sequenced PCR amplicons

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package filename ampliconnoise_1.29-5build1_amd64.deb
Package name ampliconnoise
Package version 1.29
Package release 5build1
Package architecture amd64
Package type deb
Category universe/science
Homepage http://code.google.com/p/ampliconnoise/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 462.13 KB
Installed size 1.33 MB
AmpliconNoise is a package of applications to clean up high-throughput
sequence data.  It consists of three main parts:
Pyronoise - does flowgram-based clustering to spot misreads
SeqNoise - removes PCR point mutations
Perseus - removes PCR chimeras without the need for a set of reference
sequences
Previously there was a standalone "Pyronoise" by the same authors and
this package includes an updated version.  There is also a "Denoiser"
in Qiime which is related but distinct.

Alternatives

Package Version Architecture Repository
ampliconnoise_1.29-5build1_i386.deb 1.29 i386 Ubuntu Universe
ampliconnoise - - -

Requires

Name Value
libc6 >= 2.14
libgsl2 -
libopenmpi1.10 -
mafft -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package ampliconnoise_1.29-5build1_amd64.deb
Source Package ampliconnoise

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ampliconnoise deb package:
    # sudo apt-get install ampliconnoise

Files

Path
/usr/bin/FCluster
/usr/bin/FastaUnique
/usr/bin/NDist
/usr/bin/Perseus
/usr/bin/PerseusD
/usr/bin/PyroDist
/usr/bin/PyroNoise
/usr/bin/PyroNoiseA
/usr/bin/PyroNoiseM
/usr/bin/SeqDist
/usr/bin/SeqNoise
/usr/bin/SplitClusterClust
/usr/bin/SplitClusterEven
/usr/share/ampliconnoise/Data/LookUp.dat
/usr/share/ampliconnoise/Data/LookUp_E123.dat
/usr/share/ampliconnoise/Data/LookUp_Titanium.dat
/usr/share/ampliconnoise/Data/Tran.dat
/usr/share/ampliconnoise/Data/TranN.dat
/usr/share/ampliconnoise/Data/Tran_D.dat
/usr/share/ampliconnoise/Data/Tran_V6.dat
/usr/share/ampliconnoise/Scripts/CSV.pl
/usr/share/ampliconnoise/Scripts/Class.pl
/usr/share/ampliconnoise/Scripts/Clean.sh
/usr/share/ampliconnoise/Scripts/Clean360.pl
/usr/share/ampliconnoise/Scripts/CleanAcyclic.pl
/usr/share/ampliconnoise/Scripts/CleanBoth.pl
/usr/share/ampliconnoise/Scripts/CleanBothM.pl
/usr/share/ampliconnoise/Scripts/CleanMinMax.pl
/usr/share/ampliconnoise/Scripts/CleanMinMax.sh
/usr/share/ampliconnoise/Scripts/ConvertDatFasta.pl
/usr/share/ampliconnoise/Scripts/CountFasta.pl
/usr/share/ampliconnoise/Scripts/CountSequences.pl
/usr/share/ampliconnoise/Scripts/Diversity.pl
/usr/share/ampliconnoise/Scripts/FilterGoodClass.pl
/usr/share/ampliconnoise/Scripts/FlowsFA.pl
/usr/share/ampliconnoise/Scripts/FlowsFA360.pl
/usr/share/ampliconnoise/Scripts/FlowsMinMax.pl
/usr/share/ampliconnoise/Scripts/Join.pl
/usr/share/ampliconnoise/Scripts/Map.pl
/usr/share/ampliconnoise/Scripts/MedianS.sh
/usr/share/ampliconnoise/Scripts/Parse.pl
/usr/share/ampliconnoise/Scripts/ParseBoth.pl
/usr/share/ampliconnoise/Scripts/Qiime.pl
/usr/share/ampliconnoise/Scripts/Qiime_OTU.pl
/usr/share/ampliconnoise/Scripts/Qiime_Typical.pl
/usr/share/ampliconnoise/Scripts/RunBoth.sh
/usr/share/ampliconnoise/Scripts/RunBothFLX.sh
/usr/share/ampliconnoise/Scripts/RunFLX.sh
/usr/share/ampliconnoise/Scripts/RunTitanium.sh
/usr/share/ampliconnoise/Scripts/RunTitaniumA.sh
/usr/share/ampliconnoise/Scripts/RunTitaniumFast.sh
/usr/share/ampliconnoise/Scripts/RunTitaniumWeb.sh
/usr/share/ampliconnoise/Scripts/Split.pl
/usr/share/ampliconnoise/Scripts/SplitKeys.pl
/usr/share/ampliconnoise/Scripts/SplitKeysBoth.pl
/usr/share/ampliconnoise/Scripts/SplitKeysFlower.pl
/usr/share/ampliconnoise/Scripts/Sub.pl
/usr/share/ampliconnoise/Scripts/Subsample.sh
/usr/share/ampliconnoise/Scripts/SubsampleDat.pl
/usr/share/ampliconnoise/Scripts/Truncate.pl
/usr/share/ampliconnoise/Scripts/Typical.pl
/usr/share/doc-base/ampliconnoise
/usr/share/doc/ampliconnoise/Doc.pdf
/usr/share/doc/ampliconnoise/README.Debian
/usr/share/doc/ampliconnoise/changelog.Debian.gz
/usr/share/doc/ampliconnoise/copyright
/usr/share/man/man1/FCluster.1.gz
/usr/share/man/man1/FastaUnique.1.gz
/usr/share/man/man1/NDist.1.gz
/usr/share/man/man1/Perseus.1.gz
/usr/share/man/man1/PerseusD.1.gz
/usr/share/man/man1/PyroDist.1.gz
/usr/share/man/man1/PyroNoise.1.gz
/usr/share/man/man1/PyroNoiseA.1.gz
/usr/share/man/man1/PyroNoiseM.1.gz
/usr/share/man/man1/SeqDist.1.gz
/usr/share/man/man1/SeqNoise.1.gz
/usr/share/man/man1/SplitClusterClust.1.gz
/usr/share/man/man1/SplitClusterEven.1.gz
/usr/share/man/man1/ampliconnoise.1.gz

Changelog

2016-02-07 - Matthias Klose <doko@ubuntu.com>
ampliconnoise (1.29-5build1) xenial; urgency=medium
* No-change rebuild for openmpi transition.
2015-12-18 - Andreas Tille <tille@debian.org>
ampliconnoise (1.29-5) unstable; urgency=medium
* Fix Mayhem issues by making reading fasta files more robust
Closes: #715593, #715594
* Fix remaining hardening issue
2015-12-07 - Andreas Tille <tille@debian.org>
ampliconnoise (1.29-4) unstable; urgency=medium
[ Bas Couwenberg ]
* Drop explicit dependency on libgsl0ldbl, rely on ${shlibs:Depends}.
Closes: #807177
[ Andreas Tille ]
* Verified Mayhem bugs (bugs in Perseus and PerseusD remain)
Closes: #715585
2015-12-06 - Andreas Tille <tille@debian.org>
ampliconnoise (1.29-3) unstable; urgency=medium
[ Bas Couwenberg ]
* Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
Closes: #804246
[ Andreas Tille ]
* cme fix dpkg-control
* DEP5 fix
2014-02-25 - Andreas Tille <tille@debian.org>
ampliconnoise (1.29-2) unstable; urgency=low
[ Arthur Marble ]
* Fix the FTBFS with clang:
- Fixed the non-void function should return a value in
FCluster/FCluster.c
SplitClusterEven/SplitClusterEven.c
Closes: #740029
[ James McCoy ]
* Moved debian/upstream to debian/upstream/metadata
2014-01-12 - Andreas Tille <tille@debian.org>
ampliconnoise (1.29-1) unstable; urgency=medium
* New upstream version
* debian/control:
- cme fix dpkg-control
- shorter short decription
2013-07-30 - Andreas Tille <tille@debian.org>
ampliconnoise (1.28-1) unstable; urgency=low
* New upstream version uploaded to Debian
* debian/control
- cme fix dpkg-control
- no need to Build-Depend from quilt
- debhelper 9
- Priority: optional
- Normalised Vcs fields
- Remove duplicated publication information from
long description
* debian/get-orig-source: Removed because upstream
stripped off their tarball
* debian/README.source: Removed because it became now
unneeded.
* debian/doc-base: created
* debian/rules:
- do not compress pdf files
* debian/patches/hardening.patch: Propagate hardening options
2013-06-27 - Tim Booth <tbooth@ceh.ac.uk>
ampliconnoise (1.28-0ubuntu2) precise; urgency=low
* Apply patch for segfault on attempt to load non-FASTA files 
2013-03-14 - Tim Booth <tbooth@ceh.ac.uk>
ampliconnoise (1.28-0ubuntu1) precise; urgency=low
* New upstream
* Upstream tarball now free of junk so using pristine version
* MPI versions of most things have now vanished
2012-05-16 - Andreas Tille <tille@debian.org>
ampliconnoise (1.25-2) UNRELEASED; urgency=low
* debian/upstream: Add citation information
* debian/watch: Fixed googlecode URL
* debian/copyright:
- DEP5
- Add Files-Excluded to document what was removed from original source

See Also

Package Description
amqp-specs_1-0r0-3_all.deb specs for the Advanced Message Queuing Protocol (AMQP)
amqp-tools_0.7.1-1_amd64.deb Command-line utilities for interacting with AMQP servers
ams_2.1.1-1build1_amd64.deb Realtime modular synthesizer for ALSA
amsynth_1.5.1-2build2_amd64.deb two oscillator software synthesizer
amtterm_1.4-1_amd64.deb Serial-over-lan (sol) client for Intel AMT, console version
amule-common_2.4.0~git20151120.0023527bc2-1ubuntu1_all.deb common files for the rest of aMule packages
amule-daemon_2.4.0~git20151120.0023527bc2-1ubuntu1_amd64.deb non-graphic version of aMule, a client for the eD2k and Kad networks
amule-emc_0.5.2-3_amd64.deb lists ed2k links inside emulecollection files
amule-gnome-support_2.4.0~git20151120.0023527bc2-1ubuntu1_all.deb ed2k links handling support for GNOME web browsers
amule-utils-gui_2.4.0~git20151120.0023527bc2-1ubuntu1_amd64.deb graphic utilities for aMule
amule-utils_2.4.0~git20151120.0023527bc2-1ubuntu1_amd64.deb utilities for aMule (command-line version)
amule_2.4.0~git20151120.0023527bc2-1ubuntu1_amd64.deb client for the eD2k and Kad networks, like eMule
an_1.2-1build1_amd64.deb very fast anagram generator
anagramarama-data_0.3-0ubuntu5_all.deb fast paced anagram puzzle game using SDL (data files)
anagramarama_0.3-0ubuntu5_amd64.deb fast paced anagram puzzle game using SDL
Advertisement
Advertisement