python-cliff_1.15.0-2ubuntu2_all.deb


Advertisement

Description

python-cliff - command line interface formulation framework - Python 2.x

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main i386
Package filename python-cliff_1.15.0-2ubuntu2_all.deb
Package name python-cliff
Package version 1.15.0
Package release 2ubuntu2
Package architecture all
Package type deb
Category python
Homepage https://github.com/dreamhost/cliff
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 22.74 KB
Installed size 131.00 KB
Cliff is a framework for building command line programs. It uses plugins to
define sub-commands, output formatters, and other extensions.
The cliff framework is meant to be used to create multi-level commands such as
Subversion and git, where the main program handles some basic argument parsing
and then invokes a sub-command to do the work.
This package provides the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-cliff_1.15.0-2ubuntu2_all.deb 1.15.0 all Ubuntu Main
python-cliff - - -

Requires

Name Value
python-cmd2 -
python-pbr >= 1.3
python-prettytable -
python-pyparsing -
python-six >= 1.9.0
python-stevedore >= 1.5.0
python-unicodecsv -
python-yaml -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-cliff_1.15.0-2ubuntu2_all.deb
Source Package python-cliff

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-cliff deb package:
    # sudo apt-get install python-cliff

Files

Path
/usr/lib/python2.7/dist-packages/cliff/__init__.py
/usr/lib/python2.7/dist-packages/cliff/app.py
/usr/lib/python2.7/dist-packages/cliff/command.py
/usr/lib/python2.7/dist-packages/cliff/commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/complete.py
/usr/lib/python2.7/dist-packages/cliff/display.py
/usr/lib/python2.7/dist-packages/cliff/help.py
/usr/lib/python2.7/dist-packages/cliff/interactive.py
/usr/lib/python2.7/dist-packages/cliff/lister.py
/usr/lib/python2.7/dist-packages/cliff/show.py
/usr/lib/python2.7/dist-packages/cliff/utils.py
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/cliff-1.15.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/cliff/formatters/__init__.py
/usr/lib/python2.7/dist-packages/cliff/formatters/base.py
/usr/lib/python2.7/dist-packages/cliff/formatters/commaseparated.py
/usr/lib/python2.7/dist-packages/cliff/formatters/json_format.py
/usr/lib/python2.7/dist-packages/cliff/formatters/shell.py
/usr/lib/python2.7/dist-packages/cliff/formatters/table.py
/usr/lib/python2.7/dist-packages/cliff/formatters/value.py
/usr/lib/python2.7/dist-packages/cliff/formatters/yaml_format.py
/usr/lib/python2.7/dist-packages/cliff/tests/__init__.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_app.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_command.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_complete.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_csv.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_json.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_shell.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_table.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_value.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_yaml.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_help.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_interactive.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_lister.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_show.py
/usr/lib/python2.7/dist-packages/cliff/tests/utils.py
/usr/share/doc/python-cliff/changelog.Debian.gz
/usr/share/doc/python-cliff/copyright

Changelog

2016-04-06 - Martin Pitt <martin.pitt@ubuntu.com>
python-cliff (1.15.0-2ubuntu2) xenial; urgency=medium
* Add missing python[3]-setuptools build dep to fix FTBFS.
2016-01-08 - Colin Watson <cjwatson@ubuntu.com>
python-cliff (1.15.0-2ubuntu1) xenial; urgency=medium
* Resynchronise with Debian.  Remaining changes:
- Fix Python 3.5 compatibility.
- Remove unnecessary dependency on argparse.
* Cherry-pick from upstream: only use unicodecsv for Python 2.x.
2015-11-20 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-2) unstable; urgency=medium
* Added missing build-depends on python{3,}-yaml.
2015-10-15 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-1) unstable; urgency=medium
* New upstream release.
* Uploading to unstable.
* Moved the package to PKG OpenStack as I lost write access to the DPMT.
* Added build-depends openstack-pkg-tools.
* Added export OSLO_PACKAGE_VERSION.
2016-01-08 - Colin Watson <cjwatson@ubuntu.com>
python-cliff (1.14.0-1ubuntu2) xenial; urgency=medium
* Remove unnecessary dependency on argparse (closes: #810126).
2015-09-11 - Barry Warsaw <barry@ubuntu.com>
python-cliff (1.14.0-1ubuntu1) wily; urgency=medium
* d/patches/python35-compat.patch: Fix Python 3.5 compatibility.
(LP: #1491888)
2015-09-02 - Thomas Goirand <zigo@debian.org>
python-cliff (1.14.0-1) experimental; urgency=medium
* New upstream release.
* Fixed (build-)depends for this release.
* Removed skip-test.patch now useless.
2015-07-14 - Thomas Goirand <zigo@debian.org>
python-cliff (1.13.0-1) experimental; urgency=medium
[ Thomas Goirand ]
* Updated debian/copyright.
[ Corey Bryant ]
* New upstream release:
- d/control: Align (Build-)Depends with upstream.
- d/p/skip-tests.patch: Skip failing test.
[ James Page ]
* Update watch file to use Debian pypi redirector.
2015-04-15 - Thomas Goirand <zigo@debian.org>
python-cliff (1.10.1-1) experimental; urgency=medium
* New upstream release.
* Fixed calls of nose.
* Also testing with nose and python3.
* Standards-Version is now 3.9.6.
2014-09-28 - Jan Dittberner <jandd@debian.org>
python-cliff (1.7.0-2) unstable; urgency=medium
* debian/control: add versions python{,3}-six and python{,3}-
prettytable Depends (Closes: #752741)

See Also

Package Description
python-cmd2_0.6.8-1_all.deb enhanced Python cmd module - Python 2.x
python-compressor_2.0-1ubuntu1_all.deb Compresses linked, inline JS or CSS - Python 2.7 transition package
python-concurrent.futures_3.0.5-1_all.deb backport of concurrent.futures package from Python 3.2
python-configobj-doc_5.0.6-2_all.deb simple but powerful config file reader and writer (documentation)
python-configobj_5.0.6-2_all.deb simple but powerful config file reader and writer for Python 2
python-contextlib2_0.5.1-1_all.deb Backport and enhancements for the contextlib module - Python 2.7
python-croniter_0.3.8-1_all.deb provides iteration for datetime object with cron like format - Python 2.x
python-crypto-doc_2.6.1-6build1_all.deb cryptographic algorithms and protocols for Python (documentation)
python-crypto_2.6.1-6build1_i386.deb cryptographic algorithms and protocols for Python
python-cryptography-doc_1.2.3-1_all.deb Python library exposing cryptographic recipes and primitives (documentation)
python-cryptography_1.2.3-1_i386.deb Python library exposing cryptographic recipes and primitives (Python 2)
python-csscompressor_0.9.4-2_all.deb Python port of YUI CSS Compressor - Python 2.7
python-dateutil_2.4.2-1_all.deb powerful extensions to the standard datetime module
python-dbus-dev_1.2.0-3_all.deb main loop integration development files for python-dbus
python-dbus-doc_1.2.0-3_all.deb Documentation for the D-Bus Python interface
Advertisement
Advertisement