libparse-yapp-perl_1.05-12_all.deb


Advertisement

Description

libparse-yapp-perl - Perl module for creating fully reentrant LALR parser OO Perl modules

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main i386
Package filename libparse-yapp-perl_1.05-12_all.deb
Package name libparse-yapp-perl
Package version 1.05
Package release 12
Package architecture all
Package type deb
Category perl
Homepage http://search.cpan.org/dist/Parse-Yapp/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 49.88 KB
Installed size 200.00 KB
This is a collection of modules that let you generate and use yacc
like thread safe (reentrant) parsers with perl object oriented
interface.
The script yapp is a front-end to the Parse::Yapp module and let you
easily create a Perl OO parser from an input grammar file.

Alternatives

Package Version Architecture Repository
libparse-yapp-perl_1.05-12_all.deb 1.05 all Ubuntu Main
libparse-yapp-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libparse-yapp-perl_1.05-12_all.deb
Source Package libparse-yapp-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libparse-yapp-perl deb package:
    # sudo apt-get install libparse-yapp-perl

Files

Path
/usr/bin/yapp
/usr/share/doc/libparse-yapp-perl/changelog.Debian.gz
/usr/share/doc/libparse-yapp-perl/changelog.gz
/usr/share/doc/libparse-yapp-perl/copyright
/usr/share/doc/libparse-yapp-perl/examples/Calc.yp
/usr/share/doc/libparse-yapp-perl/examples/YappParse.yp.gz
/usr/share/man/man1/yapp.1p.gz
/usr/share/man/man3/Parse::Yapp.3pm.gz
/usr/share/perl5/Parse/Yapp.pm
/usr/share/perl5/Parse/Yapp/Driver.pm
/usr/share/perl5/Parse/Yapp/Grammar.pm
/usr/share/perl5/Parse/Yapp/Lalr.pm
/usr/share/perl5/Parse/Yapp/Options.pm
/usr/share/perl5/Parse/Yapp/Output.pm
/usr/share/perl5/Parse/Yapp/Parse.pm

Changelog

2010-01-31 - Ansgar Burchardt <ansgar@43-1.org>
libparse-yapp-perl (1.05-12) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza).
* Set Maintainer to Debian Perl Group.
* Use dist-based URL in debian/watch.
* Remove debian/libparse-yapp-perl.docs, don't install README any more.
* Remove unneeded debian/libparse-yapp-perl.install.
* Revert POD changes in upstream code.
* Split out changes to Makefile.PL into a patch.
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Ansgar Burchardt ]
* Refresh rules for debhelper 7.
* Convert debian/copyright to proposed machine-readable format.
* Use source format 3.0 (quilt).
* debian/control: Remove duplicate Section, Priority fields from binary
package stanza.
* debian/watch: Use extended regular expression to match upstream releases.
* Correct POD syntax errors.
+ new patch: pod-errors.patch
* Correct spelling errors pointed out by lintian.
+ new patch: spelling.patch
* Bump Standards-Version to 3.8.4.
* Add myself to Uploaders.
2007-07-03 - Jay Bonci <jaybonci@debian.org>
libparse-yapp-perl (1.05-11) unstable; urgency=low
* Update debian/rules to use $(CURDIR) instead of $(PWD) (Closes: #390479) 
* Added check against the Makefile before running make clean for lintian
2006-06-04 - Jay Bonci <jaybonci@debian.org>
libparse-yapp-perl (1.05-10) unstable; urgency=low
* Spellchecked man page (Closes: #322108) 
* Policy version bump to 3.7.2.0 (No other changes)
* Changed Build-Depends-Indep on debhelper to be Build-Depends
2005-07-12 - Jay Bonci <jaybonci@debian.org>
libparse-yapp-perl (1.05-9) unstable; urgency=low
* New maintainer (Closes: #313635)
* Policy-version bump (no other changes)
* Changed watchfile to be more universal. Also, enable uupdate
* Gave more specific URL in copyright
* Updated to use my standard rules template
2004-11-05 - Luk Claes <luk.claes@ugent.be>
libparse-yapp-perl (1.05-8) unstable; urgency=low
* lib/Parse/Yapp.pm: =items in documentation (closes: #263848)
* debian/watch: added
* yapp & lib/Parse/Yapp.pm: - as minus in manpages
2003-10-22 - Jaldhar H. Vyas <jaldhar@debian.org>
libparse-yapp-perl (1.05-7) unstable; urgency=low
* New maintainer (closes: #210212)
* Uploaded for Luk by Jaldhar H. Vyas <jaldhar@debian.org>
2003-07-26 - Ardo van Rangelrooij <ardo@debian.org>
libparse-yapp-perl (1.05-6) unstable; urgency=low
* debian/rules: moved debhelper compatibility level setting to
'debian/compat' per latest debhelper best practices
* debian/control: updated sections according to latest archive changes:
- 'libparse-yapp-perl' from 'interpreters' to 'perl'
* debian/control: changed build dependency on 'debhelper' to '(>= 4.1)'
* debian/control: upgraded to Debian Policy 3.6.0 (no changes)
2002-08-04 - Ardo van Rangelrooij <ardo@debian.org>
libparse-yapp-perl (1.05-5) unstable; urgency=low
* debian/rules: added erroneously removed 'dh_testroot' to 'binary-indep'
2002-08-04 - Ardo van Rangelrooij <ardo@debian.org>
libparse-yapp-perl (1.05-4) unstable; urgency=low
* debian/rules: upgraded to debhelper v4
* debian/control: changed build dependency on debhelper accordingly
* debian/rules: migrated from 'dh_movefiles' to 'dh_install'
* debian/rules: split off 'install' target from 'binary-indep' target
* debian/copyright: added pointer to license
2002-05-19 - Ardo van Rangelrooij <ardo@debian.org>
libparse-yapp-perl (1.05-3) unstable; urgency=low
* debian/examples: added YappParse.yp per request of upstream author
(thanks Francois Desarmenien <francois@fdesar.net>)

See Also

Package Description
libparted-dev_3.2-15_i386.deb disk partition manipulator - development files
libparted-fs-resize0_3.2-15_i386.deb disk partition manipulator - shared FS resizing library
libparted0-dev_3.2-15_all.deb disk partition manipulator - transitional package
libparted2_3.2-15_i386.deb disk partition manipulator - shared library
libpath-utils-dev_0.5.0-1_i386.deb Development files for libpath_utils
libpath-utils1_0.5.0-1_i386.deb Filesystem Path Utilities
libpathplan4_2.38.0-12ubuntu2_i386.deb rich set of graph drawing tools - pathplan library
libpcap-dev_1.7.4-2_all.deb development library for libpcap (transitional package)
libpcap0.8-dev_1.7.4-2_i386.deb development library and header files for libpcap0.8
libpcap0.8_1.7.4-2_i386.deb system interface for user-level packet capture
libpci-dev_3.3.1-1.1ubuntu1_i386.deb Linux PCI Utilities (development files)
libpci3_3.3.1-1.1ubuntu1_i386.deb Linux PCI Utilities (shared library)
libpciaccess-dev_0.13.4-1_i386.deb Generic PCI access library for X - development files
libpciaccess0_0.13.4-1_i386.deb Generic PCI access library for X
libpcre16-3_8.38-3.1_i386.deb Perl 5 Compatible Regular Expression Library - 16 bit runtime files
Advertisement
Advertisement