liblocale-gettext-perl_1.07-1build1_i386.deb


Advertisement

Description

liblocale-gettext-perl - module using libc functions for internationalization in Perl

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main i386
Package filename liblocale-gettext-perl_1.07-1build1_i386.deb
Package name liblocale-gettext-perl
Package version 1.07
Package release 1build1
Package architecture i386
Package type deb
Category perl
Homepage https://metacpan.org/release/gettext
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 17.17 KB
Installed size 54.00 KB
The Locale::gettext module permits access from perl to the gettext() family of
functions for retrieving message strings from databases constructed
to internationalize software.
It provides gettext(), dgettext(), dcgettext(), textdomain(),
bindtextdomain(), bind_textdomain_codeset(), ngettext(), dcngettext()
and dngettext().

Alternatives

Package Version Architecture Repository
liblocale-gettext-perl_1.07-1build1_amd64.deb 1.07 amd64 Ubuntu Main
liblocale-gettext-perl - - -

Requires

Name Value
libc6 >= 2.2
perl-base >= 5.22.1-1
perlapi-5.22.1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package liblocale-gettext-perl_1.07-1build1_i386.deb
Source Package liblocale-gettext-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblocale-gettext-perl deb package:
    # sudo apt-get install liblocale-gettext-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.22/Locale/gettext.pm
/usr/lib/i386-linux-gnu/perl5/5.22/auto/Locale/gettext/gettext.so
/usr/share/doc/liblocale-gettext-perl/README.Debian
/usr/share/doc/liblocale-gettext-perl/README.gz
/usr/share/doc/liblocale-gettext-perl/changelog.Debian.gz
/usr/share/doc/liblocale-gettext-perl/copyright
/usr/share/man/man3/Locale::gettext.3pm.gz

Changelog

2015-12-17 - Colin Watson <cjwatson@ubuntu.com>
liblocale-gettext-perl (1.07-1build1) xenial; urgency=medium
* Rebuild for Perl 5.22.1.
2015-09-28 - Niko Tyni <ntyni@debian.org>
liblocale-gettext-perl (1.07-1) unstable; urgency=medium
* Imported Upstream version 1.07.
+ fixes test failures caused by $LANGUAGE being set (Closes: #796152)
+ remove obsolete debian/patches
* Add debian/upstream/metadata.
2015-06-05 - Niko Tyni <ntyni@debian.org>
liblocale-gettext-perl (1.05-9) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Raphaël Hertzog ]
* Drop myself from Uploaders.
[ Axel Beckert ]
* Fix broken MetaCPAN URL in debian/copyright. Thanks DUCK!
[ Niko Tyni ]
* Make the package autopkgtestable
* Mention the module name in the long description
2014-03-06 - intrigeri <intrigeri@debian.org>
liblocale-gettext-perl (1.05-8) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
* Remove trailing file name from MetaCPAN URL (Thanks DUCK!)
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ intrigeri ]
* Declare compatibility with Standards-Version 3.9.5.
* Bump debhelper compat level to 9.
* Adjust versioned Build-Depends on debhelper to (>= 9.20120312~)
to get hardening build flags.
2011-07-16 - gregor herrmann <gregoa@debian.org>
liblocale-gettext-perl (1.05-7) unstable; urgency=low
[ Steve McIntyre ]
* Configure perl C compilation for cross builds
+ Initial patch from Peter Pearse <peter.pearse@linaro.org>
Closes: #633949
[ gregor herrmann ]
* Improvements to Steve's patch by Ansgar.
* Switch to source format 3.0 (quilt).
* Add /me to Uploaders.
* Set Standards-Version to 3.9.2 (no changes).
* Bump debhelper compatibility level to 8.
* debian/copyright: DEP5 format.
2009-09-29 - Raphaël Hertzog <hertzog@debian.org>
liblocale-gettext-perl (1.05-6) unstable; urgency=low
* The -d option of dh_perl was lost by mistake while converting to tiny
rules files. Re-add it. Closes: #548860
2009-09-20 - Raphaël Hertzog <hertzog@debian.org>
liblocale-gettext-perl (1.05-5) unstable; urgency=low
[ gregor herrmann ]
* Add debian/README.source to document quilt usage, as required by
Debian Policy since 3.8.0.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Raphaël Hertzog ]
* Update my name in Uploaders to add the accented character.
* Switch to debhelper 7 tiny rules file and compat mode.
* Update Standards-Version to 3.8.3 (no changes needed).
* Update meta-information in patches files to comply with DEP-3.
* Update Homepage field.
* Update my email in README.debian.
2008-05-07 - Raphael Hertzog <hertzog@debian.org>
liblocale-gettext-perl (1.05-4) unstable; urgency=low
* Put ${perl:Depends} back into Pre-Depends. The revert in 1.05-2 was
wrong. The pre-dependency is needed to make sure that the right perl
version is unpacked before liblocale-gettext-perl so that any
script/module using Locale::Gettext (still) work once this module
has been unpacked. This is particulary important for transitions like
perl-5.8 -> perl-5.10 (see #479220 for example).
* New patch debian/patches/compatibility-with-POSIX-module.diff so that
Locale::Gettext re-exports the LC_* constants coming from POSIX instead
of those coming from its own XS implementation. Closes: #479803

See Also

Package Description
liblockfile-bin_1.09-6ubuntu1_i386.deb support binaries for and cli utilities based on liblockfile
liblockfile-dev_1.09-6ubuntu1_i386.deb Development library for liblockfile
liblockfile1_1.09-6ubuntu1_i386.deb NFS-safe locking library
liblouis-data_2.6.4-2_all.deb Braille translation library - data
liblouis-dev_2.6.4-2_i386.deb Braille translation library - static libs and headers
liblouis9_2.6.4-2_i386.deb Braille translation library - shared libs
liblouisutdml-bin_2.5.0-3_i386.deb Braille UTDML translation utilities
liblouisutdml-data_2.5.0-3_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.5.0-3_i386.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.5.0-3_all.deb Braille UTDML translation library - java bindings documentation
liblouisutdml6_2.5.0-3_i386.deb Braille UTDML translation library - shared libs
liblpsolve55-dev_5.5.0.13-7build2_i386.deb Solve (mixed integer) linear programming problems - library
liblqr-1-0-dev_0.4.2-2_i386.deb converts plain array images into multi-size representation (developments files)
liblqr-1-0_0.4.2-2_i386.deb converts plain array images into multi-size representation
liblrm2-dev_1.0.12~rc1+hg2777-1.2_i386.deb Reusable cluster development files -- liblrm
Advertisement
Advertisement