libaal-dev_1.0.6-1_i386.deb


Advertisement

Description

libaal-dev - Reiser4's application abstraction library: Development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main i386
Package filename libaal-dev_1.0.6-1_i386.deb
Package name libaal-dev
Package version 1.0.6
Package release 1
Package architecture i386
Package type deb
Category libdevel
Homepage http://sourceforge.net/projects/reiser4/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.72 KB
Installed size 154.00 KB
These are the development files for libaal.
They are part of the Reiser4's filesystem support tools.

Alternatives

Package Version Architecture Repository
libaal-dev_1.0.6-1_amd64.deb 1.0.6 amd64 Ubuntu Main
libaal-dev - - -

Requires

Name Value
libc-dev -
libc6-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libaal-dev_1.0.6-1_i386.deb
Source Package libaal

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libaal-dev deb package:
    # sudo apt-get install libaal-dev

Files

Path
/usr/include/aal/bitops.h
/usr/include/aal/block.h
/usr/include/aal/debug.h
/usr/include/aal/device.h
/usr/include/aal/endian.h
/usr/include/aal/exception.h
/usr/include/aal/file.h
/usr/include/aal/gauge.h
/usr/include/aal/hash.h
/usr/include/aal/libaal.h
/usr/include/aal/list.h
/usr/include/aal/malloc.h
/usr/include/aal/math.h
/usr/include/aal/print.h
/usr/include/aal/stream.h
/usr/include/aal/string.h
/usr/include/aal/types.h
/usr/include/aal/ui.h
/usr/include/aal/unaligned.h
/usr/lib/i386-linux-gnu/libaal-minimal.a
/usr/lib/i386-linux-gnu/libaal.a
/usr/share/aclocal/libaal.m4
/usr/share/doc/libaal-dev/CREDITS
/usr/share/doc/libaal-dev/THANKS
/usr/share/doc/libaal-dev/changelog.Debian.gz
/usr/share/doc/libaal-dev/copyright

Changelog

2014-08-02 - Felix Zielcke <fzielcke@z-51.de>
libaal (1.0.6-1) unstable; urgency=medium
* New upstream release
2014-01-04 - Felix Zielcke <fzielcke@z-51.de>
libaal (1.0.5-6) unstable; urgency=low
* Convert to source format 3.0 (quilt).
* debian/patches/bitops.c.diff: Make the bit_t change from Luk a patch
file.
* Remove DMUA field.
* Update to debhelper compat level 9.
* Update to policy 3.9.5.
* Add a ${misc:Depends} to libaal-dev.
* Switch rules file to use dh command.
- Use dh_autoreconf to update libtool and conig,{sub,guess} at
build time. (Closes: #700357)
* Update watch file.
* Build and ship the shared library.
* Set homepage to the sourceforge project page.
* Update description of libaal-dev.
2012-07-03 - Luk Claes <luk@debian.org>
libaal (1.0.5-5.1) unstable; urgency=low
* Non-maintainer upload.
* Use bit_t instead of int (Closes: #632632).
2009-08-26 - Felix Zielcke <fzielcke@z-51.de>
libaal (1.0.5-5) unstable; urgency=low
* Remove libaal.la and libaal-minimal.la.
* Add a Breaks: libreiser4-dev (<< 1.0.7-3).
* Update Standards-Version to 3.8.3.
* Use debhelper compat level 7.
2009-02-09 - Felix Zielcke <fzielcke@z-51.de>
libaal (1.0.5-4) unstable; urgency=low
* New maintainer (Closes: #483026)
* Add a debian/watch file.
* Change download url in debian/copyright to the kernel.org one.
2009-02-06 - Barry deFreese <bdefreese@debian.org>
libaal (1.0.5-3) unstable; urgency=low
* QA upload.
+ Set maintainer to Debian QA Group <packages@qa.debian.org>.
* Remove dead Homepage URL from package description.
* Make clean not ignore errors.
* Add appropriate Copyright holder to debian/copyright.
* Bump debhelper build-dep and compat to 5.
* Bump Standards Version to 3.8.0.
2006-09-29 - Domenico Andreoli <cavok@debian.org>
libaal (1.0.5-2) unstable; urgency=low
* Minimal library (required to add reiser4 support to grub) is now
built using --enable-libminimal configure switch.
2005-08-18 - Domenico Andreoli <cavok@debian.org>
libaal (1.0.5-1) unstable; urgency=low
* New upstream release. 
2005-02-25 - Domenico Andreoli <cavok@debian.org>
libaal (1.0.4-1) unstable; urgency=low
* New upstream release. 
2005-01-20 - Domenico Andreoli <cavok@debian.org>
libaal (1.0.3-2) unstable; urgency=low
* Applied patch provided by Vitaly Fertman in bug report #289747.

See Also

Package Description
libabw-0.1-1v5_0.1.1-2ubuntu2_i386.deb library for reading and writing AbiWord(tm) documents
libabw-dev_0.1.1-2ubuntu2_i386.deb library for reading and writing AbiWord(tm) documents -- development
libaccount-plugin-1.0-0_0.1.8+16.04.20160201-0ubuntu1_i386.deb libaccount-plugin for Unity Control Center
libaccount-plugin-1.0-dev_0.1.8+16.04.20160201-0ubuntu1_i386.deb libaccount-plugin for Unity Control Center - devel
libaccount-plugin-1.0-doc_0.1.8+16.04.20160201-0ubuntu1_all.deb libaccount-plugin for Unity Control Center - Developer Docs
libaccount-plugin-generic-oauth_0.12+16.04.20160126-0ubuntu1_i386.deb GNOME Control Center account plugin for single signon - generic OAuth
libaccount-plugin-google_0.12+16.04.20160126-0ubuntu1_i386.deb GNOME Control Center account plugin for single signon - Google Auth
libaccounts-glib-dev_1.21+16.04.20160222-0ubuntu1_i386.deb library for single signon - development files
libaccounts-glib-doc_1.21+16.04.20160222-0ubuntu1_all.deb library for single signon - documentation
libaccounts-glib0_1.21+16.04.20160222-0ubuntu1_i386.deb library for single signon
libaccounts-qt-doc_1.14+16.04.20151106.1-0ubuntu1_all.deb QT library for single sign on - documentation
libaccounts-qt5-1_1.14+16.04.20151106.1-0ubuntu1_i386.deb QT library for single sign on
libaccounts-qt5-dev_1.14+16.04.20151106.1-0ubuntu1_i386.deb QT library for single sign on - development files
libaccountsservice-dev_0.6.40-2ubuntu10_i386.deb query and manipulate user account information - header files
libaccountsservice-doc_0.6.40-2ubuntu10_all.deb query and manipulate user account information - documentation
Advertisement
Advertisement