gir1.2-gtkspell3-3.0_3.0.7-2_i386.deb


Advertisement

Description

gir1.2-gtkspell3-3.0 - GObject introspection data for the GtkSpell library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main i386
Package filename gir1.2-gtkspell3-3.0_3.0.7-2_i386.deb
Package name gir1.2-gtkspell3-3.0
Package version 3.0.7
Package release 2
Package architecture i386
Package type deb
Category introspection
Homepage http://gtkspell.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.81 KB
Installed size 49.00 KB
This package contains introspection data for GtkSpell, a spell-checking
library for GTK+. They can be used to generate dynamic bindings.
GtkSpell provides Microsoft Word/OS X-style highlighting of misspelled
words in a GtkTextView widget.  Right-clicking a misspelled word pops up a
menu of suggested replacements.

Alternatives

Package Version Architecture Repository
gir1.2-gtkspell3-3.0_3.0.7-2_amd64.deb 3.0.7 amd64 Ubuntu Main
gir1.2-gtkspell3-3.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
libgirepository-1.0-1 >= 1.41.4-1
libgtkspell3-3-0 >= 3.0.3

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-gtkspell3-3.0_3.0.7-2_i386.deb
Source Package gtkspell3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-gtkspell3-3.0 deb package:
    # sudo apt-get install gir1.2-gtkspell3-3.0

Files

Path
/usr/lib/i386-linux-gnu/girepository-1.0/GtkSpell-3.0.typelib
/usr/share/doc/gir1.2-gtkspell3-3.0/AUTHORS
/usr/share/doc/gir1.2-gtkspell3-3.0/README
/usr/share/doc/gir1.2-gtkspell3-3.0/changelog.Debian.gz
/usr/share/doc/gir1.2-gtkspell3-3.0/copyright

Changelog

2015-06-02 - Michael Biebl <biebl@debian.org>
gtkspell3 (3.0.7-2) unstable; urgency=medium
* Stop installing the generated examples/Makefile. It's not particularly
useful anyway (can't be used to compile the example .c files) and breaks
multiarch co-installability. (Closes: #787317)
2015-05-30 - Michael Biebl <biebl@debian.org>
gtkspell3 (3.0.7-1) unstable; urgency=medium
* New upstream release.
* Convert to multiarch.
* Bump Standards-Version to 3.9.6.
* Update and rewrite debian/copyright using the machine-readable copyright
format 1.0.
2014-08-23 - Andreas Henriksson <andreas@fatal.se>
gtkspell3 (3.0.6-1) unstable; urgency=medium
[ Jackson Doak ]
* New upstream release
2013-10-14 - Michael Biebl <biebl@debian.org>
gtkspell3 (3.0.4-1) unstable; urgency=low
[ Jackson Doak ]
* New upstream release
[ Michael Biebl ]
* Set GNOME_DOWNLOAD_URL and TARBALL_EXT so "get-orig-source" works, the
source tarball is hosted on sf.net.
2013-06-29 - Michael Biebl <biebl@debian.org>
gtkspell3 (3.0.3-1) unstable; urgency=low
* New upstream release.
* Drop patches, all merged upstream.
* debian/patches/01-hide-private-symbols.patch: Don't export private
symbols.
* Update symbols file, add new symbols.
2013-05-29 - Jordi Mallach <jordi@debian.org>
gtkspell3 (3.0.2-2) unstable; urgency=low
[ Iain Lane ]
* debian/patches/gtk-spell-cflags-typo.patch: Cherry-pick patch from
upstream to substitute correct variable name for CFLAGS.
* debian/patches/fix-automake-syntax.patch: Cherry-pick patch from
upstream to use correct automake substitution syntax.
* dh-autoreconf for this change.
[ Jordi Mallach ]
* Build-Depend on valac (>= 0.20).
2013-04-29 - Jordi Mallach <jordi@debian.org>
gtkspell3 (3.0.2-1) unstable; urgency=low
* New upstream release. 
* Make Debian GNOME Maintainers the primary maintainer of this package.
* Update Build-Depends as per configure.ac.
* Bump to debhelper compat v9.
* Update to Standards-Version 3.9.4.
* Enable gobject-introspection support and add a gir1.2-gtkspell3-3.0
package.
* Fix watch file to look for new tarball name.
* Rename packages for name change: libgtkspell-3-0 → libgtkspell3-3-0.
* Add Conflicts/Replaces for old packages, as there are filename clashes.
* Add a symbols file for libgtkspell3-3-0.
* Install vala files.
* Build-Depend on libglib2.0-doc to ensure correct cross references in
generated gtk-doc documentation.
* Pass -c4 to dpkg-gensymbols.
* Call the list-missing rule.
2011-12-26 - Jordi Mallach <jordi@debian.org>
gtkspell3 (3.0.0~hg20110814-1) unstable; urgency=low
* New upstream release, based on GTK+3.
* Rename source package to gtkspell3, as we need to keep the GTK+2
version and both can be installed in parallel.
* Rename binary packages to match new lib name.
* Bump Build-Depends to meet new requirements.
* Bump to debhelper compat 8.
* Rewrite debian/rules using CDBS, as most other pkg-gnome sources.
* Rename *.files to .install.
* Update symbols file.
* Remove .dirs files.
* Drop .la and .a files.
* Pass --enable-gtk-doc to configure.
* Remove duplicate Section field.
* Add Homepage and Vcs-* fields.
* Bump to Standards-Version 3.9.2.
2010-01-08 - Ari Pollak <ari@debian.org>
gtkspell (2.0.16-1) unstable; urgency=low
* New upstream release
- Should fix some memory leak problems (Closes: #520608)
* Add Build-Depends-Package to .symbols file
2009-01-10 - Ari Pollak <ari@debian.org>
gtkspell (2.0.13-2) unstable; urgency=low
* Add updated copyright & watch files from Siegfried Gevatter 
(Closes: #508069)

See Also

Package Description
gir1.2-gtop-2.0_2.32.0-1_i386.deb gtop system monitoring library (gir bindings)
gir1.2-gucharmap-2.90_3.18.2-1ubuntu1_i386.deb GObject introspection data for the Unicode browser widget library
gir1.2-gudev-1.0_230-2_i386.deb libgudev-1.0 introspection data
gir1.2-gusb-1.0_0.2.9-0ubuntu1_i386.deb GObject introspection data for libgusb
gir1.2-gweather-3.0_3.18.1-1ubuntu1_i386.deb GObject introspection data for the GWeather library
gir1.2-gxps-0.1_0.2.3.2-1_i386.deb GObject introspection data for the gxps library
gir1.2-harfbuzz-0.0_1.0.1-1build2_i386.deb OpenType text shaping engine (GObject introspection data)
gir1.2-hud-2_14.10+16.04.20160415-0ubuntu1_i386.deb typelib file for libhud2
gir1.2-hud-client-2_14.10+16.04.20160415-0ubuntu1_i386.deb typelib file for libhud-client-2
gir1.2-ibus-1.0_1.5.11-1ubuntu2_i386.deb Intelligent Input Bus - introspection data
gir1.2-ido3-0.1_13.10.0+15.10.20151002-0ubuntu1_i386.deb Typelib file for libido3-0.1
gir1.2-isocodes-1.2_1.2.2-1_i386.deb access of iso-codes data and translations - GObject introspection
gir1.2-javascriptcoregtk-4.0_2.10.9-1ubuntu1_i386.deb JavaScript engine library from WebKitGTK+ - GObject introspection data
gir1.2-json-1.0_1.1.2-0ubuntu1_i386.deb GLib JSON manipulation library (introspection data)
gir1.2-langtag-0.5_0.5.7-2ubuntu1_i386.deb library to access tags for identifying languages - introspection
Advertisement
Advertisement