qml-module-qtquick-privatewidgets_5.5.1-1ubuntu1_amd64.deb


Advertisement

Description

qml-module-qtquick-privatewidgets - Qt 5 Private Widgets QML module

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package name qml-module-qtquick-privatewidgets
Package version 5.5.1
Package release 1ubuntu1
Package architecture amd64
Package type deb
Installed size 177 B
Download size 37.95 KB
Official Mirror archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
This package contains the Private Widgets module.

Alternatives

Package Version Architecture Repository
qml-module-qtquick-privatewidgets_5.6.1-2build1~~xenialoverlay1~1_amd64.deb 5.6.1 amd64 Kubuntu Backports
qml-module-qtquick-privatewidgets_5.6.1-2build1~~xenialoverlay1~1_i386.deb 5.6.1 i386 Kubuntu Backports
qml-module-qtquick-privatewidgets_5.5.1-1ubuntu1_i386.deb 5.5.1 i386 Ubuntu Main
qml-module-qtquick-privatewidgets - - -

Requires

Name Value
libc6 >= 2.14
libqt5core5a >= 5.5.0
libqt5gui5 >= 5.3.0
libqt5gui5-gles >= 5.3.0
libqt5qml5 >= 5.0.2
libqt5quick5 >= 5.2.0
libqt5quick5-gles >= 5.2.0
libqt5widgets5 >= 5.2.0
libstdc++6 >= 4.1.1
qtbase-abi-5-5-1 -
qtdeclarative-abi-5-5-0 -

Replaces

Name Value
qtdeclarative5-privatewidgets-plugin << 5.2.1-5~

Download

Type URL
Binary Package qml-module-qtquick-privatewidgets_5.5.1-1ubuntu1_amd64.deb
Source Package qtquickcontrols-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install qml-module-qtquick-privatewidgets deb package:
    # sudo apt-get install qml-module-qtquick-privatewidgets

Files

Path
/usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/PrivateWidgets/libwidgetsplugin.so
/usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/PrivateWidgets/plugins.qmltypes
/usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/PrivateWidgets/qmldir
/usr/share/doc/qml-module-qtquick-privatewidgets/changelog.Debian.gz
/usr/share/doc/qml-module-qtquick-privatewidgets/copyright

Changelog

2015-11-30 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtquickcontrols-opensource-src (5.5.1-1ubuntu1) xenial; urgency=medium
* New upstream release.
* Merge with Debian, remaining changes:
- A transitional package until Ubuntu 16.04 LTS.
2015-10-19 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtquickcontrols-opensource-src (5.5.1-1) experimental; urgency=medium
[ Dmitry Shachnev ]
* Minor debian/copyright fixes.
[ Timo Jyrinki ]
* New upstream release. 
* Bump build dependencies.
2015-08-29 - Dmitry Shachnev <mitya57@debian.org>
qtquickcontrols-opensource-src (5.5.0-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.5.0.
* Add new qml-module-qtquick-extras binary package.
* Do not hardcode libqt5qml5 dependencies.
* Update debian/copyright.
* Avoid compiling code during arch-indep builds, by adding empty
override_dh_auto_test-indep target.
2015-06-24 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtquickcontrols-opensource-src (5.4.2-2) unstable; urgency=medium
* Upload to unstable.
2015-06-11 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtquickcontrols-opensource-src (5.4.2-1ubuntu1) wily; urgency=medium
* New upstream release.
2015-06-03 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtquickcontrols-opensource-src (5.4.2-1) experimental; urgency=medium
* New upstream release.
- Bump Qt build dependencies.
* Clear up the list in Uploaders removing people who hasn't committed to the
repo in more than a year. They can re add themselves whenever they want
(and we really hope to see you back really soon!).
* Expose HTML documentation (Closes: #751180).
2015-03-11 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtquickcontrols-opensource-src (5.4.1-0ubuntu1) vivid; urgency=medium
* New upstream release.
* Sync with Debian, remaining changes:
- Keep transitional packages until Ubuntu 16.04 LTS
- Additional dependencies for the -examples package
- Tests enabled
2015-03-05 - Dmitry Shachnev <mitya57@debian.org>
qtquickcontrols-opensource-src (5.4.1-1) experimental; urgency=medium
* New upstream release.
* Update debian/watch to use https://download.qt.io/.
* Bump Qt build-dependencies to 5.4.1.
* Add some additional dependencies to qtquickcontrols5-examples.
* Clean up debian/copyright.
2015-03-10 - Iain Lane <iain@orangesquash.org.uk>
qtquickcontrols-opensource-src (5.4.0-1ubuntu2) vivid; urgency=medium
* debian/rules: Build & run the upstream testsuite. We need to do this
manually since the upstream build system isn't set up to run these
currently.
2015-02-13 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtquickcontrols-opensource-src (5.4.0-1ubuntu1) vivid; urgency=medium
* New upstream release.
* Bump build dependencies.
* Sync with Debian, remaining changes:
- Keep transitional packages until Ubuntu 16.04 LTS
- Additional dependencies for the -examples package

See Also

Package Description
qml-module-qtquick-window2_5.5.1-2ubuntu6_amd64.deb Qt 5 window 2 QML module
qml-module-qtquick-xmllistmodel_5.5.1-2ubuntu6_amd64.deb Qt 5 xmllistmodel QML module
qml-module-qtquick2_5.5.1-2ubuntu6_amd64.deb Qt 5 Qt Quick 2 QML module
qml-module-qttest_5.5.1-2ubuntu6_amd64.deb Qt 5 test QML module
qml-module-ubuntu-components_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Qt Components for Ubuntu - Components QML plugin
qml-module-ubuntu-layouts_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Qt Components for Ubuntu - Layouts QML plugin
qml-module-ubuntu-onlineaccounts_0.6+16.04.20151106-0ubuntu1_amd64.deb Expose the Online Accounts API to QML applications
qml-module-ubuntu-performancemetrics_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Qt Components for Ubuntu - PerformanceMetrics QML plugin
qml-module-ubuntu-test_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Qt Components for Ubuntu - Test QML plugin
qml-module-ubuntu-web-doc_0.23+16.04.20160413-0ubuntu1_all.deb Ubuntu web QML module HTML documentation
qml-module-ubuntu-web_0.23+16.04.20160413-0ubuntu1_amd64.deb Ubuntu web QML module
qmlscene_5.5.1-2ubuntu6_amd64.deb Qt 5 QML scene viewer
qpdf_6.0.0-2_amd64.deb tools for transforming and inspecting PDF files
qt-at-spi-doc_0.4.0-3_all.deb at-spi accessibility plugin for Qt - Documentation
qt-at-spi_0.4.0-3_amd64.deb at-spi accessibility plugin for Qt
Advertisement
Advertisement