printer-driver-postscript-hp_3.16.3+repack0-1_all.deb


Advertisement

Description

printer-driver-postscript-hp - HP Printers PostScript Descriptions

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename printer-driver-postscript-hp_3.16.3+repack0-1_all.deb
Package name printer-driver-postscript-hp
Package version 3.16.3+repack0
Package release 1
Package architecture all
Package type deb
Category utils
Homepage http://hplipopensource.com/hplip-web/index.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 984.88 KB
Installed size 1.34 MB
The HP Linux Printing and Imaging System provides full support for
printing on most HP SFP (single function peripheral) inkjets and many
LaserJets, and for scanning, sending faxes and for photo-card access on
most HP MFP (multi-function peripheral) printers.
This package contains the compressed PPDs for the PostScript HP
Printers.

Alternatives

Package Version Architecture Repository
printer-driver-postscript-hp_3.16.3+repack0-1_all.deb 3.16.3+repack0 all Ubuntu Main
printer-driver-postscript-hp - - -

Requires

Name Value
hplip >= 3.16.3+repack0-1
python3 -
xz-utils -

Replaces

Name Value
hplip << 3.11.10-1ubuntu2
hplip-data << 3.11.10-1ubuntu2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package printer-driver-postscript-hp_3.16.3+repack0-1_all.deb
Source Package hplip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install printer-driver-postscript-hp deb package:
    # sudo apt-get install printer-driver-postscript-hp

Files

Path
/usr/lib/cups/driver/postscript-hp
/usr/share/cups/ppd-updaters/printer-driver-postscript-hp.ppd-updater
/usr/share/doc/printer-driver-postscript-hp/changelog.Debian.gz
/usr/share/doc/printer-driver-postscript-hp/copyright

Changelog

2016-03-19 - Julian Andres Klode <jak@debian.org>
hplip (3.16.3+repack0-1) unstable; urgency=medium
* Imported Upstream version 3.16.3
2016-03-12 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-7) unstable; urgency=medium
* Apply HP-LaserJet_4000-PostScript-PPD.patch like other patches
* Do not run install actions twice in indep+arch builds (Closes: #817883)
2016-03-11 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-6) unstable; urgency=medium
* Handle building of only Architecture: any packages
* Use --dbgsym-migration instead of --ddeb-migration
2016-03-10 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-5) unstable; urgency=medium
* Add myself as an uploader
* Port the packaging to dh(1) and clean it up internally:
- Drop unused patches
- debian/rules: Drop /usr/share/gnome-pkg-tools/1/rules/sf-get-source.mk
- Delete unused debian/tmpno directory
- Do not set DH_ALWAYS_EXCLUDE for CVS and drop DH_VERBOSE comment
- Drop invalid use of X-Python-Version
- debian/rules: Port to dh(1)
- clean: Restore uncompressed files
- Use the standard source:Version substvar and its friends
- Remove support for installing Linda files
- Do not install lintian overrides manually, use dh_lintian
- Install ppd-updater files directly using dh_install
- Do not pass sourcedir to dh_install
- Install FAX ppds using install files
- Simply use dh_install --list-missing
- Let upstream install html into /usr/share/doc/hplip-doc/
- debian/rules: Stop patching hplip.conf
- Do not pass variables to build/install, not needed anymore
- Delete README.source, outdated
- Rename README.Source to README.source and drop outdated stuff
- Use upstream symlinks; drops hp-hpdio (not a script)
- Clean up lintian overrides
- hplip-data: Override two lintian tags
- Bump Standards-Version to 3.9.7
* Dropped stuff:
- Do not install .la files
- Do not install hpssd into bin, it's not executable
- Drop hp-unload for now, it does not support Python 3
* Install missing manual pages that are available
* Menu entry cleanup
- Drop hplip-gui.menu, having both .desktop and .menu is forbidden now
- Get rid of HPmenu.xpm and hp-logo.xpm, use upstream logo
* Build flag changes:
- Build with as-needed
- Use full hardening
2016-02-25 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-4) unstable; urgency=medium
* Add patch to order page sizes consistently in hp-scan, to ensure manpage
generation reproducibility
2016-02-23 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-3) unstable; urgency=medium
* Fix LD_LIBRARY_PATH to include DEB_HOST_MULTIARCH when generating python
tools' manpages; fixes the FTBFS of -2
2016-02-15 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-2) unstable; urgency=medium
* Multi-arch'ify libsane-hpaio and libhpmud0 (Closes: #813043, #804379)
2016-02-13 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-1) unstable; urgency=medium
* New 3.16.2 upstream release
- Repack the 3.16.2 upstream release
Uncompress various source files, for better upstream tracking in the VCS
* debian/rules - get-orig-source:
- force upstream/latest-repack merge to use 'theirs' merge strategy and
make it not fail the target
- drop 'modeswitch' copy-paste leftover
* Fix typo in previous changelog entry

See Also

Package Description
printer-driver-ptouch_1.4-1_amd64.deb printer driver Brother P-touch label printers
printer-driver-pxljr_1.4+repack0-4_amd64.deb printer driver for HP Color LaserJet 35xx/36xx
printer-driver-sag-gdi_0.1-4ubuntu1_all.deb printer driver for Ricoh Aficio SP 1000s/SP 1100s
printer-driver-splix_2.0.0+svn315-4fakesync1_amd64.deb Driver for Samsung and Xerox SPL2 and SPLc laser printers
procmail_3.22-25_amd64.deb Versatile e-mail processor
procps_3.3.10-4ubuntu2_amd64.deb /proc file system utilities
prosper_1.00.4+cvs.2007.05.01-4_all.deb LaTeX class for writing transparencies
protobuf-compiler_2.6.1-1.3_amd64.deb compiler for protocol buffer definition files
ps2eps_1.68+binaryfree-1_amd64.deb convert PostScript to EPS (Encapsulated PostScript) files
psf-unifont_8.0.01-1_all.deb PSF (console) version of GNU Unifont with APL support
psmisc_22.21-2.1build1_amd64.deb utilities that use the proc file system
pulseaudio-module-bluetooth_8.0-0ubuntu3_amd64.deb Bluetooth module for PulseAudio sound server
pulseaudio-module-x11_8.0-0ubuntu3_amd64.deb X11 module for PulseAudio sound server
pulseaudio-utils_8.0-0ubuntu3_amd64.deb Command line tools for the PulseAudio sound server
pulseaudio_8.0-0ubuntu3_amd64.deb PulseAudio sound server
Advertisement
Advertisement