pinentry-curses_0.9.7-3_amd64.deb


Advertisement

Description

pinentry-curses - curses-based PIN or pass-phrase entry dialog for GnuPG

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename pinentry-curses_0.9.7-3_amd64.deb
Package name pinentry-curses
Package version 0.9.7
Package release 3
Package architecture amd64
Package type deb
Category utils
Homepage https://www.gnupg.org/related_software/pinentry/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 30.49 KB
Installed size 86.00 KB
This package contains a program that allows for secure entry of PINs or
pass phrases.  That means it tries to take care that the entered
information is not swapped to disk or temporarily stored anywhere.
This functionality is particularly useful for entering pass phrases
when using encryption software such as GnuPG or e-mail clients using
the same.  It uses an open protocol and is therefore not tied to
particular software.
The program contained in this package implements a PIN entry dialog
using the curses tool kit, meaning that it is useful for users
working in text mode without the X Window System.  There are sibling
packages that implement PIN entry dialogs that use an X tool kit.  If
you install any of the graphical packages then this package is not
necessary because the sibling packages automatically fall back to
text mode if X is not active.

Alternatives

Package Version Architecture Repository
pinentry-curses_0.9.7-3_i386.deb 0.9.7 i386 Ubuntu Main
pinentry-curses - - -

Requires

Name Value
libassuan0 >= 2.0.1
libc6 >= 2.14
libgpg-error0 >= 1.14
libncursesw5 >= 6
libtinfo5 >= 6

Provides

Name Value
pinentry -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pinentry-curses_0.9.7-3_amd64.deb
Source Package pinentry

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pinentry-curses deb package:
    # sudo apt-get install pinentry-curses

Files

Path
/usr/bin/pinentry-curses
/usr/share/doc/pinentry-curses/AUTHORS
/usr/share/doc/pinentry-curses/NEWS.gz
/usr/share/doc/pinentry-curses/README.Debian
/usr/share/doc/pinentry-curses/changelog.Debian.gz
/usr/share/doc/pinentry-curses/copyright
/usr/share/man/man1/pinentry-curses.1.gz

Changelog

2016-02-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-3) unstable; urgency=medium
* build -tty, -curses, and -qt without libsecret (Closes: #787883)
2016-02-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-2) unstable; urgency=medium
* avoid use-after-free in QT pw quality calculation (patch from upstream)
2016-01-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-1) unstable; urgency=medium
* New upstream release.
2015-10-28 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.6-4) unstable; urgency=medium
* make pinentry-qt use qt5 by default. (Closes: #802936)
2015-10-19 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.6-3) unstable; urgency=medium
* added NEWS entry for pinentry-gtk2 (Closes: #801757)
2015-10-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.6-2) unstable; urgency=medium
* dummy/transitional pinentry-qt4 package: update alternatives
2015-10-01 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.6-1) unstable; urgency=medium
* New upstream release
* fix pinentry-tty description typo (Closes: #798944)
Thanks, Yuri D'Elia
* introduce new pinentry-qt, which people should use instead of
pinentry-qt4.
* pinentry-qt4 is now a dummy transitional package.
2015-08-11 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.5-4) unstable; urgency=medium
* use -std=gnu++11 for pinentry-qt4 (Closes: #795175)
2015-08-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.5-3) unstable; urgency=medium
* added dependency from pinentry-gnome3 to gcr (Closes: #791379)
2015-07-07 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.5-2) unstable; urgency=medium
* disable emacs and emacs-fallback until we get a better description of
them in the upstream documentation

See Also

Package Description
pinentry-doc_0.9.7-3_all.deb documentation for pinentry packages
pinentry-gnome3_0.9.7-3_amd64.deb GNOME 3 PIN or pass-phrase entry dialog for GnuPG
pkg-config_0.29.1-0ubuntu1_amd64.deb manage compile and link flags for libraries
pkg-create-dbgsym_0.72_all.deb automatically build debug symbol ddeb packages
pkg-php-tools_1.32ubuntu2_all.deb various packaging tools and scripts for PHP packages
pkgbinarymangler_129_all.deb strips translations and alters maintainers during build
plainbox-provider-checkbox_0.25-1_amd64.deb CheckBox provider for PlainBox
plainbox-provider-resource-generic_0.23-1_amd64.deb CheckBox generic resource jobs provider
plainbox-secure-policy_0.25-1_all.deb policykit policy required to use plainbox (secure version)
plymouth-label_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer - label control
plymouth-theme-ubuntu-logo_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer - ubuntu theme
plymouth-theme-ubuntu-text_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer - ubuntu text theme
plymouth-themes_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer - themes
plymouth-x11_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer - X11 renderer
plymouth_0.9.2-3ubuntu13_amd64.deb boot animation, logger and I/O multiplexer
Advertisement
Advertisement