pax_20151013-1_amd64.deb


Advertisement

Description

pax - Portable Archive Interchange (cpio, pax, tar)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename pax_20151013-1_amd64.deb
Package name pax
Package version 20151013
Package release 1
Package architecture amd64
Package type deb
Category utils
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 76.96 KB
Installed size 166.00 KB
paxtar is an implementation of an archiving utility that reads
and writes several formats - traditional ones, the extended
formats specified in IEEE 1003.1, and the ar(5) format used
by deb(5) packages (MirBSD specific paxtar extension). The
pax interface was designed by IEEE 1003.2 as a compromise in
the chronic controversy over which of tar or cpio is best, but
this implementation offers paxcpio and paxtar for easy calling.
This is the MirBSD paxtar implementation supporting the formats
ar, bcpio, cpio, SVR4 cpio with and without CRC, old tar, and
ustar, but not the format known as pax yet. It has extensions
for removing non-numerical user and group IDs from the archive,
storing hardlinked files only once, setting ownership to the
superuser, anonymising inode and device information, changing
the mtime to zero, and producing GNU tar compatible trailing
slashes on ustar directory nodes. Its "ar" format is suitable
for operating on *.deb files, unlike that of GNU binutils.
Note that ACLs and Extended Attributes are not supported.
Also, on Debian GNU/Hurd and Debian GNU/Linux (but not
Debian GNU/kFreeBSD), size of archive members is limited
to the width of the "long" type, that is, 2 GiB on platforms
that do not have a 64-bit "long" type, due to a bug in the
GNU C library (Debian #317466).

Alternatives

Package Version Architecture Repository
pax_20151013-1_i386.deb 20151013 i386 Ubuntu Main
pax - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pax_20151013-1_amd64.deb
Source Package pax

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pax deb package:
    # sudo apt-get install pax

Files

Path
/bin/pax
/bin/paxcpio
/bin/paxtar
/usr/share/doc/pax/changelog.Debian.gz
/usr/share/doc/pax/copyright
/usr/share/lintian/overrides/pax
/usr/share/man/man1/pax.1.gz
/usr/share/man/man1/paxcpio.1.gz
/usr/share/man/man1/paxtar.1.gz

Changelog

2015-10-13 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20151013-1) unstable; urgency=low
* QA upload.
* New upstream version
- document more known issues
- make list output line-buffered
* Use more current debhelper compat and techniques
* No longer try link-time optimisation as it’s constantly broken
* Unbreak x32 build
* Update lintian overrides
2014-10-07 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20140703-2) unstable; urgency=low
* QA upload.
* Revert to a more standard Debian packaging style
* Bump to Policy 3.9.6 while here
* Orphan the package.
2014-07-03 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20140703-1) unstable; urgency=medium
* Merge 1:20120606-2+deb7u1 upload
* debian/control: Move VCS-* fields to Alioth collab-maint git
* Remove now-useless RCS IDs
* Bump Policy to 3.9.5 (no changes needed)
* Revert intrusive, troubling packaging changes from experimental
* New upstream version, upload to unstable
* Address lintian’s concerns
* Plug some GCC fortify warnings
2012-11-26 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120606-3) experimental; urgency=low
* “Our littlest” upload
* Policy 3.9.4.0, with no relevant changes
* Drop temporary B-C for fakeroot on hurd again
* debian/watch: mangle the epoch away so DDPO is green again
* Completely rewrite packaging using debhelper (Closes: #690381)
2013-01-26 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120606-2+deb7u1) unstable; urgency=low
* The “I know how that feels, porting” upload
* Apparently, x32 did the right thing and uses a 64-bit off_t
by default as the BSDs do, even if its long is shorter; it’s
the first Linux architecture to do so ⇒ needs an extra check
* Upload to unstable, so the x32 porting can go on; it doesn’t
need to migrate to wheezy in itself but this change shouldn’t
prevent an eventual 1:20120606-2+deb7u2 from migrating either
2012-06-07 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120606-2) unstable; urgency=low
* Fix permissions, timestamps, and shuffle dh_* around
* Switch to 3.0 (quilt)
* Temporarily add a versioned B-C for fakeroot on hurd (#676428)
2012-06-06 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120606-1) unstable; urgency=low
* The “How the … did I get sore s̲h̲o̲u̲l̲d̲e̲r̲ muscles from football?” upload
* Update to new upstream version:
- oops, fix tty_init rewrito
* This fixes FTBFS
2012-06-05 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120605-1) unstable; urgency=low
* The “Sport ist Mord” upload
* Update to new upstream version:
- merge fixes from OpenBSD
- improve portability
- remove use of stdio in favour of syscalls in some places
- mention nōn-support (TOOD) of pax file format in manpages
* Drop lintian overrides
- false positive is resolved
- we don’t really care about no-homepage and no-upstream-changelog
* Build-Depends less package! Thanks to “goodbye” sample package!
* Aid cross-compiling by setting ${CC} to something useful
2012-05-20 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120520-1) unstable; urgency=low
* New upstream version
- paxtar front-end got a new 'a' option for compression
utility auto-detection, based on archive filename
- includes options.c change (drop Debian patch)
* Mention member size limitations on !kfreebsd !LP64 platforms
due to an eglibc bug (#317466)
* Override lintian false-positive "hardening-no-stackprotector"
* Add overrides for "yes, not an omission, there are none"
2012-02-27 - Thorsten Glaser <tg@mirbsd.de>
pax (1:20120216-2) unstable; urgency=low
* Update options.c to version from CVS to ensure the order of
command line arguments in the cpio front-end more tightly,
to prevent creating archives in the wrong format accidentally
* Link with --as-needed (not enough to workaround #650145 though ☹)
* Policy 3.9.3 (no changes)
* Mention non-support of ACLs/EAs in the long description

See Also

Package Description
pbuilder_0.223_all.deb personal package builder for Debian packages
pciutils_3.3.1-1.1ubuntu1_amd64.deb Linux PCI Utilities
pcmciautils_018-8_amd64.deb PCMCIA utilities for Linux 2.6
perl-base_5.22.1-9_amd64.deb minimal Perl system
perl-debug_5.22.1-9_amd64.deb debug-enabled Perl interpreter
perl-doc_5.22.1-9_all.deb Perl documentation
perl-modules-5.22_5.22.1-9_all.deb Core Perl modules
perl_5.22.1-9_amd64.deb Larry Wall's Practical Extraction and Report Language
php-all-dev_35ubuntu6_all.deb package depending on all supported PHP development packages
php-cgi_7.0+35ubuntu6_all.deb server-side, HTML-embedded scripting language (CGI binary) (default)
php-cli_7.0+35ubuntu6_all.deb command-line interpreter for the PHP scripting language (default)
php-common_35ubuntu6_all.deb Common files for PHP packages
php-curl_7.0+35ubuntu6_all.deb CURL module for PHP [default]
php-dev_7.0+35ubuntu6_all.deb Files for PHP module development (default)
php-gd_7.0+35ubuntu6_all.deb GD module for PHP [default]
Advertisement
Advertisement