modemmanager-dev_1.4.12-1ubuntu1_amd64.deb


Advertisement

Description

modemmanager-dev - D-Bus service for managing modems - development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename modemmanager-dev_1.4.12-1ubuntu1_amd64.deb
Package name modemmanager-dev
Package version 1.4.12
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.freedesktop.org/wiki/Software/ModemManager/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.59 KB
Installed size 128.00 KB
ModemManager is a DBus-activated daemon which controls mobile broadband
(2G/3G/4G) devices and connections. Whether built-in devices, USB dongles,
bluetooth-paired telephones or professional RS232/USB devices with external
power supplies, ModemManager is able to prepare and configure the modems and
setup connections with them.
This package contains header files for ModemManager.

Alternatives

Package Version Architecture Repository
modemmanager-dev_1.6.4-1ubuntu0.16.04.1_i386.deb 1.6.4 i386 Ubuntu Updates Main
modemmanager-dev_1.6.4-1ubuntu0.16.04.1_amd64.deb 1.6.4 amd64 Ubuntu Updates Main
modemmanager-dev_1.4.12-1ubuntu1_i386.deb 1.4.12 i386 Ubuntu Main
modemmanager-dev - - -

Replaces

Name Value
modemmanager << 0.7.990

Download

Type URL
Mirror archive.ubuntu.com
Binary Package modemmanager-dev_1.4.12-1ubuntu1_amd64.deb
Source Package modemmanager

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install modemmanager-dev deb package:
    # sudo apt-get install modemmanager-dev

Files

Path
/usr/include/ModemManager/ModemManager-enums.h
/usr/include/ModemManager/ModemManager-errors.h
/usr/include/ModemManager/ModemManager-names.h
/usr/include/ModemManager/ModemManager-version.h
/usr/include/ModemManager/ModemManager.h
/usr/lib/x86_64-linux-gnu/pkgconfig/ModemManager.pc
/usr/share/doc/modemmanager-dev/changelog.Debian.gz
/usr/share/doc/modemmanager-dev/copyright

Changelog

2015-11-04 - Sebastien Bacher <seb128@ubuntu.com>
modemmanager (1.4.12-1ubuntu1) xenial; urgency=medium
* Resynchronize on Debian, remaining changes
* New hardware enablement: Support the new MBIM devices from Dell.
(LP: #1441095)
* debian/rules: drop ubuntu vendor-specific changes for an upstart job.
Now that we use systemd there is no reason to keep special-casing to keep
the upstart job around, and it's confusing to have a SysV, upstart, and
systemd way of starting ModemManager all at the same time.
2015-10-08 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.12-1) unstable; urgency=medium
* New upstream release.
2015-07-26 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.10-1) unstable; urgency=medium
* New upstream release.
- Blacklist: ignore devices from Posnet Polska S.A. (Closes: #791341)
2015-05-08 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.8-1) unstable; urgency=medium
* Upload to unstable.
* New upstream release.
2015-02-13 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.4-1) experimental; urgency=medium
* Imported Upstream version 1.4.4.
* Bump Build-Depends on libqmi-glib-dev to (>= 1.12.4).
2015-02-09 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.2-1) experimental; urgency=medium
[ Marius B. Kotsbak ]
* Imported Upstream version 1.4.2.
* Removed all patches applied upstream.
* Update to latest Standards-Version 3.9.6.
[ Michael Biebl ]
* Set debian-branch to experimental in gbp.conf.
* Update Vcs-Browser to use cgit and https.
* Install typelib files into multiarch paths now that gobject-introspection
supports that.
* Mark dev and gir packages as Multi-Arch: same.
2014-09-17 - Michael Biebl <biebl@debian.org>
modemmanager (1.4.0-1) unstable; urgency=medium
* New upstream release.
- Fixes conflicting definitions of mm_manager_new. (Closes: #749387)
* Refresh patches.
* Bump Build-Depends on libmbim-glib-dev to (>= 1.10).
* Install NEWS file which includes the relevant upstream changes.
(Closes: #641467)
* Update symbols file for libmm-glib0.
* Add Build-Depends on dbus, required to run the test suite.
2014-06-25 - Michael Biebl <biebl@debian.org>
modemmanager (1.2.0-1) unstable; urgency=medium
[ Guido G√ľnther ]
* New upstream version 1.2.0 (Closes: #731851)
* Update patches
* Install locale files
* Require newer libqmi
* Update symbols file
* Ship gobject introspection data
* Ship vala bindings
[ Michael Biebl ]
* Use canonical URI for Vcs-Git
* Use gir dh addon
* Update extendend package description (Closes: #744180)
2014-06-03 - Martin Pitt <mpitt@debian.org>
modemmanager (1.0.0-5) unstable; urgency=medium
[ Michael Biebl ]
* Fix typo in package description (Closes: #745140)
[ Martin Pitt ]
* libmm-glib: Initialize result array
* Add systemd unit link to shadow upstart job (LP: #1314795)
* Fix systemd/upstart job on upgrades on Ubuntu
* Avoid cancelling of systemd unit stop on remove (Closes: #745621)
2014-03-29 - Michael Biebl <biebl@debian.org>
modemmanager (1.0.0-4) unstable; urgency=medium
* Kill old modem-manager process when upgrading from pre 1.0.0 versions.

See Also

Package Description
modemmanager-doc_1.4.12-1ubuntu1_all.deb D-Bus service for managing modems - documentation files
modemmanager_1.4.12-1ubuntu1_amd64.deb D-Bus service for managing modems
mokutil_0.3.0-0ubuntu3_amd64.deb tools for manipulating machine owner keys
monitoring-plugins-basic_2.1.2-2ubuntu2_amd64.deb Plugins for nagios compatible monitoring systems (basic)
monitoring-plugins-common_2.1.2-2ubuntu2_amd64.deb Common files for plugins for nagios compatible monitoring
monitoring-plugins-standard_2.1.2-2ubuntu2_amd64.deb Plugins for nagios compatible monitoring systems (standard)
monitoring-plugins_2.1.2-2ubuntu2_all.deb Plugins for nagios compatible monitoring systems (metapackage)
mono-4.0-gac_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono GAC tool (for CLI 4.0)
mono-csharp-shell_4.2.1.102+dfsg2-7ubuntu4_all.deb interactive C# shell
mono-devel_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono development tools
mono-gac_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono GAC tool
mono-mcs_4.2.1.102+dfsg2-7ubuntu4_all.deb Mono C# 2.0 / 3.0 / 4.0 / 5.0 compiler for CLI 2.0 / 4.0 / 4.5
mono-runtime-boehm_4.2.1.102+dfsg2-7ubuntu4_amd64.deb Mono runtime - Boehm
mono-runtime-common_4.2.1.102+dfsg2-7ubuntu4_amd64.deb Mono runtime - common files
mono-runtime-sgen_4.2.1.102+dfsg2-7ubuntu4_amd64.deb Mono runtime - SGen
Advertisement
Advertisement