lua-lpeg-dev_0.12.2-1_amd64.deb


Advertisement

Description

lua-lpeg-dev - LPeg development files for the Lua language

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename lua-lpeg-dev_0.12.2-1_amd64.deb
Package name lua-lpeg-dev
Package version 0.12.2
Package release 1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.inf.puc-rio.br/~roberto/lpeg.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 42.53 KB
Installed size 271.00 KB
This package contains the development files of the lpeg library,
useful to create a statically linked binary (like a C application or a
standalone Lua interpreter).
Documentation is also shipped within this package.

Alternatives

Package Version Architecture Repository
lua-lpeg-dev_0.12.2-1_i386.deb 0.12.2 i386 Ubuntu Main
lua-lpeg-dev - - -

Requires

Name Value
lua-lpeg = 0.12.2-1

Provides

Name Value
lua5.1-lpeg-dev -
lua5.2-lpeg-dev -
lua5.3-lpeg-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package lua-lpeg-dev_0.12.2-1_amd64.deb
Source Package lua-lpeg

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-lpeg-dev deb package:
    # sudo apt-get install lua-lpeg-dev

Files

Path
/usr/include/lua5.1/lua-lpeg.h
/usr/include/lua5.2/lua-lpeg.h
/usr/include/lua5.3/lua-lpeg.h
/usr/lib/x86_64-linux-gnu/liblua5.1-lpeg.a
/usr/lib/x86_64-linux-gnu/liblua5.1-lpeg.so
/usr/lib/x86_64-linux-gnu/liblua5.2-lpeg.a
/usr/lib/x86_64-linux-gnu/liblua5.2-lpeg.so
/usr/lib/x86_64-linux-gnu/liblua5.3-lpeg.a
/usr/lib/x86_64-linux-gnu/liblua5.3-lpeg.so
/usr/lib/x86_64-linux-gnu/pkgconfig/lua5.1-lpeg.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/lua5.2-lpeg.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/lua5.3-lpeg.pc
/usr/share/doc/lua-lpeg-dev/changelog.Debian.gz
/usr/share/doc/lua-lpeg-dev/copyright
/usr/share/doc/lua-lpeg-dev/lpeg-128.gif
/usr/share/doc/lua-lpeg-dev/lpeg.html
/usr/share/doc/lua-lpeg-dev/re.html

Changelog

2015-08-14 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.12.2-1) unstable; urgency=medium
* New upstream release
* Pre-Depends: remove multiarch-support
* Remove transitional packages leftover
* Bump Standards-Version, no change 
2012-04-17 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.12-1) unstable; urgency=low
* New upstream release
* Updated copyright file 
* Removed transitional packages
2012-03-28 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.10.2-5) unstable; urgency=low
* Disable optimizations on mipsel too, since some buildds (like rem)
dont like them, while others (like phrixos) do.
2012-03-28 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.10.2-4) unstable; urgency=low
* Disable optimizations on mips
2012-03-24 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.10.2-3) unstable; urgency=low
* Disable optimizations on sparc (Closes: #652116)
* Switch to dh-lua to build for lua5.1 and lua5.2
* Packages remaned to conform to the new Lua policy
* Transitional packages added to ease the upgrade
2011-07-21 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.10.2-2) unstable; urgency=low
* multi-arch compliant (dh >= 8.1.3, lua5.1-policy >= 32)
* bumped standards-version to 3.9.2, no changes 
2011-02-20 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.10.2-1) unstable; urgency=low
* new upstream release 
* bumped standards-version to 3.9.1, depend on liblua5.1-policy-dev >= 27
* source format 3.0 (quilt)
* patch: test, do not include strict.lua since not provided 
2009-10-12 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.9-4) unstable; urgency=low
* fixed watch file (thanks Yan Morin) (Closes: #550735) 
* bumped standards-version to 3.8.3, no changes
2009-07-21 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.9-3) unstable; urgency=low
* changed lua to Lua in control 
* added build-depends on lua5.1-policy-dev >= 22
* bomped standards-version to 3.8.2, no changes needed
2009-03-15 - Enrico Tassi <gareuselesinge@debian.org>
lua-lpeg (0.9-2) unstable; urgency=low
* upload to unstable

See Also

Package Description
lua-lpeg_0.12.2-1_amd64.deb LPeg library for the Lua language
lua-lxc_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools (LUA bindings)
lua-rrd-dev_1.5.5-4_amd64.deb time-series data storage and display system (Lua development)
lua-rrd_1.5.5-4_amd64.deb time-series data storage and display system (Lua interfaces)
lua5.1-doc_5.1.5-8ubuntu1_all.deb Documentation for the Lua language version 5.1
lua5.2-doc_5.2.4-1ubuntu1_all.deb Documentation for the Lua language version 5.2
lua5.2_5.2.4-1ubuntu1_amd64.deb Simple, extensible, embeddable programming language
lupin-casper_0.57_all.deb Add support for loop-mount installations to casper
lupin-support_0.57_amd64.deb Support files for loop-mount installations
lvm2_2.02.133-1ubuntu10_amd64.deb Linux Logical Volume Manager
lxc-common_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools (common tools)
lxc-dev_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools (development)
lxc-templates_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools (templates)
lxc-tests_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools (test binaries)
lxc1_2.0.0-0ubuntu2_amd64.deb Linux Containers userspace tools
Advertisement
Advertisement