libxi6_1.7.6-1_amd64.deb


Advertisement

Description

libxi6 - X11 Input extension library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libxi6_1.7.6-1_amd64.deb
Package name libxi6
Package version 1.7.6
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.x.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 27.90 KB
Installed size 87.00 KB
libXi provides an X Window System client interface to the XINPUT
extension to the X protocol.
The Input extension allows setup and configuration of multiple input devices,
and hotplugging of input devices (to be added and removed on the fly).
More information about X.Org can be found at:
<URL:http://www.X.org>
This module can be found at
git://anongit.freedesktop.org/git/xorg/lib/libXi

Alternatives

Package Version Architecture Repository
libxi6_1.7.6-1_i386.deb 1.7.6 i386 Ubuntu Main
libxi6 - - -

Requires

Name Value
libc6 >= 2.14
libx11-6 >= 2:1.6.0
libxext6 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libxi6_1.7.6-1_amd64.deb
Source Package libxi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxi6 deb package:
    # sudo apt-get install libxi6

Files

Path
/usr/lib/x86_64-linux-gnu/libXi.so.6
/usr/lib/x86_64-linux-gnu/libXi.so.6.1.0
/usr/share/doc/libxi6/changelog.Debian.gz
/usr/share/doc/libxi6/copyright

Changelog

2016-01-24 - Julien Cristau <jcristau@debian.org>
libxi (2:1.7.6-1) unstable; urgency=medium
* New upstream release.
* Remove Drew and Cyril from Uploaders.
* Fix package descriptions: input hotplugging has been implemented years ago
(closes: #782987).  Thanks, Paul Wise!
2015-10-13 - Julien Cristau <jcristau@debian.org>
libxi (2:1.7.5-1) unstable; urgency=medium
[ Andreas Boll ]
* New upstream release.
* Switch to dh with the autoreconf and quilt addons.
* Fix lintian error: pre-depends-directly-on-multiarch-support libxi6.
* Let uscan verify tarball signatures.
* Fix Vcs-* fields.
* Remove obsolete XC- prefix from Package-Type field.
* Add upstream url.
* Bump standards version to 3.9.6.
[ Julien Cristau ]
* Delete obsolete debian/xsfbs.
2014-07-21 - Maarten Lankhorst <maarten.lankhorst@ubuntu.com>
libxi (2:1.7.4-1) unstable; urgency=low
* New upstream release.
2013-08-12 - Julien Cristau <jcristau@debian.org>
libxi (2:1.7.2-1) unstable; urgency=low
* New upstream release.
2013-06-30 - Julien Cristau <jcristau@debian.org>
libxi (2:1.7.1.901-1) unstable; urgency=low
* New upstream release candidate.
[ Timo Aaltonen ]
* control: Bump policy to 3.9.4, no changes.
* control: Bump x11proto-input-dev build-dep to 2.2.99.1.
* libxi6.symbols: Added new symbols.
* rules: Bump shlibs.
* control: Add libfixes-dev to build-deps and libxi-dev Depends.
[ Julien Cristau ]
* Use dpkg-buildflags.
* Disable silent build rules.
* Bump debhelper compat level to 7.
* Simplify installing manpages.
* Fix clean rule for config.h.in.
* Use dh_prep instead of dh_clean -k.
2012-05-20 - Cyril Brulebois <kibi@debian.org>
libxi (2:1.6.1-1) unstable; urgency=low
[ Julien Cristau ]
* Don't require (fake)root for debian/rules clean.
[ Cyril Brulebois ]
* New upstream release.
2012-04-16 - Julien Cristau <jcristau@debian.org>
libxi (2:1.6.0-1) unstable; urgency=low
[ Chase Douglas ]
* New upstream release
- Fix bus error on MIPS N32 (closes: #636920)
* Bump build deps on x11proto-input-dev
* Bump lintian standards version to 3.9.3
[ Julien Cristau ]
* Pull some more changes from upstream master:
- Fix wrong button label and mask copy on OS X (fixes regression in the
patch for bug#636920)
- Move version comparison into a helper function
- Set the RawEvent sourceid (#34240)
* Upload to unstable.
2011-12-22 - Cyril Brulebois <kibi@debian.org>
libxi (2:1.5.99.2-1) experimental; urgency=low
* New upstream release candidate:
- With XI 2.2 support, needed for multitouch.
* Fix changelog entry for 2:1.4.99.1-1:
- With XI 2.1 support, no multitouch yet.
* Bump x11proto-input-dev and libx11-dev build-deps.
* Update libxi6.symbols with new symbols and bump shlibs.
2011-12-21 - Cyril Brulebois <kibi@debian.org>
libxi (2:1.5.0-1) experimental; urgency=low
* New upstream release.
2011-12-15 - Cyril Brulebois <kibi@debian.org>
libxi (2:1.4.99.1-1) experimental; urgency=low
* New upstream release candidate:
- With XI 2.1 support.
* Update build dependencies accordingly:
- Bump xutils-dev, x11proto-input-dev, xorg-sgml-doctools.
- Add xsltproc.
* Update libxi-dev.install: specs/ and docs/ have been merged.
* Don't install *.db yet.
* Add -c4 to dh_makeshlibs.

See Also

Package Description
libxinerama-dev_1.1.3-1_amd64.deb X11 Xinerama extension library (development headers)
libxinerama1_1.1.3-1_amd64.deb X11 Xinerama extension library
libxkbcommon-dev_0.5.0-1ubuntu2_amd64.deb library interface to the XKB compiler - development files
libxkbcommon-x11-0_0.5.0-1ubuntu2_amd64.deb library to create keymaps with the XKB X11 protocol
libxkbcommon-x11-dev_0.5.0-1ubuntu2_amd64.deb library to create keymaps with the XKB X11 protocol - development files
libxkbcommon0_0.5.0-1ubuntu2_amd64.deb library interface to the XKB compiler - shared library
libxkbfile-dev_1.0.9-0ubuntu1_amd64.deb X11 keyboard file manipulation library (development headers)
libxkbfile1_1.0.9-0ubuntu1_amd64.deb X11 keyboard file manipulation library
libxklavier-dev_5.4-0ubuntu2_amd64.deb Development files for libxklavier
libxklavier16_5.4-0ubuntu2_amd64.deb X Keyboard Extension high-level API
libxml-commons-external-java-doc_1.4.01-2build1_all.deb Documentation of XML Commons external API
libxml-commons-external-java_1.4.01-2build1_all.deb XML Commons external code - DOM, SAX, and JAXP, etc
libxml-commons-resolver1.1-java-doc_1.2-7build1_all.deb XML entity and URI resolver library -- documentation
libxml-commons-resolver1.1-java-gcj_1.2-7build1_amd64.deb XML entity and URI resolver library -- native library
libxml-commons-resolver1.1-java_1.2-7build1_all.deb XML entity and URI resolver library
Advertisement
Advertisement