libxenstore3.0_4.6.0-1ubuntu4_amd64.deb


Advertisement

Description

libxenstore3.0 - Xenstore communications library for Xen

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libxenstore3.0_4.6.0-1ubuntu4_amd64.deb
Package name libxenstore3.0
Package version 4.6.0
Package release 1ubuntu4
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 18.69 KB
Installed size 79.00 KB
This package contains the client library interface to XenStore.  .

Alternatives

Package Version Architecture Repository
libxenstore3.0_4.6.5-0ubuntu1.4_i386.deb 4.6.5 i386 Ubuntu Updates Main
libxenstore3.0_4.6.5-0ubuntu1.4_amd64.deb 4.6.5 amd64 Ubuntu Updates Main
libxenstore3.0_4.6.0-1ubuntu4_i386.deb 4.6.0 i386 Ubuntu Main
libxenstore3.0 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libxenstore3.0_4.6.0-1ubuntu4_amd64.deb
Source Package xen

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxenstore3.0 deb package:
    # sudo apt-get install libxenstore3.0

Files

Path
/usr/lib/x86_64-linux-gnu/libxenstore.so.3.0
/usr/lib/x86_64-linux-gnu/libxenstore.so.3.0.3
/usr/share/doc/libxenstore3.0/changelog.Debian.gz
/usr/share/doc/libxenstore3.0/copyright

Changelog

2016-02-19 - Stefan Bader <stefan.bader@canonical.com>
xen (4.6.0-1ubuntu4) xenial; urgency=low
* d/rules.real: Set LANG=C.UTF-8 for the builds to avoid a grep bug.
2016-02-18 - Stefan Bader <stefan.bader@canonical.com>
xen (4.6.0-1ubuntu3) xenial; urgency=low
* Fix unmount error message on shutdown and init script ordering issues:
- d/xen-utils-common.xenstored.init: Introduce new init script which only
starts xenstored (but also shuts it down on stop). Prevent this one to
be run on upgrade.
- d/xen-utils-common.xen.init:
* Add X-Start-Before/X-Stop-After dependencies on libvirt-bin
* Remove xenstored related code
* d/scripts/xen-init-list: Revert back to unmodified version from Debian.
With the ordering fixed, libvirt guests should be handled by its own
script before xendomains is run.
* d/control, d/libxen-dev.install and d/rules.real:
Add xenlight.pc and xlutil.pc to be packaged as part of libxen-dev in
multi-arch suitable location. Also declare libxen-dev as multi-arch
same.
* Additional Security Patches:
- CVE-2016-2270 / XSA-154
* x86: enforce consistent cachability of MMIO mappings
- CVE-2016-1570 / XSA-167
* x86/mm: PV superpage handling lacks sanity checks
- CVE-2016-1571 / XSA-168
* x86/VMX: prevent INVVPID failure due to non-canonical guest address
- CVE-2015-8615 / XSA-169
* x86: make debug output consistent in hvm_set_callback_via
- CVE-2016-2271 / XSA-170
* x86/VMX: sanitize rIP before re-entering guest
2015-12-16 - Stefan Bader <stefan.bader@canonical.com>
xen (4.6.0-1ubuntu2) xenial; urgency=low
* Applying Xen Security Advisories:
- CVE-2015-8550 / XSA-155
* xen: Add RING_COPY_REQUEST()
* blktap2: Use RING_COPY_REQUEST
* libvchan: Read prod/cons only once.
- CVE-2015-8338 / XSA-158
* memory: split and tighten maximum order permitted in memops
- CVE-2015-8339, CVE-2015-8340 / XSA-159
* memory: fix XENMEM_exchange error handling
- CVE-2015-8341 / XSA-160
* libxl: Fix bootloader-related virtual memory leak on pv
build failure
- CVE-2015-8555 / XSA-165
* x86: don't leak ST(n)/XMMn values to domains first using them
- CVE-2015-???? / XSA-166
* x86/HVM: avoid reading ioreq state more than once
2015-12-02 - Stefan Bader <stefan.bader@canonical.com>
xen (4.6.0-1ubuntu1) xenial; urgency=low
* Merge of Xen-4.6 from Debian. Remaining changes:
- debian/control, debian/rules.gen:
Generate transitional xen-hypervisor packages.
- debian/rules.real:
Install the grub.d config file.
- debian/scripts/xen-init-list:
Ignore libxl guests not created by the xl toolstack (e.g. libvirt).
- debian/tree/xen-utils-common/usr/share/xen-utils-common/default.xen:
Minor readability improvements (maybe get rid of those)
- debian/xen-hypervisor-4.6.xen.cfg:
Additional config file to simplify grub configuration.
- debian/xen-utils-4.6.postinst, debian/xen-utils-4.6.prerm:
Remove update-alternatives call.
- debian/xen-utils-common.xen.init:
Fix consoled_stop_real and additional code to start and attach a
qemu instance to dom0 (needed for pygrub booting QCOW2 PVM guests).
Note: Also contains a work-around for a kernel bug which should be
dropped in the next release.
- debian/patches/ubuntu-config-prefix-fix.patch:
Modifies configure and tools/configure to use the correct (versioned)
libexec path.
- Additional security fixes:
* XSA-156 / CVE-2015-5307
x86/HVM: always intercept #AC and #DB
2015-11-01 - Bastian Blank <waldi@debian.org>
xen (4.6.0-1) unstable; urgency=medium
* New upstream release.
* CVE-2015-7812
* CVE-2015-7813
* CVE-2015-7814
* CVE-2015-7835
* CVE-2015-7969
* CVE-2015-7970
* CVE-2015-7971
* CVE-2015-7972

See Also

Package Description
libxerces2-java-doc_2.11.0-7_all.deb Validating XML parser for Java -- Documentation and examples
libxerces2-java-gcj_2.11.0-7_amd64.deb Validating XML parser for Java with DOM level 3 support (native code)
libxerces2-java_2.11.0-7_all.deb Validating XML parser for Java with DOM level 3 support
libxext-dev_1.3.3-1_amd64.deb X11 miscellaneous extensions library (development headers)
libxext-doc_1.3.3-1_all.deb X11 miscellaneous extensions library (documentation)
libxext6_1.3.3-1_amd64.deb X11 miscellaneous extension library
libxfixes-dev_5.0.1-2_amd64.deb X11 miscellaneous 'fixes' extension library (development headers)
libxfixes3_5.0.1-2_amd64.deb X11 miscellaneous 'fixes' extension library
libxfont-dev_1.5.1-1_amd64.deb X11 font rasterisation library (development headers)
libxfont1_1.5.1-1_amd64.deb X11 font rasterisation library
libxfreerdp-client1.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Free Remote Desktop Protocol library (xfreerdp-client library)
libxft-dev_2.3.2-1_amd64.deb FreeType-based font drawing library for X (development files)
libxft2_2.3.2-1_amd64.deb FreeType-based font drawing library for X
libxi-dev_1.7.6-1_amd64.deb X11 Input extension library (development headers)
libxi6_1.7.6-1_amd64.deb X11 Input extension library
Advertisement
Advertisement