libxcb-ewmh-dev_0.4.1-1ubuntu1_amd64.deb


Advertisement

Description

libxcb-ewmh-dev - utility libraries for X C Binding -- ewmh, development files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libxcb-ewmh-dev_0.4.1-1ubuntu1_amd64.deb
Package name libxcb-ewmh-dev
Package version 0.4.1
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://xcb.freedesktop.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.95 KB
Installed size 224.00 KB
This package contains the header and library files needed to build software
using libxcb-ewmh, providing client and window-manager helpers for EWMH.
The xcb-util module provides a number of libraries which sit on top of
libxcb, the core X protocol library, and some of the extension
libraries. These experimental libraries provide convenience functions
and interfaces which make the raw X protocol more usable. Some of the
libraries also provide client-side code which is not strictly part of
the X protocol but which have traditionally been provided by Xlib.

Alternatives

Package Version Architecture Repository
libxcb-ewmh-dev_0.4.1-1ubuntu1_i386.deb 0.4.1 i386 Ubuntu Main
libxcb-ewmh-dev - - -

Requires

Name Value
libxcb-ewmh2 = 0.4.1-1ubuntu1
libxcb1-dev -

Conflicts

Name Value
libxcb-ewmh1-dev -

Replaces

Name Value
libxcb-ewmh1-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libxcb-ewmh-dev_0.4.1-1ubuntu1_amd64.deb
Source Package xcb-util-wm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxcb-ewmh-dev deb package:
    # sudo apt-get install libxcb-ewmh-dev

Files

Path
/usr/include/xcb/xcb_ewmh.h
/usr/lib/x86_64-linux-gnu/libxcb-ewmh.a
/usr/lib/x86_64-linux-gnu/libxcb-ewmh.so
/usr/lib/x86_64-linux-gnu/pkgconfig/xcb-ewmh.pc
/usr/share/doc/libxcb-ewmh-dev/NEWS.gz
/usr/share/doc/libxcb-ewmh-dev/README
/usr/share/doc/libxcb-ewmh-dev/changelog.Debian.gz
/usr/share/doc/libxcb-ewmh-dev/copyright

Changelog

2014-02-19 - Steve Langasek <steve.langasek@ubuntu.com>
xcb-util-wm (0.4.1-1ubuntu1) trusty; urgency=medium
* Merge from Debian unstable, remaining changes:
- Use dh-autoreconf.
2014-02-19 - Arnaud Fontaine <arnau@debian.org>
xcb-util-wm (0.4.1-1) unstable; urgency=medium
* New upstream release.
+ Useless pkgconfig depends on xcb-proto has been removed. Closes: #722632.
+ debian/control:
- Bump xutils-dev B-D to >= 1:7.7~1~ because util-macros >= 1.16.0
is now required.
* debian/control: Make Vcs-* fields URIs canonical (lintian warning).
2013-12-12 - Steve Langasek <steve.langasek@ubuntu.com>
xcb-util-wm (0.3.9-2ubuntu1) trusty; urgency=medium
* Use dh-autoreconf.
2012-06-13 - Arnaud Fontaine <arnau@debian.org>
xcb-util-wm (0.3.9-2) unstable; urgency=low
* debian/control:
+ Revert renaming of libxcb-ewmh1-dev to libxcb-ewmh2-dev as a -dev
package should not be versioned, so rename it to libxcb-ewmh-dev.
2012-06-10 - Arnaud Fontaine <arnau@debian.org>
xcb-util-wm (0.3.9-1) unstable; urgency=low
* New upstream release.
+ debian/rules: do not remove autogen.sh (shipped) and Doxyfile (deleted).
+ debian/control: rename libxcb-ewmh* following SONAME bump.
* debian/control:
+ Fix duplicated short description on development package.
+ Bump Standards-Version to 3.9.3.
- debian/copyright: switch to machine-readable format.
2011-05-06 - Arnaud Fontaine <arnau@debian.org>
xcb-util-wm (0.3.8-1) unstable; urgency=low
* New upstream release.
+ xcb-util has been split up into several modules, so rename
source package.
* debian/control:
+ Bump Standards-Version to 3.9.2. No changes needed.
+ Now maintain as part of pkg-xorg team.
* Switch to "3.0 (quilt)" source format.
2009-08-24 - Julien Danjou <acid@debian.org>
xcb-util (0.3.6-1) unstable; urgency=low
* New upstream release
* Bump standard version
2009-05-29 - Julien Danjou <acid@debian.org>
xcb-util (0.3.5-1) unstable; urgency=low
* New upstream release
2009-04-15 - Julien Danjou <acid@debian.org>
xcb-util (0.3.4-1) unstable; urgency=low
* New upstream release
+ Bump version of keysyms
+ Remove wm library
* Bump standard version
2009-02-15 - Julien Danjou <acid@debian.org>
xcb-util (0.3.3-2) unstable; urgency=low
* Add versioned link to GPL.

See Also

Package Description
libxcb-ewmh2_0.4.1-1ubuntu1_amd64.deb utility libraries for X C Binding -- ewmh
libxcb-glx0-dev_1.11.1-1ubuntu1_amd64.deb X C Binding, glx extension, development files
libxcb-glx0_1.11.1-1ubuntu1_amd64.deb X C Binding, glx extension
libxcb-icccm4-dev_0.4.1-1ubuntu1_amd64.deb utility libraries for X C Binding -- icccm, development files
libxcb-icccm4_0.4.1-1ubuntu1_amd64.deb utility libraries for X C Binding -- icccm
libxcb-image0-dev_0.4.0-1build1_amd64.deb utility libraries for X C Binding -- image, development files
libxcb-image0_0.4.0-1build1_amd64.deb utility libraries for X C Binding -- image
libxcb-keysyms1-dev_0.4.0-1_amd64.deb utility libraries for X C Binding -- keysyms, development files
libxcb-keysyms1_0.4.0-1_amd64.deb utility libraries for X C Binding -- keysyms
libxcb-present-dev_1.11.1-1ubuntu1_amd64.deb X C Binding, present extension, development files
libxcb-present0_1.11.1-1ubuntu1_amd64.deb X C Binding, present extension
libxcb-randr0-dev_1.11.1-1ubuntu1_amd64.deb X C Binding, randr extension, development files
libxcb-randr0_1.11.1-1ubuntu1_amd64.deb X C Binding, randr extension
libxcb-record0-dev_1.11.1-1ubuntu1_amd64.deb X C Binding, record extension, development files
libxcb-record0_1.11.1-1ubuntu1_amd64.deb X C Binding, record extension
Advertisement
Advertisement