libwrap0_7.6.q-25_amd64.deb


Advertisement

Description

libwrap0 - Wietse Venema's TCP wrappers library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libwrap0_7.6.q-25_amd64.deb
Package name libwrap0
Package version 7.6.q
Package release 25
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 45.08 KB
Installed size 121.00 KB
Wietse Venema's network logger, also known as TCPD or LOG_TCP.
These programs log the client host name of incoming telnet,
ftp, rsh, rlogin, finger etc. requests.
Security options are:
- access control per host, domain and/or service;
- detection of host name spoofing or host address spoofing;
- booby traps to implement an early-warning system.

Alternatives

Package Version Architecture Repository
libwrap0_7.6.q-25_i386.deb 7.6.q i386 Ubuntu Main
libwrap0 - - -

Requires

Name Value
libc6 >= 2.14
multiarch-support -

Replaces

Name Value
tcpd << 7.6.q-20

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libwrap0_7.6.q-25_amd64.deb
Source Package tcp-wrappers

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwrap0 deb package:
    # sudo apt-get install libwrap0

Files

Path
/lib/x86_64-linux-gnu/libwrap.so.0
/lib/x86_64-linux-gnu/libwrap.so.0.7.6
/usr/share/doc/libwrap0/README.Debian
/usr/share/doc/libwrap0/README.gz
/usr/share/doc/libwrap0/changelog.Debian.gz
/usr/share/doc/libwrap0/copyright
/usr/share/man/man5/hosts.allow.5.gz
/usr/share/man/man5/hosts.deny.5.gz
/usr/share/man/man5/hosts_access.5.gz
/usr/share/man/man5/hosts_options.5.gz

Changelog

2013-12-30 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-25) unstable; urgency=medium
* Replace portmap with rpcbind in the hosts.* files comments.
(Closes: #722230)
* Update patch fix_warnings: fix the declaration of fix_options().
(Closes: #710391)
2012-07-30 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-24) unstable; urgency=low
* Do not remove /etc/hosts.{allow,deny} on purge of libwrap0 if it is
installed for multiple architectures. (Closes: #682425)
Patch courtesy of Jonathan Nieder.
2012-02-19 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-23) unstable; urgency=medium
* Correctly install libwrap.{a,so} in the multiarch directory.
(Closes: #658765)
2011-12-05 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-22) unstable; urgency=medium
* Added patch ignore_missing_inetdconf: stop tcpdmatch and tcpdchk
from aborting if /etc/inetd.conf does not exist. (Closes: #650826)
* Enabled hardening with dpkg-buildflags, and this time for real.
* libwrap0-dev marked "Multi-Arch: same".
* Added patch initgroups: properly set supplementary group IDs, taken
from the Red Hat package.
2011-06-24 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-21) unstable; urgency=medium
* Added the proper Breaks/Replaces directives to deal with the man pages
moved in 7.6.q-20. (Closes: #631252, #631311)
* Enabled IPv6 support for the Hurd build. (Closes: #631247)
* Enabled hardening with hardening-includes.
2011-06-21 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-20) unstable; urgency=low
* Added patch fix_parsing_long_lines: fixes the /etc/hosts.{allow,deny}
parser to properly detect lines longer than 2047 characters which
would cause the caller to hang forever in a loop. (Closes: #596261)
* Fixed the link ordering of the shared library, patch courtesy of
Matthias Klose of Ubuntu. (Closes: #609598)
* Moved the *.5 man pages from tcpd to libwrap0. (Closes: #630244)
* Converted to multiarch the libwrap0 and tcpd packages.
* Switched to debhelper level 8.
* Hopefully added proper support for overriding CFLAGS and LDFLAGS.
* Removed the -D_REENTRANT flag which has been useless since libc6.
2010-05-23 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-19) unstable; urgency=low
* Made piuparts happy by removing /etc/hosts.{allow,deny} on purge, even
if the package is never purged on real systems.
* Moved the documentation in libwrap0 and made the documentation
directory of the other packages a symlink.
* Converted to source format 3.0 (quilt).
* Switched to debhelper level 7.
2009-07-02 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-18) unstable; urgency=medium
* Updated 13_shlib_weaksym again to make the library build even if
libwrap0-dev is not installed. (Closes: #535509)
2009-07-02 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-17) unstable; urgency=medium
* Moved the creation of /etc/hosts.{allow,deny} from tcpd to libwrap0.
* Removed the debconf question.
* tcpd demoted from important to standard priority.
* Updated 13_shlib_weaksym: make the symbols in libwrap weak for real.
(Closes: #531942)
2008-07-26 - Marco d'Itri <md@linux.it>
tcp-wrappers (7.6.q-16) unstable; urgency=low
* New debconf translation: sk. (Closes: #489267)
* Updated debconf translations: gl, sv, es, ro.
(Closes: #480968, #483768, #488606, #488889)

See Also

Package Description
libwvstreams-dev_4.6.1-7_amd64.deb Development libraries and header files for libwvstreams4.6
libwvstreams4.6-base_4.6.1-7_amd64.deb C++ network libraries for rapid application development
libwvstreams4.6-doc_4.6.1-7_all.deb Documentation for WvStreams
libwvstreams4.6-extras_4.6.1-7_amd64.deb C++ network libraries for rapid application development
libwww-perl_6.15-1_all.deb simple and consistent interface to the world-wide web
libwww-robotrules-perl_6.01-1_all.deb database of robots.txt-derived permissions
libx11-6_1.6.3-1ubuntu2_amd64.deb X11 client-side library
libx11-data_1.6.3-1ubuntu2_all.deb X11 client-side library
libx11-dev_1.6.3-1ubuntu2_amd64.deb X11 client-side library (development headers)
libx11-doc_1.6.3-1ubuntu2_all.deb X11 client-side library (development documentation)
libx11-protocol-perl_0.56-7_all.deb Perl module for the X Window System Protocol, version 11
libx11-xcb-dev_1.6.3-1ubuntu2_amd64.deb Xlib/XCB interface library (development headers)
libx11-xcb1_1.6.3-1ubuntu2_amd64.deb Xlib/XCB interface library
libx32asan2_5.3.1-14ubuntu2_amd64.deb AddressSanitizer -- a fast memory error detector (x32)
libx32atomic1_5.3.1-14ubuntu2_amd64.deb support library providing __atomic built-in functions (x32)
Advertisement
Advertisement