libwmf0.2-7-gtk_0.2.8.4-10.5ubuntu1_amd64.deb


Advertisement

Description

libwmf0.2-7-gtk - Windows metafile conversion library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libwmf0.2-7-gtk_0.2.8.4-10.5ubuntu1_amd64.deb
Package name libwmf0.2-7-gtk
Package version 0.2.8.4
Package release 10.5ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.90 KB
Installed size 33.00 KB
Windows metafile (WMF) is a picture format used by many Windows
programs, e.g. Microsoft Word.  libwmf is a library for interpreting
metafile images and either displaying them using X or converting them
to standard formats such as PNG, JPEG, PS, EPS and SVG(Z)...
This package contains the GTK pixbuf plugin.

Alternatives

Package Version Architecture Repository
libwmf0.2-7-gtk_0.2.8.4-10.5ubuntu1_i386.deb 0.2.8.4 i386 Ubuntu Main
libwmf0.2-7-gtk - - -

Requires

Name Value
libc6 >= 2.4
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.12.0
libwmf0.2-7 = 0.2.8.4-10.5ubuntu1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libwmf0.2-7-gtk_0.2.8.4-10.5ubuntu1_amd64.deb
Source Package libwmf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwmf0.2-7-gtk deb package:
    # sudo apt-get install libwmf0.2-7-gtk

Files

Path
/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/io-wmf.so
/usr/share/doc/libwmf0.2-7-gtk/changelog.Debian.gz
/usr/share/doc/libwmf0.2-7-gtk/copyright

Changelog

2016-01-27 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libwmf (0.2.8.4-10.5ubuntu1) xenial; urgency=medium
* Merge from Debian unstable. Remaining changes:
- Split out GTK plugin into separate package.
2016-01-22 - Gianfranco Costamagna <locutusofborg@debian.org>
libwmf (0.2.8.4-10.5) unstable; urgency=medium
* Non-maintainer upload.
* Change libpng12-dev build-dependency to libpng-dev, to ease libpng
transition. (Closes: #662416)
2016-01-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libwmf (0.2.8.4-10.4ubuntu1) xenial; urgency=medium
* Merge from Debian unstable. Remaining changes:
- Split out GTK plugin into separate package.
2015-07-30 - Alessandro Ghedini <ghedo@debian.org>
libwmf (0.2.8.4-10.4) unstable; urgency=high
* NMU from the Security Team
* Fix multiple vulnerabilities:
- CVE-2015-0848 (Closes: #790365)
- CVE-2015-4588 (Closes: #787644)
- CVE-2015-4695 (Closes: #784205)
- CVE-2015-4696 (Closes: #784192)
* Fix lintian override
2015-07-07 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libwmf (0.2.8.4-10.3ubuntu2) wily; urgency=medium
* SECURITY UPDATE: denial of service and possible code execution
- d/p/CVE-2015-0848_CVE-2015-4588_CVE-2015-4695_CVE-2015-4696.patch:
check bounds and handle unexpected pixel depth in src/player/meta.h,
src/ipa/ipa.h,  src/ipa/ipa/bmp.h.
- CVE-2015-0848
- CVE-2015-4588
- CVE-2015-4685
- CVE-2015-4696
2013-02-24 - Logan Rosen <logatronico@gmail.com>
libwmf (0.2.8.4-10.3ubuntu1) raring; urgency=low
* Merge from Debian unstable. Remaining changes:
- Split out GTK plugin into separate package.
2013-02-21 - Andreas Beckmann <anbe@debian.org>
libwmf (0.2.8.4-10.3) unstable; urgency=low
* Non-maintainer upload.
* libwmf-{dev,doc}.preinst: Delete /usr/share/doc/$PKG if it is a symlink
because this is now shipped as a regular directory.  (Closes: #700353)
2012-12-10 - Logan Rosen <logatronico@gmail.com>
libwmf (0.2.8.4-10.2ubuntu1) raring; urgency=low
* Merge from Debian unstable. Remaining changes:
- Split out GTK plugin into separate package.
2012-11-29 - Helmut Grohne <helmut@subdivi.de>
libwmf (0.2.8.4-10.2) unstable; urgency=low
* Non-maintainer upload.
* Add Multi-Arch headers. (Closes: #677786)
The support was basically there. libwmf0.2-7 already ships libraries in
/usr/lib/<triplet>. No changes besides adding headers were necessary.
2012-10-31 - Colin Watson <cjwatson@ubuntu.com>
libwmf (0.2.8.4-10.1ubuntu1) raring; urgency=low
* Resynchronise with Debian.  Remaining changes:
- Split out GTK plugin into separate package.
* Drop no-op prerm in libwmf0.2-7, only needed for upgrades from
pre-12.04.

See Also

Package Description
libwmf0.2-7_0.2.8.4-10.5ubuntu1_amd64.deb Windows metafile conversion library
libwnck-3-0_3.14.1-2_amd64.deb Window Navigator Construction Kit - runtime files
libwnck-3-common_3.14.1-2_all.deb Window Navigator Construction Kit - common files
libwnck-3-dev_3.14.1-2_amd64.deb Window Navigator Construction Kit - development files
libwpd-0.10-10_0.10.1-1ubuntu1_amd64.deb Library for handling WordPerfect documents (shared library)
libwpd-dev_0.10.1-1ubuntu1_amd64.deb Library for handling WordPerfect documents (development)
libwpd-doc_0.10.1-1ubuntu1_all.deb Library for handling WordPerfect documents (documentation)
libwpg-0.3-3_0.3.1-1ubuntu1_amd64.deb WordPerfect graphics import/convert library (shared library)
libwpg-dev_0.3.1-1ubuntu1_amd64.deb WordPerfect graphics import/convert library (development)
libwpg-doc_0.3.1-1ubuntu1_all.deb WordPerfect graphics import/convert library (documentation)
libwps-0.4-4_0.4.3-1ubuntu1_amd64.deb Works text file format import filter library (shared library)
libwps-dev_0.4.3-1ubuntu1_amd64.deb Works text file format import filter library (development)
libwps-doc_0.4.3-1ubuntu1_all.deb Works text file format import filter library (documentation)
libwrap0-dev_7.6.q-25_amd64.deb Wietse Venema's TCP wrappers library, development files
libwrap0_7.6.q-25_amd64.deb Wietse Venema's TCP wrappers library
Advertisement
Advertisement