libwhoopsie0_0.2.52_amd64.deb


Advertisement

Description

libwhoopsie0 - Ubuntu error tracker submission - shared library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libwhoopsie0_0.2.52_amd64.deb
Package name libwhoopsie0
Package version 0.2.52
Package release -
Package architecture amd64
Package type deb
Category libs
Homepage http://wiki.ubuntu.com/ErrorTracker
License -
Maintainer Evan Dandrea <ev@ubuntu.com>
Download size 9.70 KB
Installed size 43.00 KB
This library provides methods to generate an identifier for use with the
Ubuntu error tracker

Alternatives

Package Version Architecture Repository
libwhoopsie0_0.2.52.5ubuntu0.1_i386.deb 0.2.52.5ubuntu0.1 i386 Ubuntu Updates Main
libwhoopsie0_0.2.52.5ubuntu0.1_amd64.deb 0.2.52.5ubuntu0.1 amd64 Ubuntu Updates Main
libwhoopsie0_0.2.52_i386.deb 0.2.52 i386 Ubuntu Main
libwhoopsie0 - - -

Requires

Name Value
libc6 >= 2.4
libgcrypt20 >= 1.6.1
libglib2.0-0 >= 2.32

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libwhoopsie0_0.2.52_amd64.deb
Source Package whoopsie

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwhoopsie0 deb package:
    # sudo apt-get install libwhoopsie0

Files

Path
/usr/lib/x86_64-linux-gnu/libwhoopsie.so.0
/usr/lib/x86_64-linux-gnu/libwhoopsie.so.0.0
/usr/share/doc/libwhoopsie0/changelog.gz
/usr/share/doc/libwhoopsie0/copyright

Changelog

2016-03-17 - Barry Warsaw <barry@ubuntu.com>
whoopsie (0.2.52) xenial; urgency=medium
* src/whoopsie.c: Preserve TABs in crash data.  (LP: #1390627)
* debian/control: Build-Depend on pyflakes3.
2016-01-28 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.51) xenial; urgency=medium
[ Matthias Klose ]
* Multiarchify the library packages.
* Convert scripts to Python3.
[ Brian Murray ]
* Use pyflakes3 not pyflakes in the Makefile.
2015-11-03 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.50) xenial; urgency=medium
* src/whoopsie.c: Move UnreportableReason from fields we don't send to
errors to fields we do, that way we know apport's opinion of the crash.
(LP: #1382233)
2015-10-07 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.49) wily; urgency=medium
[ Evan Dandrea ]
* Helper to create recoverable problem reports. Thanks Ted Gould!
[ Brian Murray ]
* Switch build-depends from transitional libgcrypt11-dev to libgcrypt20-dev.
Thanks to Robert Ancell.
* Only publish the CRASH_DB_IDENTIFIER on the file system if it was not
set via an environmental variable. (LP: #1389357)
2015-05-13 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.48) wily; urgency=medium
* data/whoopsie.service: remove check for ubiquity-dm so that whoopsie
will run again on the Live CD.
2015-03-12 - Didier Roche <didrocks@ubuntu.com>
whoopsie (0.2.47) vivid; urgency=medium
[ Didier Roche ]
* Remove /etc/default/whoopsie conffile and avoid upgrade prompt:
(LP: #1431432)
- debian/whoopsie.maintscript: get it removed on upgrade
- debian/whoopsie.preinst: copy the optional report_metrics value if set
by gnome-control-center capplet to /etc/whoopsie (not a conffile).
(LP: #1412719)
Refactor the logic for caching report_crashes as well.
- debian/whoopsie.postinst: enhance the logic to ensure we don't have the
service started after upgrade and keep it disable if it was disabled
- Makefile, data/whoopsie: remove the conffile so that we don't ship it
* Bump Standards-Version
[ Michael Blennerhassett ]
* Under upstart: Set the WAIT_STATE to get wait-for-state to do something
useful. GOAL is also not needed.
2015-02-05 - Ricardo Salveti de Araujo <ricardo.salveti@canonical.com>
whoopsie (0.2.46) vivid; urgency=medium
* debian/whoopsie.init: Reverting previous change as it makes whoopsie
upstart job to get in an infinite loop when starting the service (needs
to be better investigated first)
2015-02-02 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.45) vivid; urgency=medium
* Merge patch from Bryan Quigley to only log when whoopsie's state changes.
(LP: #1217407)
2015-01-15 - Martin Pitt <martin.pitt@ubuntu.com>
whoopsie (0.2.44) vivid; urgency=medium
* debian/whoopsie.init: Make this actually work.
2014-12-17 - Brian Murray <brian@ubuntu.com>
whoopsie (0.2.43) vivid; urgency=medium
* Remove .crash file if we are unable to create a .uploaded file for it
to prevent trying to upload the same crash file multiple times.
(LP: #1392412)
* Avoid buffer overflow when parsing reports. Thanks to John-Mark Bell for
the patch. (LP: #1397340)

See Also

Package Description
libwind0-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - stringprep implementation
libwinpr-asn1-0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (ASN1 library)
libwinpr-bcrypt0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (bcrypt library)
libwinpr-credentials0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (credentials library)
libwinpr-credui0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (credeui library)
libwinpr-crt0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (crt library)
libwinpr-crypto0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (crypto library)
libwinpr-dev_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (development files)
libwinpr-dsparse0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (dsparse library)
libwinpr-environment0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (environment library)
libwinpr-error0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (error library)
libwinpr-file0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (file library)
libwinpr-handle0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (handle library)
libwinpr-heap0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (heap library)
libwinpr-input0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (input library)
Advertisement
Advertisement