libwebkit2gtk-4.0-37_2.10.9-1ubuntu1_amd64.deb


Advertisement

Description

libwebkit2gtk-4.0-37 - Web content engine library for GTK+

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libwebkit2gtk-4.0-37_2.10.9-1ubuntu1_amd64.deb
Package name libwebkit2gtk-4.0-37
Package version 2.10.9
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://webkitgtk.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.68 MB
Installed size 35.68 MB
WebKit is a web content engine, derived from KHTML and KJS from KDE, and
used primarily in Apple's Safari browser.  It is made to be embedded in
other applications, such as mail readers, or web browsers.
It is able to display content such as HTML, SVG, XML, and others. It also
supports DOM, XMLHttpRequest, XSLT, CSS, JavaScript/ECMAScript and more.
WebKit2 is an API layer for WebKit designed from the ground up to
support a split process model, where the web content lives in a
separate process from the application UI.
This build comes from the GTK+ port of WebKit (API version 4.0).
This is the library for embedding in GTK+ applications.

Alternatives

Package Version Architecture Repository
libwebkit2gtk-4.0-37_2.20.5-0ubuntu0.16.04.1_i386.deb 2.20.5 i386 Ubuntu Updates Main
libwebkit2gtk-4.0-37_2.20.5-0ubuntu0.16.04.1_amd64.deb 2.20.5 amd64 Ubuntu Updates Main
libwebkit2gtk-4.0-37_2.10.9-1ubuntu1_i386.deb 2.10.9 i386 Ubuntu Main
libwebkit2gtk-4.0-37 - - -

Requires

Name Value
libatk1.0-0 >= 2.12.0
libc6 >= 2.14
libcairo2 >= 1.14.0
libegl1-mesa >= 7.8.1
libegl1-x11 -
libenchant1c2a >= 1.6.0
libfontconfig1 >= 2.11.1
libfreetype6 >= 2.2.1
libgcc1 >= 1:4.0
libgdk-pixbuf2.0-0 >= 2.22.0
libgeoclue0 >= 0.11.1+git20091217
libgl1 -
libgl1-mesa-glx -
libglib2.0-0 >= 2.37.3
libgstreamer-plugins-base1.0-0 >= 1.2.0
libgstreamer1.0-0 >= 1.4.0
libgtk-3-0 >= 3.16.2
libharfbuzz-icu0 >= 0.9.18
libharfbuzz0b >= 0.9.18
libhyphen0 >= 2.7.1
libicu55 >= 55.1-1~
libjavascriptcoregtk-4.0-18 = 2.10.9-1ubuntu1
libjpeg8 >= 8c
libnotify4 >= 0.7.0
libpango-1.0-0 >= 1.30.0
libpng12-0 >= 1.2.13-4
libsecret-1-0 >= 0.7
libsoup2.4-1 >= 2.44.0
libsqlite3-0 >= 3.7.15
libstdc++6 >= 5.2
libwayland-client0 >= 1.3.92
libwayland-egl1 -
libwayland-egl1-mesa >= 10.0.2
libwayland-server0 >= 1.0.2
libwebp5 >= 0.4.3
libx11-6 -
libxcomposite1 >= 1:0.3-1
libxdamage1 >= 1:1.1
libxml2 >= 2.7.4
libxslt1.1 >= 1.1.25
zlib1g >= 1:1.2.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libwebkit2gtk-4.0-37_2.10.9-1ubuntu1_amd64.deb
Source Package webkit2gtk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwebkit2gtk-4.0-37 deb package:
    # sudo apt-get install libwebkit2gtk-4.0-37

Files

Path
/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37
/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37.11.12
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/MiniBrowser
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitDatabaseProcess
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitNetworkProcess
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitPluginProcess
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProcess
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
/usr/share/doc/libwebkit2gtk-4.0-37/NEWS.Debian.gz
/usr/share/doc/libwebkit2gtk-4.0-37/changelog.Debian.gz
/usr/share/doc/libwebkit2gtk-4.0-37/copyright
/usr/share/lintian/overrides/libwebkit2gtk-4.0-37

Changelog

2016-03-23 - Iain Lane <iain.lane@canonical.com>
webkit2gtk (2.10.9-1ubuntu1) xenial; urgency=medium
* Merge with Debian unstable. Remaining changes:
+ Build with GeoClue 1, which is what we still use in Ubuntu.
2016-03-18 - Alberto Garcia <berto@igalia.com>
webkit2gtk (2.10.9-1) unstable; urgency=medium
* New upstream release.
2016-03-15 - Iain Lane <iain@orangesquash.org.uk>
webkit2gtk (2.10.8-1ubuntu1) xenial; urgency=low
* Build with GeoClue 1, which is what we still use in Ubuntu.
2016-03-12 - Alberto Garcia <berto@igalia.com>
webkit2gtk (2.10.8-1) unstable; urgency=high
* New upstream release. This fixes CVE-2016-1726 (Closes: #802380).
* Allow building the package with debhelper < 9.20151219. This won't
produce any debug packages (since they are automatically generated
now), but it can be useful for backports.
+ debian/control:
- Revert build dependency on debhelper back to >= 9.
+ debian/rules:
- Don't make dh_strip fail if it doesn't support --ddeb-migration.
* debian/rules:
+ The list of architectures in which the debug packages are causing
problems continues to grow, so let's try the opposite approach: we
build by default using -g1 except in the cases where we know that
-g works fine (amd64, ppc64, ppc64el).
+ Enable all hardening flags.
* debian/patches/fix-ftbfs-m68k.patch:
+ Enclose the changes to the compile assertions inside an #ifdef block
so they only apply to m68k.
* debian/patches/fix-ftbfs-alpha.patch:
+ Fix FTBFS in alpha (Closes: #815124).
* debian/patches/fix-ftbfs-sparc64.patch:
+ Add patch metadata.
* debian/source/lintian-overrides:
+ Update overrides so the latest lintian doesn't give more
source-is-missing false positives.
* debian/control:
+ Bump Standards-Version to 3.9.7; no changes needed.
+ Use secure URIs for the Vcs-* fields.
2016-02-12 - Iain Lane <iain@orangesquash.org.uk>
webkit2gtk (2.10.6-1ubuntu1) xenial; urgency=medium
* Build with GeoClue 1, which is what we still use in Ubuntu.
2016-01-27 - Alberto Garcia <berto@igalia.com>
webkit2gtk (2.10.6-1) unstable; urgency=medium
* New upstream release.
2016-01-21 - Alberto Garcia <berto@igalia.com>
webkit2gtk (2.10.5-1) unstable; urgency=high
* New upstream release. Fixes CVE-2015-7096 and CVE-2015-7098.
This release doesn't contain any non-DFSG files in the original
tarball, so we can ship it as-is and remove the +dfsg suffix from the
Debian version.
+ debian/watch:
- Remove the 'dversionmangle' option.
+ debian/rules:
- Remove the get-orig-source target.
- Don't generate (and clean) jquery.min.js.
+ debian/control:
- Remove build dependency on slimit.
+ debian/jquery-1.9.1.js:
- Remove.
* debian/patches/fix-ftbfs-sparc64.patch:
+ Fix FTBFS on sparc64 (Closes: #806816).
* debian/rules:
+ Don't pass -DENABLE_YARR_JIT=0, passing -DENABLE_JIT=OFF already
takes care of that.
+ Remove EXTRA_DH_ARGUMENTS, this is no longer being used.
* debian/watch:
+ Only scan releases from the stable branches.
* Migrate to automatic -dbgsym packages:
+ debian/control:
- Remove the entries for libjavascriptcoregtk-4.0-18-dbg and
libwebkit2gtk-4.0-37-dbg.
- Require debhelper >= 9.20151219.
+ debian/rules:
- Replace --dbg-package with --ddeb-migration in dh_strip.
* debian/copyright:
+ Update copyright years.
+ Remove mentions to jquery (which is no longer included) and
FontWithNoValidEncoding.fon, which is a regular font in the FON file
format.

See Also

Package Description
libwebkit2gtk-4.0-dev_2.10.9-1ubuntu1_amd64.deb Web content engine library for GTK+ - development files
libwebkit2gtk-4.0-doc_2.10.9-1ubuntu1_all.deb Web content engine library for GTK+ - documentation
libwebp-dev_0.4.4-1_amd64.deb Lossy compression of digital photographic images
libwebp5_0.4.4-1_amd64.deb Lossy compression of digital photographic images
libwebpdemux1_0.4.4-1_amd64.deb Lossy compression of digital photographic images
libwebpmux1_0.4.4-1_amd64.deb Lossy compression of digital photographic images
libwebrtc-audio-processing-0_0.1-3ubuntu1~gcc5.1_amd64.deb AudioProcessing module from the WebRTC project
libwebrtc-audio-processing-dev_0.1-3ubuntu1~gcc5.1_amd64.deb development files for the webrtc-audio-processing library
libwhoopsie-dev_0.2.52_amd64.deb Ubuntu error tracker submission - library development files
libwhoopsie-preferences-dev_0.18_amd64.deb Ubuntu error tracker submission settings - library development files
libwhoopsie-preferences0_0.18_amd64.deb Ubuntu error tracker submission settings - shared library
libwhoopsie0_0.2.52_amd64.deb Ubuntu error tracker submission - shared library
libwind0-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - stringprep implementation
libwinpr-asn1-0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (ASN1 library)
libwinpr-bcrypt0.1_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb Windows Portable Runtime library (bcrypt library)
Advertisement
Advertisement