libvpx3_1.5.0-2ubuntu1_amd64.deb


Advertisement

Description

libvpx3 - VP8 and VP9 video codec (shared library)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libvpx3_1.5.0-2ubuntu1_amd64.deb
Package name libvpx3
Package version 1.5.0
Package release 2ubuntu1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.webmproject.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 714.52 KB
Installed size 2.18 MB
VP8 and VP9 are open video codecs, originally developed by On2 and released
as open source by Google Inc. They are the successor of the VP3 codec,
on which the Theora codec was based.
This package contains the shared libraries.

Alternatives

Package Version Architecture Repository
libvpx3_1.5.0-2ubuntu1_i386.deb 1.5.0 i386 Ubuntu Main
libvpx3 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libvpx3_1.5.0-2ubuntu1_amd64.deb
Source Package libvpx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvpx3 deb package:
    # sudo apt-get install libvpx3

Files

Path
/usr/lib/x86_64-linux-gnu/libvpx.so.3
/usr/lib/x86_64-linux-gnu/libvpx.so.3.0
/usr/lib/x86_64-linux-gnu/libvpx.so.3.0.0
/usr/share/doc/libvpx3/AUTHORS.gz
/usr/share/doc/libvpx3/README.gz
/usr/share/doc/libvpx3/changelog.Debian.gz
/usr/share/doc/libvpx3/copyright

Changelog

2016-04-05 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
libvpx (1.5.0-2ubuntu1) xenial; urgency=medium
* Update to PHP7.0 build-dependencies (LP: #1566423).
2015-12-28 - Sebastian Dröge <slomo@debian.org>
libvpx (1.5.0-2) unstable; urgency=medium
* debian/rules:
+ Disable PPC specific target to fix FTBFS. It's not supported anymore.
2015-12-28 - Sebastian Dröge <slomo@debian.org>
libvpx (1.5.0-1) unstable; urgency=medium
* New upstream release:
+ debian/rules,
debian/control,
debian/libvpx*.symbols:
- Update from libvpx2 to libvpx3.
* debian/patches/fix-build.patch:
+ Fix invalid C that causes the build to fail (Closes: #809129).
Patch based on the one from Colin Watson from
https://bugs.launchpad.net/ubuntu/+source/libvpx/+bug/1528297
2015-06-23 - Sebastian Dröge <slomo@debian.org>
libvpx (1.4.0-4) unstable; urgency=medium
* debian/rules:
+ Configure with --size-limit=16384x16384 to work around
CVE-2015-1258 like Chrome does. Streams with a higher
resolution than that will fail to decode now.
+ Configure with --enable-postproc --enable-multi-res-encoding
--enable-temporal-denoising --enable-vp9-temporal-denoising
--enable-vp9-postproc to mirror the configuration that Chrome
is using.
2015-05-14 - Sebastian Dröge <slomo@debian.org>
libvpx (1.4.0-3) unstable; urgency=medium
* debian/rules:
+ Disable MIPS assembly in the rules for now to try to fix FTBFS. The
assembly is only used in the tools, not the library, and requires
DSP R2 support.
2015-05-13 - Sebastian Dröge <slomo@debian.org>
libvpx (1.4.0-2) unstable; urgency=medium
* Upload to unstable.
2015-04-13 - Sebastian Dröge <slomo@debian.org>
libvpx (1.4.0-1) experimental; urgency=medium
* New upstream stable release:
+ debian/control,
debian/rules,
debian/libvpx*symbols:
- Update for new soname.
2015-03-02 - Sebastian Dröge <slomo@debian.org>
libvpx (1.3.0+git20150219-1) experimental; urgency=medium
* New upstream GIT snapshot, based on the Chrome version from 2015-02-19:
+ debian/patches/Bug-fix-in-ssse3-quantize-function.patch,
debian/patches/vp9-out-of-bounds-access.patch:
- Deleted, merged upstream.
+ debian/patches/fix-armhf-link.patch:
- Rebased.
+ debian/libvpx1.symbols:
- Update for API changes, i.e. dropping of old non-public API and
addition of some new API.
2014-10-21 - Sebastian Dröge <slomo@debian.org>
libvpx (1.3.0-3) unstable; urgency=high
* debian/control:
+ Add VP9 to the short and long package descriptions (Closes: #760095).
* debian/patches/vp9-out-of-bounds-access.patch:
+ Fix out of bounds access in the VP9 codec (CVE-2014-1578) (Closes: #765435).
2014-08-09 - Matthias Klose <doko@debian.org>
libvpx (1.3.0-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Build using the default GCC. Closes: #751318.
* Move doxygen and php5-cli to B-D-I (Peter Pentchev). Closes: #726485.
* Build using hardening defaults. Closes: #674570.
* Apply bug fix for ssse3 quantize function.

See Also

Package Description
libvte-2.91-0_0.42.5-1ubuntu1_amd64.deb Terminal emulator widget for GTK+ 3.0 - runtime files
libvte-2.91-common_0.42.5-1ubuntu1_all.deb Terminal emulator widget for GTK+ 3.0 - common files
libvte-2.91-dev_0.42.5-1ubuntu1_amd64.deb Terminal emulator widget for GTK+ 3.0 - development files
libvte-2.91-doc_0.42.5-1ubuntu1_all.deb Terminal emulator widget for GTK+ 3.0 - documentation
libwacom-bin_0.18-1_amd64.deb Wacom model feature query library -- binaries
libwacom-common_0.18-1_all.deb Wacom model feature query library (common files)
libwacom-dev_0.18-1_amd64.deb Wacom model feature query library (development files)
libwacom2_0.18-1_amd64.deb Wacom model feature query library
libwavpack-dev_4.75.2-2_amd64.deb audio codec (lossy and lossless) - development files
libwavpack1_4.75.2-2_amd64.deb audio codec (lossy and lossless) - library
libwayland-client0_1.9.0-1_amd64.deb wayland compositor infrastructure - client library
libwayland-cursor0_1.9.0-1_amd64.deb wayland compositor infrastructure - cursor library
libwayland-dev_1.9.0-1_amd64.deb wayland compositor infrastructure - development files
libwayland-doc_1.9.0-1_all.deb wayland compositor infrastructure - documentation files
libwayland-egl1-mesa-lts-utopic_10_amd64.deb Transitional package for libwayland-egl1-mesa-lts-utopic
Advertisement
Advertisement