libvotequorum-dev_2.3.5-3ubuntu1_amd64.deb


Advertisement

Description

libvotequorum-dev - cluster engine Votequorum library development

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libvotequorum-dev_2.3.5-3ubuntu1_amd64.deb
Package name libvotequorum-dev
Package version 2.3.5
Package release 3ubuntu1
Package architecture amd64
Package type deb
Category libdevel
Homepage http://corosync.github.io/corosync/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.62 KB
Installed size 250.00 KB
The Corosync Cluster Engine is a Group Communication System with
additional features for implementing high availability within
applications. The project provides four C Application Programming
Interface features:
* A closed process group communication model with virtual synchrony
guarantees for creating replicated state machines.
* A simple availability manager that restarts the application process
when it has failed.
* A configuration and statistics in-memory database that provide the
ability to set, retrieve, and receive change notifications of
information.
* A quorum system that notifies applications when quorum is achieved
or lost.
This package contains the headers and other necessary files to build
applications or libraries that use the Votequorum library.

Alternatives

Package Version Architecture Repository
libvotequorum-dev_2.3.5-3ubuntu2.3_i386.deb 2.3.5 i386 Ubuntu Updates Main
libvotequorum-dev_2.3.5-3ubuntu2.3_amd64.deb 2.3.5 amd64 Ubuntu Updates Main
libvotequorum-dev_2.3.5-3ubuntu1_i386.deb 2.3.5 i386 Ubuntu Main
libvotequorum-dev - - -

Requires

Name Value
libvotequorum7 = 2.3.5-3ubuntu1

Replaces

Name Value
corosync << 1.99.9-1
corosync-dev << 1.99.9-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libvotequorum-dev_2.3.5-3ubuntu1_amd64.deb
Source Package corosync

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvotequorum-dev deb package:
    # sudo apt-get install libvotequorum-dev

Files

Path
/usr/include/corosync/votequorum.h
/usr/lib/x86_64-linux-gnu/libvotequorum.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libvotequorum.pc
/usr/share/doc/libvotequorum-dev/changelog.Debian.gz
/usr/share/doc/libvotequorum-dev/copyright
/usr/share/man/man3/votequorum_context_get.3.gz
/usr/share/man/man3/votequorum_context_set.3.gz
/usr/share/man/man3/votequorum_dispatch.3.gz
/usr/share/man/man3/votequorum_fd_get.3.gz
/usr/share/man/man3/votequorum_finalize.3.gz
/usr/share/man/man3/votequorum_getinfo.3.gz
/usr/share/man/man3/votequorum_initialize.3.gz
/usr/share/man/man3/votequorum_qdevice_master_wins.3.gz
/usr/share/man/man3/votequorum_qdevice_poll.3.gz
/usr/share/man/man3/votequorum_qdevice_register.3.gz
/usr/share/man/man3/votequorum_qdevice_unregister.3.gz
/usr/share/man/man3/votequorum_qdevice_update.3.gz
/usr/share/man/man3/votequorum_setexpected.3.gz
/usr/share/man/man3/votequorum_setvotes.3.gz
/usr/share/man/man3/votequorum_trackstart.3.gz
/usr/share/man/man3/votequorum_trackstop.3.gz
/usr/share/man/man8/votequorum_overview.8.gz

Changelog

2016-04-01 - Jorge Niedbalski <jorge.niedbalski@canonical.com>
corosync (2.3.5-3ubuntu1) xenial; urgency=high
* debian/patches/Totempg-Fix-memory-leak.patch: Fixes memory leak on 
Totempg. (LP: #1563089).
2015-10-22 - Ferenc Wágner <wferi@niif.hu>
corosync (2.3.5-3) unstable; urgency=medium
* [e64ff08] Really add arm64 support (Closes: #753289)
* [5e60e11] Enable the monitoring service on Linux architectures
* [9b635d5] Make libtotem-pg-dev usable by shipping corosync/list.h
2015-10-16 - Ferenc Wágner <wferi@niif.hu>
corosync (2.3.5-2) unstable; urgency=medium
* [e66dda1] Make sure environment variables are propagated by the init script
* [638b690] Mention the significance of cluster_name when creating shared LVM
VGs
* [48d88e3] Generalization may be acceptable for upstream, Debianization is
not
* [cd6437f] New patch Send-corosync-startup-notification-to-systemd.patch
* [f4da902] New patch Make-systemd-stop-and-restart-corosync-notifyd-if-
co.patch
* [1504fb9] New patch Send-corosync-notifyd-startup-notification-to-
system.patch
* [837ec3e] New patch Use-debian-changelog-timestamp-for-the-build-time-
of.patch
(Closes: #800662, #800663)
* [c96145c] libcorosync-common-dev takes over files from old corosync-dev
(Closes: #800923)
* [24f4fe9] New patch cmap_track_add.3.in-fix-typo-bellow-below.patch
* [ef858f3] Only Linux supports RDMA, let's omit it on other architectures
* [70989fd] Simplify debian/rules by providing .pc files for rdmacm and
ibverbs

See Also

Package Description
libvotequorum7_2.3.5-3ubuntu1_amd64.deb cluster engine Votequorum library
libvpx-dev_1.5.0-2ubuntu1_amd64.deb VP8 and VP9 video codec (development files)
libvpx-doc_1.5.0-2ubuntu1_all.deb VP8 and VP9 video codec (API documentation)
libvpx3_1.5.0-2ubuntu1_amd64.deb VP8 and VP9 video codec (shared library)
libvte-2.91-0_0.42.5-1ubuntu1_amd64.deb Terminal emulator widget for GTK+ 3.0 - runtime files
libvte-2.91-common_0.42.5-1ubuntu1_all.deb Terminal emulator widget for GTK+ 3.0 - common files
libvte-2.91-dev_0.42.5-1ubuntu1_amd64.deb Terminal emulator widget for GTK+ 3.0 - development files
libvte-2.91-doc_0.42.5-1ubuntu1_all.deb Terminal emulator widget for GTK+ 3.0 - documentation
libwacom-bin_0.18-1_amd64.deb Wacom model feature query library -- binaries
libwacom-common_0.18-1_all.deb Wacom model feature query library (common files)
libwacom-dev_0.18-1_amd64.deb Wacom model feature query library (development files)
libwacom2_0.18-1_amd64.deb Wacom model feature query library
libwavpack-dev_4.75.2-2_amd64.deb audio codec (lossy and lossless) - development files
libwavpack1_4.75.2-2_amd64.deb audio codec (lossy and lossless) - library
libwayland-client0_1.9.0-1_amd64.deb wayland compositor infrastructure - client library
Advertisement
Advertisement