libvirt0_1.3.1-1ubuntu10_amd64.deb


Advertisement

Description

libvirt0 - library for interfacing with different virtualization systems

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libvirt0_1.3.1-1ubuntu10_amd64.deb
Package name libvirt0
Package version 1.3.1
Package release 1ubuntu10
Package architecture amd64
Package type deb
Category devel
Homepage http://libvirt.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.07 MB
Installed size 3.84 MB
Libvirt is a C toolkit to interact with the virtualization capabilities
of recent versions of Linux (and other OSes). The library aims at providing
a long term stable C API for different virtualization mechanisms. It currently
supports QEMU, KVM, XEN, OpenVZ, LXC, and VirtualBox.

Alternatives

Package Version Architecture Repository
libvirt0_1.3.1-1ubuntu10.28_i386.deb 1.3.1 i386 Ubuntu Proposed Main
libvirt0_1.3.1-1ubuntu10.28_amd64.deb 1.3.1 amd64 Ubuntu Proposed Main
libvirt0_1.3.1-1ubuntu10.27_i386.deb 1.3.1 i386 Ubuntu Updates Main
libvirt0_1.3.1-1ubuntu10.27_amd64.deb 1.3.1 amd64 Ubuntu Updates Main
libvirt0_1.3.1-1ubuntu10_i386.deb 1.3.1 i386 Ubuntu Main
libvirt0 - - -

Requires

Name Value
libapparmor1 >= 2.6~devel
libaudit1 >= 1:2.2.1
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libc6 >= 2.17
libcap-ng0 -
libcurl3-gnutls >= 7.28.0
libdbus-1-3 >= 1.9.14
libdevmapper1.02.1 >= 2:1.02.20
libgnutls30 >= 3.4.2
libnl-3-200 >= 3.2.7
libnuma1 -
libsasl2-2 -
libsystemd0 -
libxen-4.6 >= 4.6.0
libxml2 >= 2.7.4
libyajl2 >= 2.0.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libvirt0_1.3.1-1ubuntu10_amd64.deb
Source Package libvirt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvirt0 deb package:
    # sudo apt-get install libvirt0

Files

Path
/usr/lib/x86_64-linux-gnu/libvirt-admin.so.0
/usr/lib/x86_64-linux-gnu/libvirt-admin.so.0.1003.1
/usr/lib/x86_64-linux-gnu/libvirt-lxc.so.0
/usr/lib/x86_64-linux-gnu/libvirt-lxc.so.0.1003.1
/usr/lib/x86_64-linux-gnu/libvirt-qemu.so.0
/usr/lib/x86_64-linux-gnu/libvirt-qemu.so.0.1003.1
/usr/lib/x86_64-linux-gnu/libvirt.so.0
/usr/lib/x86_64-linux-gnu/libvirt.so.0.1003.1
/usr/share/doc/libvirt0/changelog.Debian.gz
/usr/share/doc/libvirt0/copyright

Changelog

2016-04-15 - William Grant <wgrant@ubuntu.com>
libvirt (1.3.1-1ubuntu10) xenial; urgency=medium
* d/p/u/virt-aa-helper-apparmor-allow-usr-share-AAVMF-too.patch: Allow
access to /usr/share/AAVMF/** and /usr/share/qemu-efi/** for aarch64 UEFI.
(LP: #1538882)
2016-04-07 - Serge Hallyn <serge.hallyn@ubuntu.com>
libvirt (1.3.1-1ubuntu9) xenial; urgency=medium
* Remove the tasks limit on libvirt-bin service (LP: #1567381)
This should be un-done when it is properly fixed in the code so
that virtual machines are started in their own pids cgroup.
2016-03-11 - Serge Hallyn <serge.hallyn@ubuntu.com>
libvirt (1.3.1-1ubuntu8) xenial; urgency=medium
* d/p/u/virt-aa-helper-add-guest-agent-rule.patch: this actually solves
the qemu guest agent problem for rhel7 vms for me.  (LP: #1393842)
Also drop the mknod rule which isn't needed.
* d/apparmor/usr.lib.libvirt.virt-aa-helper: add permission to read under
/var/run.  This is needed for some openvswitch info. (LP: #1513367)
2016-03-10 - Serge Hallyn <serge.hallyn@ubuntu.com>
libvirt (1.3.1-1ubuntu7) xenial; urgency=medium
* zfs support (LP: #1553023)
- Cherrypick upstream patches to support zfs
- debian/rules: build with zfs support
- debian/control: add zfs as build-dep
* d/p/u/virt-aa-helper-no-explicity-deny-for-basefiles.patch: don't mark
readonly files with an explicity deny only because the xml marks it
as reasonly. (LP: #1554031)
* fix typo in virt-aa-helper helptext
* fix d/p/u/preup-virt-aa-helper-better-write-denials-handling.patch to
not overwrite const memory.
2016-03-09 - Serge Hallyn <serge.hallyn@ubuntu.com>
libvirt (1.3.1-1ubuntu6) xenial; urgency=medium
* d/apparmor/libvirt-qemu: generalize the qemu-block-extra libs line.
(LP: #1554761)
* d/p/ubuntu/virt-aa-helper-add-mknod-for-guest-agent.patch: add mknod
capability if there is a qemu guest agent. (LP: #1393842)
2016-03-09 - Stefan Bader <stefan.bader@canonical.com>
libvirt (1.3.1-1ubuntu5) xenial; urgency=low
* Added d/p/ubuntu/preup-virt-aa-helper-better-write-denials-handling.patch
and refreshed d/p/ubuntu/9034-complete-9p-support accordingly.
* Added d/p/ubuntu/additional-libvirt-guest-tweaks.patch to fix default
URI detection when running in a Xen control domain. Also change the
default config to do parallel shutdown requests (max. 10) and reduce the
timeout to 2 minutes.
2016-03-01 - Stefan Bader <stefan.bader@canonical.com>
libvirt (1.3.1-1ubuntu4) xenial; urgency=low
* d/libvirt-bin.virtlockd.init: Replace by the version I had already
prepared and was tested (LP: #1547208).
* d/libvirt-bin.virtlogd.init: Fix up some left-over references to
libvirtd.
* d/control: Add provides libvirt-daemon for libvirt-bin (LP: #1551643)
2016-02-29 - James Page <james.page@ubuntu.com>
libvirt (1.3.1-1ubuntu3) xenial; urgency=medium
* d/libvirt-bin.virtlockd.init: Re-write based on virtlogd init script
as upstream provided version is not compatible with Ubuntu/Debian.
2016-02-17 - Matthias Klose <doko@ubuntu.com>
libvirt (1.3.1-1ubuntu2) xenial; urgency=medium
* No-change rebuild for gnutls transition.

See Also

Package Description
libvisio-0.1-1_0.1.5-1ubuntu1_amd64.deb library for parsing the visio file structure
libvisio-dev_0.1.5-1ubuntu1_amd64.deb library for parsing the visio file structure -- development
libvisio-doc_0.1.5-1ubuntu1_all.deb library for parsing the visio file structure -- documentatio
libvisual-0.4-0_0.4.0-8_amd64.deb audio visualization framework
libvisual-0.4-dev_0.4.0-8_amd64.deb audio visualization framework (development files)
libvncclient1_0.9.10+dfsg-3build1_amd64.deb API to write one's own VNC server - client library
libvncserver-config_0.9.10+dfsg-3build1_amd64.deb API to write one's own VNC server - library utility
libvncserver-dev_0.9.10+dfsg-3build1_amd64.deb API to write one's own VNC server - development files
libvncserver1_0.9.10+dfsg-3build1_amd64.deb API to write one's own VNC server
libvoikko-dev_4.0.1-3ubuntu1_amd64.deb Development files for libvoikko
libvoikko1_4.0.1-3ubuntu1_amd64.deb Library of free natural language processing tools
libvorbis-dev_1.3.5-3_amd64.deb development files for Vorbis General Audio Compression Codec
libvorbis0a_1.3.5-3_amd64.deb decoder library for Vorbis General Audio Compression Codec
libvorbisenc2_1.3.5-3_amd64.deb encoder library for Vorbis General Audio Compression Codec
libvorbisfile3_1.3.5-3_amd64.deb high-level API for Vorbis General Audio Compression Codec
Advertisement
Advertisement