libtspi1_0.3.13-4_amd64.deb


Advertisement

Description

libtspi1 - open-source TCG Software Stack (library)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libtspi1_0.3.13-4_amd64.deb
Package name libtspi1
Package version 0.3.13
Package release 4
Package architecture amd64
Package type deb
Category libs
Homepage http://trousers.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 141.70 KB
Installed size 495.00 KB
TrouSerS is an implementation of the Trusted Computing Group's Software Stack
(TSS) specification. You can use TrouSerS to write applications that make use
of your TPM hardware. TPM hardware can create, store and use RSA keys securely
(without ever being exposed in memory), verify a platform's software state
using cryptographic hashes and more.
This package contains the library.

Alternatives

Package Version Architecture Repository
libtspi1_0.3.13-4_i386.deb 0.3.13 i386 Ubuntu Main
libtspi1 - - -

Requires

Name Value
libc6 >= 2.14
libssl1.0.0 >= 1.0.0
multiarch-support -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtspi1_0.3.13-4_amd64.deb
Source Package trousers

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtspi1 deb package:
    # sudo apt-get install libtspi1

Files

Path
/usr/lib/x86_64-linux-gnu/libtspi.so.1
/usr/lib/x86_64-linux-gnu/libtspi.so.1.2.0
/usr/share/doc/libtspi1/changelog.Debian.gz
/usr/share/doc/libtspi1/copyright
/usr/share/lintian/overrides/libtspi1

Changelog

2015-06-28 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.13-4) unstable; urgency=medium
* Add patch 07 to fix FTBFS with gcc 5 (Closes: #778149)
* Bump Standards Version to 3.9.6
2014-11-04 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.13-3) unstable; urgency=high
* Fix postinst script, preventing installation (Closes: #767690)
- The postinst script does not fail anymore if the TPM device is not
present, or if udev reload command fails.
This is typically the case in a chroot environment.
* Fix init script to be more robust:
- Test for TPM device owner and issue a warning if not matching the tss
user.
- Do not try to change uid before running tcsd, the daemon already changes
its uid just after starting.
* Urgency high, RC bug
2014-08-20 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.13-2) unstable; urgency=medium
* Fix FTBFS on hurd-i386 and kfreebsd-any (Closes: #754359)
Thanks to Svante Signell for the patch.
2014-06-29 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.13-1) unstable; urgency=medium
* Imported Upstream version 0.3.13
* Refreshed quilt patches
* Include utmp.h, should fix FTBFS on Hurd (Closes: #729179)
* Try to workaround systemd/udev names when reloading rules (Closes: #739485)
* Update symbols
* Bump Standards Version to 3.9.5
2013-08-20 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.11.2-1) unstable; urgency=low
* Imported Upstream version 0.3.11.2
* Upstream license changed to BSD
* Example tools are not shipped anymore
* Remove 05-gcc47.patch, not needed anymore
* Updated symbols file
2013-07-04 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.10-3) unstable; urgency=low
* Remove tools, distributed under GPLv2+ but linked with CPL
(Closes: #697512)
* Bump Standards Version to 3.9.4
2013-02-19 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.10-2) unstable; urgency=low
* Reload udev rules before triggering event during postinst (Closes: #581505)
2012-11-10 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.10-1) unstable; urgency=low
* Imported Upstream version 0.3.10
* Update symbols file
* Force build of tools
2012-07-05 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-3) unstable; urgency=low
* Fix regression introduced in previous patch, preventing removal
(Closes: #680375)
2012-07-04 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-2) unstable; urgency=low
* Add workaround for upgrade failure for versions before 0.3.8-3
(Closes: #679621)

See Also

Package Description
libtxc-dxtn-s2tc-dev_0~git20131104-1.1_amd64.deb Development files for the S2TC library
libtxc-dxtn-s2tc0_0~git20131104-1.1_amd64.deb Texture compression library for Mesa
libtypes-serialiser-perl_1.0-1_all.deb module providing simple data types for common serialisation formats
libubsan0-arm64-cross_5.3.1-14ubuntu2cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0-armhf-cross_5.3.1-14ubuntu2cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0-powerpc-cross_5.3.1-14ubuntu2cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0-ppc64el-cross_5.3.1-14ubuntu2cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0_5.3.1-14ubuntu2_amd64.deb UBSan -- undefined behaviour sanitizer (runtime)
libubuntugestures5-dev_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu gestures library development files
libubuntugestures5-private-dev_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu gestures library private development files
libubuntugestures5_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu gestures library for Ubuntu UI Toolkit
libubuntutoolkit5-dev_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu toolkit common library development files
libubuntutoolkit5-private-dev_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu toolkit common library private development files
libubuntutoolkit5_1.3.1918+16.04.20160404-0ubuntu1_amd64.deb Ubuntu toolkit common library for Ubuntu UI Toolkit
libucpp-dev_1.3.2-1_amd64.deb embeddable, quick and light C preprocessor -- development
Advertisement
Advertisement