libtool-doc_2.4.6-0.1_all.deb


Advertisement

Description

libtool-doc - Generic library support script

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libtool-doc_2.4.6-0.1_all.deb
Package name libtool-doc
Package version 2.4.6
Package release 0.1
Package architecture all
Package type deb
Category doc
Homepage http://www.gnu.org/software/libtool/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 226.15 KB
Installed size 712.00 KB
This package contains the GNU libtool documentation.
GNU libtool is generic library support script.  Libtool hides
the complexity of generating special library types (such as shared
libraries) behind a consistent interface.  To use libtool, add the
new generic library building commands to your Makefile, Makefile.in,
or Makefile.am.  See the documentation for details.  Libtool supports
building static libraries on all platforms.

Alternatives

Package Version Architecture Repository
libtool-doc_2.4.6-0.1_all.deb 2.4.6 all Ubuntu Main
libtool-doc - - -

Conflicts

Name Value
libtool1.4-doc -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtool-doc_2.4.6-0.1_all.deb
Source Package libtool

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtool-doc deb package:
    # sudo apt-get install libtool-doc

Files

Path
/usr/share/doc-base/libtool-doc
/usr/share/doc/libtool-doc/AUTHORS
/usr/share/doc/libtool-doc/NEWS.gz
/usr/share/doc/libtool-doc/README
/usr/share/doc/libtool-doc/THANKS.gz
/usr/share/doc/libtool-doc/TODO.gz
/usr/share/doc/libtool-doc/changelog.Debian.gz
/usr/share/doc/libtool-doc/copyright
/usr/share/doc/libtool-doc/libtool.html
/usr/share/info/libtool.info-1.gz
/usr/share/info/libtool.info-2.gz
/usr/share/info/libtool.info.gz

Changelog

2016-02-07 - Matthias Klose <doko@debian.org>
libtool (2.4.6-0.1) unstable; urgency=medium
* Non maintainer upload.
[ Rico Tzschichholz ]
* New upstream release
Remove patches applied upstream:
- hurd.patch
- x32.patch
- ppc64el.patch
* Cherry-picked patches from upstream git:
- 0001-libtool-fix-GCC-linking-with-specs.patch
- 0003-libtoolize-fix-infinite-recursion-in-m4.patch
- 0015-syntax-check-fix-sed-syntax-errors.patch
- 0020-libtool-fix-GCC-clang-linking-with-fsanitize.patch
* Build-depend on texinfo needed by bootstrap.
* *.install/rules: Updated for upstream changes.
2014-10-14 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.11) unstable; urgency=medium
* Non-maintainer upload.
* Drop libtool's dependency on libtool-bin.
* Add libtool-bin dependency on libtool.
* Make libtool Multi-Arch: foreign. Closes: #682045.
* Bump standards version to 3.9.6.
2014-08-19 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.10) unstable; urgency=medium
* Non-maintainer upload.
* Run the tests in the build target, not the install target.
2014-08-19 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.9) unstable; urgency=medium
* Non-maintainer upload.
* Fix the architecture only build.
2014-08-17 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.8) unstable; urgency=medium
* Non-maintainer upload with maintainer's permission.
* Split-out the libtool binary into a libtool-bin package, let libtool
still depend on the libtool-bin package.
* Set the architecture for libtool to `all'.
* The next steps are:
- Fix package builds with libtool's dependency on libtool-bin removed,
either by changing the package build not to require libtool or by
adding a build dependency on libtool-bin.
- Drop libtool's dependency on libtool-bin.
* Build using dpkg-buildflags.
* Fix some lintian warnings. Closes: #711521.
* Only ship the complete upstream changelogs in the -doc package.
* Move texinfo to Build-Depends-Indep (Daniel Schepler). Closes: #737941.
* Build-depend on most recent autoconf and automake versions to minimize
the risk of mismatching files in the libltdl-dev M-A: same package.
Closes: #733935.
2014-02-10 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.7) unstable; urgency=medium
* Non-maintainer upload.
* Fix typo in the ppc64el guessing in config.guess.
2014-01-02 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.6) unstable; urgency=low
* Non-maintainer upload.
* Rebuild using the recent automake 1.14.1 version. Closes: #733935.
2014-01-02 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.5) unstable; urgency=medium
* Non-maintainer upload.
* Update the powerpc little endian support, outdated in the Debian
patch in #726404.
2014-01-01 - Matthias Klose <doko@debian.org>
libtool (2.4.2-1.4) unstable; urgency=low
* Non-maintainer upload with maintainer's permission.
* Add powerpc little endian updates. Closes: #726404.
* Build-conflict with and suggest gcj-jdk instead of gcj.
2013-07-01 - Colin Watson <cjwatson@debian.org>
libtool (2.4.2-1.3) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on help2man (closes: #712413).

See Also

Package Description
libtool_2.4.6-0.1_all.deb Generic library support script
libtotem-dev_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player - development files
libtotem-pg-dev_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library development
libtotem-pg5_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library
libtotem-plparser-common_3.10.6-1ubuntu1_all.deb Totem Playlist Parser library - common files
libtotem-plparser-dev_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - development files
libtotem-plparser18_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - runtime files
libtotem0_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player
libtracker-control-1.0-0_1.6.2-0ubuntu1_amd64.deb library to control/monitor tracker miners
libtracker-control-1.0-dev_1.6.2-0ubuntu1_amd64.deb library to control/monitor tracker miners - development files
libtracker-control-doc_1.6.2-0ubuntu1_all.deb library to control/monitor tracker miners - API documentation
libtracker-miner-1.0-0_1.6.2-0ubuntu1_amd64.deb tracker data miner library
libtracker-miner-1.0-dev_1.6.2-0ubuntu1_amd64.deb tracker data miner library - development files
libtracker-miner-doc_1.6.2-0ubuntu1_all.deb tracker data miner library - API documentation
libtracker-sparql-1.0-0_1.6.2-0ubuntu1_amd64.deb metadata database, indexer and search tool - library
Advertisement
Advertisement