libtommath-dev_0.42.0-1.2_amd64.deb


Advertisement

Description

libtommath-dev - multiple-precision integer library [development files]

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libtommath-dev_0.42.0-1.2_amd64.deb
Package name libtommath-dev
Package version 0.42.0
Package release 1.2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://libtom.org/?page=features&whatfile=ltm
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 51.68 KB
Installed size 334.00 KB
LibTomMath is a C language library that provides a vast array of highly
optimized functions for number theory; including:
* Simple Algebra (Addition, Subtraction, Multiplication, Division)
* Digit Manipulation (shift, binary AND/OR/XOR)
* Modular Reduction (Barrett, Montgomery, DR, 2k)
* Number Theory
- Greatest Common Divisor
- Least Common Multiple
- Jacobi Symbol Computation
- Multiplicative Inverse
- Modular Exponentiation
- Fermat & Miller-Rabin Primality Tests
* Miscellaneous
- Root finding over Z
- Pseudo-random integers
- Signed & Unsigned comparisons
- Karatsuba and Toom-Cook multiplication algorithms
- Fast Comba based Multiplier, Squaring and Montgomery routines
This package contains the files needed to create programs that use LibTomMath.
It is not needed to merely execute programs that use LibTomMath.

Alternatives

Package Version Architecture Repository
libtommath-dev_0.42.0-1.2_i386.deb 0.42.0 i386 Ubuntu Main
libtommath-dev - - -

Requires

Name Value
libtommath0 = 0.42.0-1.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtommath-dev_0.42.0-1.2_amd64.deb
Source Package libtommath

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtommath-dev deb package:
    # sudo apt-get install libtommath-dev

Files

Path
/usr/include/tommath.h
/usr/include/tommath_class.h
/usr/include/tommath_superclass.h
/usr/lib/libtommath.a
/usr/lib/libtommath.so
/usr/share/doc/libtommath-dev/changelog.Debian.gz
/usr/share/doc/libtommath-dev/copyright

Changelog

2015-08-29 - Dominique Dumont <dod@debian.org>
libtommath (0.42.0-1.2) unstable; urgency=medium
* Non-maintainer upload.
* control: fix description (Closes:  #755756)
* control: removed duplicate build dependencies
* updated compat to 9
* control: updated std-versions to 3.9.6
* added patch to fix hardening
* added patch to fix latex build error (Closes: #790320)
* added patch fix-mp-radix-size patch (Closes: #796507)
2014-10-09 - Matthias Klose <doko@debian.org>
libtommath (0.42.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Build-depend on libtool-bin. Closes: #761770.
2011-01-30 - Joe Nahmias <jello@debian.org>
libtommath (0.42.0-1) unstable; urgency=low
* New upstream release, closes: #508900.
* change override to optional, closes: #610549.
* debian/control: Bump Std-Ver
+ Don't install libtommath.la
* debian/control: Add Homepage
* debian/watch: added
2010-07-05 - Joe Nahmias <jello@debian.org>
libtommath (0.39-4) unstable; urgency=low
* Ack NMU, thanks!
* Upstream has disappeared :(
+ debian/control: remove Homepage header
+ debian/watch: removed
* debian/control: bump Std-Ver, no changes
2010-06-26 - Christine Spang <christine@debian.org>
libtommath (0.39-3.2) unstable; urgency=low
* Non-maintainer upload.
* Revert "remove duplicate texlive-latex-recommended and ghostscript" from
previous NMU. (Closes: #583820)
2010-05-05 - Jari Aalto <jari.aalto@cante.net>
libtommath (0.39-3.1) unstable; urgency=low
[ Jari Aalto ]
* Non-maintainer upload.
- Move to packaging format "3.0 (quilt)".
* debian/compat
- Update to 7.
* Non-maintainer upload.
* debian/control
- (Build-Depends): Update to debhelper 7.1. Remove duplicate
texlive-latex-recommended and ghostscript.
- (Build-Depends-Indep): Remove duplicate libtiff-tools.
- (Depends): Add ${misc:Depends}.
- (Standards-Version): Update to 3.8.4.
- (libtommath0::Section): Remove; inherited from above.
* debian/copyright
- Update layout.
- Point to GPL-2.
* debian/rules
- (install): Update dh_clean to dh_prep.
* debian/source/format
- New file
* bx.tex
- Remove unused macro \undefined (FTBFS: Closes: #562349).
Patch thanks to Daniel Schepler <dschepler@gmail.com>. 
2008-05-21 - Joe Nahmias <jello@debian.org>
libtommath (0.39-3) unstable; urgency=low
* debian/control: work around auto-builders' brokenness by adding all the
build-dep-indeps to Build-Depends, really closes: #474413.
2008-04-28 - Joe Nahmias <jello@debian.org>
libtommath (0.39-2) unstable; urgency=low
* debian/rules: install target should only depend on build-arch which caused
FTBFS on the buildds, closes: #474413.
* debian/rules: make build-indep and build-arch .PHONY targets
* debian/watch: add call to uupdate on new upstream version
2008-03-24 - Joe Nahmias <jello@debian.org>
libtommath (0.39-1) unstable; urgency=low
* Initial release, closes: #472281.

See Also

Package Description
libtommath-docs_0.42.0-1.2_all.deb multiple-precision integer library [documentation]
libtommath0_0.42.0-1.2_amd64.deb multiple-precision integer library [runtime]
libtool-bin_2.4.6-0.1_amd64.deb Generic library support script (libtool binary)
libtool-doc_2.4.6-0.1_all.deb Generic library support script
libtool_2.4.6-0.1_all.deb Generic library support script
libtotem-dev_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player - development files
libtotem-pg-dev_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library development
libtotem-pg5_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library
libtotem-plparser-common_3.10.6-1ubuntu1_all.deb Totem Playlist Parser library - common files
libtotem-plparser-dev_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - development files
libtotem-plparser18_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - runtime files
libtotem0_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player
libtracker-control-1.0-0_1.6.2-0ubuntu1_amd64.deb library to control/monitor tracker miners
libtracker-control-1.0-dev_1.6.2-0ubuntu1_amd64.deb library to control/monitor tracker miners - development files
libtracker-control-doc_1.6.2-0ubuntu1_all.deb library to control/monitor tracker miners - API documentation
Advertisement
Advertisement