libtmglib3_3.6.0-2ubuntu2_amd64.deb


Advertisement

Description

libtmglib3 - test matrix generators of LAPACK - shared version

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libtmglib3_3.6.0-2ubuntu2_amd64.deb
Package name libtmglib3
Package version 3.6.0
Package release 2ubuntu2
Package architecture amd64
Package type deb
Category libs
Homepage http://www.netlib.org/lapack/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 119.42 KB
Installed size 430.00 KB
libtmglib is a component of the LAPACK library, containing routines for
generation of input matrices for testing and timing of LAPACK.
This package contains a shared version of the library.

Alternatives

Package Version Architecture Repository
libtmglib3_3.6.0-2ubuntu2_i386.deb 3.6.0 i386 Ubuntu Main
libtmglib3 - - -

Requires

Name Value
libblas.so.3 -
libblas3 -
libc6 >= 2.4
libgcc1 >= 1:4.0
liblapack.so.3 -
liblapack3 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtmglib3_3.6.0-2ubuntu2_amd64.deb
Source Package lapack

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtmglib3 deb package:
    # sudo apt-get install libtmglib3

Files

Path
/usr/lib/libtmglib.so.3
/usr/lib/libtmglib.so.3.6.0
/usr/share/doc/libtmglib3/changelog.Debian.gz
/usr/share/doc/libtmglib3/copyright

Changelog

2016-01-17 - Matthias Klose <doko@ubuntu.com>
lapack (3.6.0-2ubuntu2) xenial; urgency=medium
* Don't run the blas-testsuite autopkg test, apparently it has known
test failures on i386.
2016-01-16 - Matthias Klose <doko@ubuntu.com>
lapack (3.6.0-2ubuntu1) xenial; urgency=medium
* Don't run the lapack-testsuite autopkg test, apparently it has known
test failures, which are not regressions. See Debian #811191.
2016-01-07 - Sébastien Villemot <sebastien@debian.org>
lapack (3.6.0-2) unstable; urgency=low
* Build deprecated routines in LAPACK and LAPACKE. (Closes: #810143)
2016-01-06 - Sébastien Villemot <sebastien@debian.org>
lapack (3.6.0-1) unstable; urgency=low
* Imported Upstream version 3.6.0
* No longer repack upstream tarball.
* d/copyright: rewrite in machine readable format 1.0.
* Remove patches applied upstream.
+ cgesvd-zgesvd-stack-corruption.patch
+ zstemr-n2.patch
+ zlanhf-clanhf-norm.patch
+ dormlq_interface_check.patch
+ dlansy_1_norm_segfault.patch
+ dlange_rowmajor_inconsistent.patch
* doxygen-exclude-binary-objects.patch: drop patch, no longer needed.
* decouple_gcc.diff: remove patch.
Add equivalent functionality in the make.inc rule of debian/rules.
* lapack_testing.patch: drop useless patch.
* fix-typos.patch: new patch, fixes various typos.
Thanks to lintian!
* doxygen-strip-source.patch: new patch.
Suppresses verbatim source code from Doxygen output, to save space.
* Build libblas* binary packages (taken over from src:blas).
+ New patches:
- cblas-makerule.patch
- cblas-test-output.patch
- cblas-zblat2.patch
- icamax-izamax-extended-precision.patch
+ libblas-doc is now a transitional package (depends on
liblapack-doc-man). Unmaintained cinterface.pdf and faq.html have
been dropped.
+ libblas-test: ship test data files in /usr/lib/libblas.
+ libblas-dev now suggests liblapack-doc{,-man}.
+ Patches not taken from src:blas:
- an apparently wrong patch for crotg.
- the big patch for dealing with info codes in cblas routines when
used in row major order, when xerbla was overridden by the user.
The modified behavior was debatable, and at any rate, it is not
implemented in ATLAS and OpenBLAS.
* Ship all manpages (including BLAS') in liblapack-doc-man.
Drop no_blas_manpages.patch. Incidentally, all BLAS routines now have
manpages, including the xDOT ones. (Closes: #511574)
* LAPACK testsuite in liblapack-test:
+ dynamically link test programs.
+ Move test input data to /usr/lib/lapack.
+ Ship a script for running all tests in /u/s/doc/liblapack-test/examples.
* liblapack{,e}-dev now suggest liblapack-doc{,-man}.
* Drop liblapack-dbg, migrate to automatic debug packages.
* d/liblapack-doc.dirs: delete it, no need for these empty dirs.
* Remove useless *.md5 and *.map in liblapack-doc.
* Add autopkgtest for BLAS and LAPACK testsuites.
* Various improvements to package descriptions.
* Ship lapacke.pc in liblapacke-dev.
2015-10-31 - Sébastien Villemot <sebastien@debian.org>
lapack (3.5.0-5) unstable; urgency=medium
* Fix static libraries: they were compiled with -fPIC.
* Add missing dependency of liblapacke-dev on libblas-dev and liblapack-dev.
* Package tmglib. (Closes: #772196)
+ new libtmglib3 and libtmglib-dev packages.
+ now include libtmglib wrappers in lapacke. In particular, drop
d/p/lapacke_no_matgen.patch.
* Use upstream version number for filename of shared libraries.
* Add debug package liblapack-dbg.
* Remove obsolete Conflicts/Replaces for lapack{,3}-{pic,test,doc}.
* Drop transitional package liblapack3gf.
* New patches taken from upstream:
+ dlange_rowmajor_inconsistent.patch
+ dlansy_1_norm_segfault.patch
+ dormlq_interface_check.patch

See Also

Package Description
libtokyocabinet-dev_1.4.48-10_amd64.deb Tokyo Cabinet Database Libraries [development]
libtokyocabinet9_1.4.48-10_amd64.deb Tokyo Cabinet Database Libraries [runtime]
libtomcat8-java_8.0.32-1ubuntu1_all.deb Apache Tomcat 8 - Servlet and JSP engine -- core libraries
libtommath-dev_0.42.0-1.2_amd64.deb multiple-precision integer library [development files]
libtommath-docs_0.42.0-1.2_all.deb multiple-precision integer library [documentation]
libtommath0_0.42.0-1.2_amd64.deb multiple-precision integer library [runtime]
libtool-bin_2.4.6-0.1_amd64.deb Generic library support script (libtool binary)
libtool-doc_2.4.6-0.1_all.deb Generic library support script
libtool_2.4.6-0.1_all.deb Generic library support script
libtotem-dev_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player - development files
libtotem-pg-dev_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library development
libtotem-pg5_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library
libtotem-plparser-common_3.10.6-1ubuntu1_all.deb Totem Playlist Parser library - common files
libtotem-plparser-dev_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - development files
libtotem-plparser18_3.10.6-1ubuntu1_amd64.deb Totem Playlist Parser library - runtime files
Advertisement
Advertisement