libtirpc1_0.2.5-1_amd64.deb


Advertisement

Description

libtirpc1 - transport-independent RPC library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libtirpc1_0.2.5-1_amd64.deb
Package name libtirpc1
Package version 0.2.5
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage http://sourceforge.net/projects/libtirpc
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 73.85 KB
Installed size 237.00 KB
This package contains a port of Sun's transport-independent RPC library to
Linux. The library is intended as a replacement for the RPC code in the GNU C
library, providing among others support for RPC (and in turn, NFS) over IPv6.

Alternatives

Package Version Architecture Repository
libtirpc1_0.2.5-1ubuntu0.1_i386.deb 0.2.5 i386 Ubuntu Updates Main
libtirpc1_0.2.5-1ubuntu0.1_amd64.deb 0.2.5 amd64 Ubuntu Updates Main
libtirpc1_0.2.5-1_i386.deb 0.2.5 i386 Ubuntu Main
libtirpc1 - - -

Requires

Name Value
libc6 >= 2.16
libgssapi-krb5-2 >= 1.10+dfsg~
multiarch-support -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtirpc1_0.2.5-1_amd64.deb
Source Package libtirpc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtirpc1 deb package:
    # sudo apt-get install libtirpc1

Files

Path
/etc/netconfig
/lib/x86_64-linux-gnu/libtirpc.so.1
/lib/x86_64-linux-gnu/libtirpc.so.1.0.10
/usr/share/doc/libtirpc1/changelog.Debian.gz
/usr/share/doc/libtirpc1/copyright
/usr/share/man/man5/netconfig.5.gz

Changelog

2014-09-09 - Anibal Monsalve Salazar <anibal@debian.org>
libtirpc (0.2.5-1) unstable; urgency=medium
* New upstream version 0.2.5.
Remove the INSTALL symlink, replace it with INSTALL from 0.2.3
and repackage original upstream to fix lintian error:
E: libtirpc source: source-contains-unsafe-symlink INSTALL
* Merged upstream at http://git.infradead.org/users/steved/libtirpc.git
e63e2b5 Add a pthread key initializer constant
db2faef Clean up forward declarations in src/auth_gss.c
797365f Clean up forward declarations in src/svc_auth_gss.c
3bb76d9 man: Organize man/Makefile.am
fd96ce3 man: Replace outdated Solaris and BSD references in the man pages
03de41b Pre-register server side RPCSEC GSS support
cf2e008 Avoid buffer overruns by allocating buffer in svcauth_gss_validate()
a940bf9 xdr_rejected_reply: Don't crash with invalid server rejection
* Refresh patches.
2014-08-11 - Steve Langasek <vorlon@debian.org>
libtirpc (0.2.4-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Upload to unstable where this belongs to fix the release critical bug.
* Declare Breaks: against versions of nfs-common, nfs-kernel-server that
link against libtirpc1 and libgssglue1, so that we have a proper
transition.  Closes: #755703.
2014-08-02 - Anibal Monsalve Salazar <anibal@debian.org>
libtirpc (0.2.4-2) experimental; urgency=medium
* Get rid of libgssglue1.
Run configure without "--enable-gss".
Don't build-depend on libgssglue-dev.
Drop 07-gssglue-gssapi.h.diff.
Closes: #755703.
* autogen.sh creates config.h.in.
Drop 08-config.h.in.diff.
* Refresh db2faef.patch.
2014-07-18 - Anibal Monsalve Salazar <anibal@debian.org>
libtirpc (0.2.4-1) unstable; urgency=medium
* New maintainer.
Closes: #740622.
* New upstream version 0.2.4.
Remove the INSTALL symlink, replace it with INSTALL from 0.2.3
and repackage original upstream to fix lintian error:
E: libtirpc source: source-contains-unsafe-symlink INSTALL
* Fix "fatal error: gssapi/gssapi.h: No such file or directory"
Add 07-gssglue-gssapi.h.diff
* Update 05-hurd-port.diff to have AM_CONFIG_HEADER(config.h) in
configure.ac.
* Run autogen.sh to create config.h.in.
* Run autoheader to create config.h.
Add 09-autogen.sh.diff.
* Build-Depends on libkrb5-dev.
* Add upstream patches from http://git.infradead.org/users/steved/libtirpc.git
e63e2b5 Add a pthread key initializer constant
db2faef Clean up forward declarations in src/auth_gss.c
797365f Clean up forward declarations in src/svc_auth_gss.c
3bb76d9 man: Organize man/Makefile.am
fd96ce3 man: Replace outdated Solaris and BSD references in the man pages
03de41b Pre-register server side RPCSEC GSS support
cf2e008 Avoid buffer overruns by allocating buffer in svcauth_gss_validate()
a940bf9 xdr_rejected_reply: Don't crash with invalid server rejection
* Add debian/watch.
* Refresh patches.
2014-07-04 - Aurelien Jarno <aurel32@debian.org>
libtirpc (0.2.3-2) unstable; urgency=medium
* Debian QA upload.
* Fix breakage introduced by 05-hurd-port.diff (Closes: #740491, #740574):
- Include config.h from src/getpeereid.c so that the test on
HAVE_SYS_USER_H actually works.
- Drop src/config.h which is an old copy of src/config.h.in. 
2014-06-10 - Aurelien Jarno <aurel32@debian.org>
libtirpc (0.2.3-1) unstable; urgency=medium
* Debian QA upload.
* New upstream version:
- includes fix to avoid issues with lock elision. (Closes: #751147).
- drop 01-remove-des-crypt.diff patch (merged upstream).
- drop 02-rerun-bootstrap.diff patch (not needed anymore).
- refresh 03-kfreebsd.diff patch.
- refresh 05-hurd-port.diff patch.
2014-03-03 - Petter Reinholdtsen <pere@debian.org>
libtirpc (0.2.2-7) unstable; urgency=low
* Debian QA group upload.
* Added patch 06-hurd-client-port.diff, avoid malloc overflow in
client code on Hurd (Closes: #739674).
* Rewrite rules file to use dh and move to debhelper compat level 9
for hardening support.

See Also

Package Description
libtk8.6_8.6.5-1_amd64.deb Tk toolkit for Tcl and X11 v8.6 - run-time files
libtmglib-dev_3.6.0-2ubuntu2_amd64.deb test matrix generators of LAPACK - development files
libtmglib3_3.6.0-2ubuntu2_amd64.deb test matrix generators of LAPACK - shared version
libtokyocabinet-dev_1.4.48-10_amd64.deb Tokyo Cabinet Database Libraries [development]
libtokyocabinet9_1.4.48-10_amd64.deb Tokyo Cabinet Database Libraries [runtime]
libtomcat8-java_8.0.32-1ubuntu1_all.deb Apache Tomcat 8 - Servlet and JSP engine -- core libraries
libtommath-dev_0.42.0-1.2_amd64.deb multiple-precision integer library [development files]
libtommath-docs_0.42.0-1.2_all.deb multiple-precision integer library [documentation]
libtommath0_0.42.0-1.2_amd64.deb multiple-precision integer library [runtime]
libtool-bin_2.4.6-0.1_amd64.deb Generic library support script (libtool binary)
libtool-doc_2.4.6-0.1_all.deb Generic library support script
libtool_2.4.6-0.1_all.deb Generic library support script
libtotem-dev_3.18.1-1ubuntu4_amd64.deb Main library for the Totem media player - development files
libtotem-pg-dev_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library development
libtotem-pg5_2.3.5-3ubuntu1_amd64.deb cluster engine Totem library
Advertisement
Advertisement