libsmi2ldbl_0.4.8+dfsg2-11_amd64.deb


Advertisement

Description

libsmi2ldbl - library to access SMI MIB information

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libsmi2ldbl_0.4.8+dfsg2-11_amd64.deb
Package name libsmi2ldbl
Package version 0.4.8+dfsg2
Package release 11
Package architecture amd64
Package type deb
Category libs
Homepage http://www.ibr.cs.tu-bs.de/projects/libsmi/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.63 KB
Installed size 425.00 KB
The purpose of libsmi is to
* give network management applications a concise programmer-friendly
interface to access MIB module information,
* separate the knowledge on SMI from the main parts of management
applications,
* allow to add new kinds of MIB repositories without the need to adapt
applications that make use of libsmi.
In this context, MIB is "Management Information Base" and SMI stands for
"Structure and identification of Management Information". See RFC1902 and
others for details.
This package contains the main libsmi library.

Alternatives

Package Version Architecture Repository
libsmi2ldbl_0.4.8+dfsg2-11_i386.deb 0.4.8+dfsg2 i386 Ubuntu Main
libsmi2ldbl - - -

Requires

Name Value
libc6 >= 2.14

Conflicts

Name Value
libsmi0 -
libsmi1 -
libsmi2 -

Replaces

Name Value
libsmi0 -
libsmi1 -
libsmi2 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libsmi2ldbl_0.4.8+dfsg2-11_amd64.deb
Source Package libsmi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsmi2ldbl deb package:
    # sudo apt-get install libsmi2ldbl

Files

Path
/etc/smi.conf
/usr/lib/x86_64-linux-gnu/libsmi.so.2
/usr/lib/x86_64-linux-gnu/libsmi.so.2.0.27
/usr/share/doc/libsmi2ldbl/ANNOUNCE
/usr/share/doc/libsmi2ldbl/README
/usr/share/doc/libsmi2ldbl/THANKS
/usr/share/doc/libsmi2ldbl/TODO.gz
/usr/share/doc/libsmi2ldbl/changelog.Debian.gz
/usr/share/doc/libsmi2ldbl/copyright
/usr/share/doc/libsmi2ldbl/smi.conf-example
/usr/share/lintian/overrides/libsmi2ldbl

Changelog

2015-11-27 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-11) unstable; urgency=medium
* Ensure build with -A is possible. Closes: #806062.
2014-08-06 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-10) unstable; urgency=medium
* Use dh-autoreconf to fix FTBFS on ppc64el. Closes: #757214.
2014-04-17 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-9) unstable; urgency=low
* Make the -dbg package multi-arch "same".
* Fix FTBFS due to a change in Bison. Closes: #733361.
Thanks to Andy Whitcroft.
* Bump Standards-Version to 3.9.5.
2013-10-27 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-8) unstable; urgency=low
* Update config.{guess,sub} with autotools-dev package. This enables
support for AArch64 port. Closes: #727439.
* Bump Standards-Version to 3.9.4.
* Fix Vcs-* fields.
* Add some lintian overrides.
2013-02-25 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-7) unstable; urgency=low
* Remove debian/shlibs.local since we use a symbols file. Also, the file
was incorrect. Closes: #701622.
2012-06-08 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-6) unstable; urgency=low
* Fix a segfault when reading partially invalid MIB. Closes: #600076.
* Add a symbols file.
2012-01-07 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-5) unstable; urgency=low
* Switch to debhelper 9 with tiny set of rules.
This also happens to enable hardening flags. Closes: #654812.
* Programs in libsmi2ldbl are now shipped in `smitool` package.
* Enable multiarch for libsmi2ldbl.
2011-05-18 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-4) unstable; urgency=low
* Bump Standards-Version to 3.9.2.
* Get rid of *.la. Closes: #622450.
* Switch to 3.0 (quilt) format.
2010-10-23 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-3) unstable; urgency=high
* Really ship Debian.NEWS.
* Fix CVE-2010-2891: buffer overflow when handling large OID.
* Update Standards-Version to 3.9.1.
2009-12-03 - Vincent Bernat <bernat@debian.org>
libsmi (0.4.8+dfsg2-2) unstable; urgency=low
* Suggest snmp-mibs-downloader, a package in contrib that will download
MIB from Internet, if requested by the user, instead of libsnmp-base.
* Upload to unstable.
* Update NEWS.Debian.
* Ship smistrip in a separate package.
* Update paths in shipped smi.conf.

See Also

Package Description
libsnappy-dev_1.1.3-2_amd64.deb fast compression/decompression library (development files)
libsnappy1v5_1.1.3-2_amd64.deb fast compression/decompression library
libsndfile1-dev_1.0.25-10_amd64.deb Development files for libsndfile; a library for reading/writing audio files
libsndfile1_1.0.25-10_amd64.deb Library for reading/writing audio files
libsnmp-base_5.7.3+dfsg-1ubuntu4_all.deb SNMP configuration script, MIBs and documentation
libsnmp-dev_5.7.3+dfsg-1ubuntu4_amd64.deb SNMP (Simple Network Management Protocol) development files
libsnmp30_5.7.3+dfsg-1ubuntu4_amd64.deb SNMP (Simple Network Management Protocol) library
libsocket6-perl_0.25-1build2_amd64.deb Perl extensions for IPv6
libsonic-dev_0.2.0-3_amd64.deb Header file for linking to libsonic
libsonic0_0.2.0-3_amd64.deb Simple library to speed up or slow down speech
libsoup-gnome2.4-1_2.52.2-1_amd64.deb HTTP library implementation in C -- GNOME support library
libsoup-gnome2.4-dev_2.52.2-1_amd64.deb HTTP library implementation in C -- GNOME support development files
libsoup2.4-1_2.52.2-1_amd64.deb HTTP library implementation in C -- Shared library
libsoup2.4-dev_2.52.2-1_amd64.deb HTTP library implementation in C -- Development files
libsoup2.4-doc_2.52.2-1_all.deb HTTP library implementation in C -- API Reference
Advertisement
Advertisement