librsync-dev_0.9.7-10_amd64.deb


Advertisement

Description

librsync-dev - rsync remote-delta algorithm library (development)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename librsync-dev_0.9.7-10_amd64.deb
Package name librsync-dev
Package version 0.9.7
Package release 10
Package architecture amd64
Package type deb
Category libdevel
Homepage http://librsync.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.24 KB
Installed size 54.00 KB
librsync implements the rsync remote-delta algorithm, which allows for
efficient remote updates of a file, without requiring the old and new versions
to both be present at the transmitter. The library uses a stream-based designed
so that it can be easily embedded into network applications.
This package contains the development files.

Alternatives

Package Version Architecture Repository
librsync-dev_0.9.7-10_i386.deb 0.9.7 i386 Ubuntu Main
librsync-dev - - -

Requires

Name Value
libbz2-dev -
libpopt-dev -
librsync1 = 0.9.7-10
zlib1g-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package librsync-dev_0.9.7-10_amd64.deb
Source Package librsync

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librsync-dev deb package:
    # sudo apt-get install librsync-dev

Files

Path
/usr/include/librsync-config.h
/usr/include/librsync.h
/usr/lib/x86_64-linux-gnu/librsync.so
/usr/share/doc/librsync-dev/changelog.Debian.gz
/usr/share/doc/librsync-dev/copyright

Changelog

2013-06-27 - Andrey Rahmatullin <wrar@wrar.name>
librsync (0.9.7-10) unstable; urgency=low
* Fix tests with new automake (Closes: #713443).
* Do not overwrite LDFLAGS from dpkg-buildflags.
* Add debian/watch.
* Make the debug subpackage Multi-Arch: same.
* Use canonical URLs in Vcs-*.
* Remove the dependency on -dev from -dbg.
* Bump Standards-Version to 3.9.4.
2012-02-05 - Andrey Rahmatullin <wrar@wrar.name>
librsync (0.9.7-9) unstable; urgency=low
* Switch to debhelper v9.
* Use dh_autoreconf --as-needed instead of autotools-dev to fix rpath build
issue with the multiarch path and reduce librsync1 deps.
* Fix a format-security warning.
* Fix an implicit-function-declaration warning in the test suite.
* Set Multi-Arch: same for librsync1.
2011-04-13 - Andrey Rahmatullin <wrar@wrar.name>
librsync (0.9.7-8) unstable; urgency=low
* Adopt the package (Closes: #543849).
* Bump Standards-Version to 3.9.2 (no change needed).
* Change source format to 3.0 (quilt).
* Use autotools_dev debhelper addon instead of manual file copying.
* Enable -Wl,--as-needed.
* Remove unused compression-related rdiff options (Closes: #608470).
* Do not build and install the static library.
* Do not install librsync.la (Closes: #622495)
2009-08-27 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-7) unstable; urgency=low
* Updating package to standards version 3.8.3.
* Removing vcs fields.
* Orphaning package.
2009-08-02 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-6) unstable; urgency=low
* Updating vcs fields in control file.
* Replacing obsolete dh_clean -k with dh_prep.
* Updating section of the debug package.
* Using correct rfc-2822 date formats in changelog.
* Wrapping build-depends.
* Updating to standards version 3.8.2.
* Adding misc depends.
* Updating section of the source package.
* Updating year in copyright file.
* Using quilt rather than dpatch.
* Minimizing rules file.
2008-07-01 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-5) unstable; urgency=medium
* Adding patch to make rdiff aware of -i and -z (Closes: #435894).
2008-06-24 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-4) unstable; urgency=high
* Adding patch from upstream to fix problem when transfering >4GB from
a 32bit to 64bit host (Closes: #355178).
* Updating manpage patch to remove dead link to Linuxcare Australia
(Closes: #288758).
2008-06-20 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-3) unstable; urgency=medium
* Adding debug package.
2008-06-20 - Daniel Baumann <daniel@debian.org>
librsync (0.9.7-2) unstable; urgency=low
* New maintainer (Closes: #487131).
* Redone debian packaging from scratch.
2004-11-28 - Simon Law <sfllaw@debian.org>
librsync (0.9.7-1) unstable; urgency=low
* New upstream release.
- Large files are now supported.  (Closes: Bug#277032)
* Fix description of librsync1.  (Closes: Bug#230839)
* Describe how to use rdiff.  (Closes: Bug#228005, Bug#156457)
* Trust upstream's autoconfiscation.

See Also

Package Description
librsync1_0.9.7-10_amd64.deb rsync remote-delta algorithm library
librtmp-dev_2.4+20151223.gitfa8646d-1build1_amd64.deb toolkit for RTMP streams (development files)
librtmp1_2.4+20151223.gitfa8646d-1build1_amd64.deb toolkit for RTMP streams (shared library)
libruby2.3_2.3.0-5ubuntu1_amd64.deb Libraries necessary to run Ruby 2.3
libsam-dev_2.3.5-3ubuntu1_amd64.deb cluster engine SAM library development
libsam4_2.3.5-3ubuntu1_amd64.deb cluster engine SAM library
libsamplerate0-dev_0.1.8-8_amd64.deb Development files for audio sample rate conversion
libsamplerate0_0.1.8-8_amd64.deb Audio sample rate conversion library
libsane-common_1.0.25+git20150528-1ubuntu2_all.deb API library for scanners -- documentation and support files
libsane-dev_1.0.25+git20150528-1ubuntu2_amd64.deb API development library for scanners [development files]
libsane-hpaio_3.16.3+repack0-1_amd64.deb HP SANE backend for multi-function peripherals
libsane_1.0.25+git20150528-1ubuntu2_amd64.deb API library for scanners
libsasl2-2_2.1.26.dfsg1-14build1_amd64.deb Cyrus SASL - authentication abstraction library
libsasl2-dev_2.1.26.dfsg1-14build1_amd64.deb Cyrus SASL - development files for authentication abstraction library
libsasl2-modules-db_2.1.26.dfsg1-14build1_amd64.deb Cyrus SASL - pluggable authentication modules (DB)
Advertisement
Advertisement