libreoffice-voikko_5.0-2_amd64.deb


Advertisement

Description

libreoffice-voikko - Spellchecker, grammar checker and hyphenator for LibreOffice

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libreoffice-voikko_5.0-2_amd64.deb
Package name libreoffice-voikko
Package version 5.0
Package release 2
Package architecture amd64
Package type deb
Category text
Homepage http://voikko.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.54 KB
Installed size 96.00 KB
LibreOffice is a full-featured office productivity suite that provides
a near drop-in replacement for Microsoft(R) Office.
This package contains a libreoffice-voikko, a multi language spellchecker,
grammar checker and hyphenator extension for LibreOffice. It uses
libvoikko for all linguistic operations.
Based on the configuration of libvoikko, spell checking is supported for
multiple languages. Other features are currently available only for
Finnish.
NOTE: Usually spell-checking, grammar checking and hyphenation should be
automatically activated after installing this package. If this is not the
case, go to "Writing Aids" settings in LibreOffice and activate Voikko
components manually.

Alternatives

Package Version Architecture Repository
libreoffice-voikko_5.0-2_i386.deb 5.0 i386 Ubuntu Main
libreoffice-voikko - - -

Requires

Name Value
libreoffice-core -
python3-libvoikko >= 4.0
voikko-fi -

Provides

Name Value
libreoffice-hyphenation-fi -
libreoffice-spellcheck-fi -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libreoffice-voikko_5.0-2_amd64.deb
Source Package libreoffice-voikko

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libreoffice-voikko deb package:
    # sudo apt-get install libreoffice-voikko

Files

Path
/usr/lib/libreoffice/share/extensions/voikko/Linguistic.xcu
/usr/lib/libreoffice/share/extensions/voikko/SettingsDialog.xcu
/usr/lib/libreoffice/share/extensions/voikko/SettingsDialog.xdl
/usr/lib/libreoffice/share/extensions/voikko/SettingsDialog_en_US.default
/usr/lib/libreoffice/share/extensions/voikko/SettingsDialog_en_US.properties
/usr/lib/libreoffice/share/extensions/voikko/SettingsDialog_fi_FI.properties
/usr/lib/libreoffice/share/extensions/voikko/config.xcs
/usr/lib/libreoffice/share/extensions/voikko/config.xcu
/usr/lib/libreoffice/share/extensions/voikko/description.xml
/usr/lib/libreoffice/share/extensions/voikko/icon.png
/usr/lib/libreoffice/share/extensions/voikko/lovoikko.py
/usr/lib/libreoffice/share/extensions/voikko/voikko.components
/usr/lib/libreoffice/share/extensions/voikko/META-INF/manifest.xml
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/GrammarChecker.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/HyphenatedWord.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/Hyphenator.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/PossibleHyphens.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/PropertyManager.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/SettingsEventHandler.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/SpellAlternatives.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/SpellChecker.py
/usr/lib/libreoffice/share/extensions/voikko/pythonpath/VoikkoHandlePool.py
/usr/share/doc/libreoffice-voikko/changelog.Debian.gz
/usr/share/doc/libreoffice-voikko/copyright
/usr/share/lintian/overrides/libreoffice-voikko

Changelog

2016-02-17 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (5.0-2) unstable; urgency=medium
* Depend on python3-libvoikko instead of the transitional package.
2016-02-10 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (5.0-1) unstable; urgency=medium
* New upstream version.
* Require libvoikko >= 4.0.
* libreoffice-dev no longer needed.
* Drop hardening-wrapper dependency.
* Build depend on python-libvoikko >= 4.0.
* Also runtime dependency on python-libvoikko.
* Update Standards-Version, no changes.
* Build depend on dh-python.
* Use C.UTF-8 locale for building.
2014-09-29 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (4.1-1) unstable; urgency=medium
* Imported Upstream version 4.1
2013-12-07 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (4.0-1) unstable; urgency=medium
* Update watch file
* Imported Upstream version 4.0
* Drop both patches not needed anymore
* Update package description to match current upstream description
* Add Vcs urls
2013-07-28 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.4.1-2) unstable; urgency=low
[ Rene Engelhard ]
* fix build with LibreOffice 4.1.0
2013-07-23 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.4.1-1) unstable; urgency=low
* New upstream release
* debian/rules: add clean/test targets, adjust install
2013-05-21 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.4-1) unstable; urgency=low
* New upstream release
* Change to debhelper 9, simplify packaging
* Update Standards-Version
* Enable hardening-wrapper
* Add lintian-override for the image file
2012-04-04 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.3-3) unstable; urgency=low
* Upload to unstable
* Update Standards-Version
2012-02-25 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.3-2) experimental; urgency=low
[ Rene Engelhard ]
* stop using basis-link. it's gone (Closes: #661181)
2012-02-07 - Timo Jyrinki <timo@debian.org>
libreoffice-voikko (3.3-1) unstable; urgency=low
* New upstream release

See Also

Package Description
libreoffice-writer_5.1.2-0ubuntu1_amd64.deb office productivity suite -- word processor
libreofficekit-dev_5.1.2-0ubuntu1_all.deb LibreOfficeKit -- headers
librest-0.7-0_0.7.93-1_amd64.deb REST service access library
librest-dev_0.7.93-1_amd64.deb REST service access library (development headers)
librest-doc_0.7.93-1_all.deb REST service access library (documentation)
librest-extras-0.7-0_0.7.93-1_amd64.deb REST service access library extra components
librest-extras-dev_0.7.93-1_amd64.deb REST service access library extra components (development headers)
librevenge-0.0-0_0.0.4-4ubuntu1_amd64.deb Base Library for writing document interface filters
librevenge-dev_0.0.4-4ubuntu1_amd64.deb Base Library for writing document interface filters -- development
librgw-dev_10.1.2-0ubuntu1_amd64.deb RADOS client library (development files)
librgw2_10.1.2-0ubuntu1_amd64.deb RADOS Gateway client library
librhythmbox-core9_3.3-1ubuntu7_amd64.deb support library for the rhythmbox music player
libroken18-heimdal_1.7~git20150920+dfsg-4ubuntu1_amd64.deb Heimdal Kerberos - roken support library
librrd-dev_1.5.5-4_amd64.deb time-series data storage and display system (development)
librrd4_1.5.5-4_amd64.deb time-series data storage and display system (runtime library)
Advertisement
Advertisement