libreoffice-core_5.1.2-0ubuntu1_amd64.deb


Advertisement

Description

libreoffice-core - office productivity suite -- arch-dependent files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libreoffice-core_5.1.2-0ubuntu1_amd64.deb
Package name libreoffice-core
Package version 5.1.2
Package release 0ubuntu1
Package architecture amd64
Package type deb
Category editors
Homepage http://www.libreoffice.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 26.83 MB
Installed size 107.58 MB
LibreOffice is a full-featured office productivity suite that provides
a near drop-in replacement for Microsoft(R) Office.
This package contains the architecture-dependent core files of
LibreOffice.  See the libreoffice package for more information.

Alternatives

Package Version Architecture Repository
libreoffice-core_5.1.6~rc2-0ubuntu1~xenial8_amd64.deb 5.1.6~rc2 amd64 Ubuntu Updates Main
libreoffice-core_5.1.6~rc2-0ubuntu1~xenial8_i386.deb 5.1.6~rc2 i386 Ubuntu Updates Main
libreoffice-core_5.1.2-0ubuntu1_i386.deb 5.1.2 i386 Ubuntu Main
libreoffice-core - - -

Requires

Name Value
fontconfig -
fonts-opensymbol -
libc6 >= 2.16
libcairo2 >= 1.10.0
libclucene-contribs1v5 >= 2.3.3.4
libclucene-core1v5 >= 2.3.3.4
libcmis-0.5-5v5 -
libcups2 >= 1.4.0
libcurl3-gnutls >= 7.16.2
libdbus-glib-1-2 >= 0.78
libeot0 -
libexpat1 >= 2.0.1
libexttextcat-2.0-0 >= 2.2-8
libfontconfig1 >= 2.11.94
libfreetype6 >= 2.3.5
libgcc1 >= 1:3.0
libgl1 -
libgl1-mesa-glx -
libglew1.13 >= 1.12.0
libglib2.0-0 >= 2.15.0
libgraphite2-3 >= 1.2.2
libharfbuzz-icu0 >= 0.9.18
libharfbuzz0b >= 0.9.18
libhunspell-1.3-0 >= 1.3.3
libhyphen0 >= 2.7.1
libice6 >= 1:1.0.0
libicu55 >= 55.1-1~
libjpeg8 >= 8c
liblangtag1 >= 0.4.0
liblcms2-2 >= 2.2+git20110628
libldap-2.4-2 >= 2.4.7
libmythes-1.2-0 -
libneon27-gnutls -
libnspr4 >= 2:4.9-2~
libnspr4-0d >= 1.8.0.10
libnss3 >= 2:3.13.4-2~
libnss3-1d >= 3.12.0~1.9b1
libpng12-0 >= 1.2.13-4
librdf0 >= 1.0.17
libreoffice-common >> 1:5.1.2
librevenge-0.0-0 -
libsm6 -
libstdc++6 >= 5.2
libx11-6 -
libxext6 -
libxinerama1 -
libxml2 >= 2.7.4
libxrandr2 -
libxrender1 -
libxslt1.1 >= 1.1.25
lp-solve >= 5.5.0.13-5+b1
uno-libs3 >= 5.1.0~alpha
ure >= 4.2~
zlib1g >= 1:1.1.4

Provides

Name Value
libreoffice-bundled -

Conflicts

Name Value
cacao-oj6-jre -
libreoffice-filter-binfilter -
libreoffice-unbundled -

Replaces

Name Value
libreoffice-calc << 1:3.3.2-5
libreoffice-common << 1:4.4.1-0ubuntu2
uno-libs3 << 1:3.6.1-2
ure << 1:3.6.1-2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libreoffice-core_5.1.2-0ubuntu1_amd64.deb
Source Package libreoffice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libreoffice-core deb package:
    # sudo apt-get install libreoffice-core

Files

Path
/usr/lib/libreoffice/program/libacclo.so
/usr/lib/libreoffice/program/libbasctllo.so
/usr/lib/libreoffice/program/libbasprovlo.so
/usr/lib/libreoffice/program/libbiblo.so
/usr/lib/libreoffice/program/libcached1.so
/usr/lib/libreoffice/program/libcairocanvaslo.so
/usr/lib/libreoffice/program/libcanvasfactorylo.so
/usr/lib/libreoffice/program/libchartcontrollerlo.so
/usr/lib/libreoffice/program/libchartcorelo.so
/usr/lib/libreoffice/program/libchartopengllo.so
/usr/lib/libreoffice/program/libclewlo.so
/usr/lib/libreoffice/program/libcmdmaillo.so
/usr/lib/libreoffice/program/libcollator_data.so
/usr/lib/libreoffice/program/libcomphelper.so
/usr/lib/libreoffice/program/libctllo.so
/usr/lib/libreoffice/program/libcuilo.so
/usr/lib/libreoffice/program/libdbmmlo.so
/usr/lib/libreoffice/program/libdeploymentgui.so
/usr/lib/libreoffice/program/libdict_ja.so
/usr/lib/libreoffice/program/libdict_zh.so
/usr/lib/libreoffice/program/libdlgprovlo.so
/usr/lib/libreoffice/program/libembobj.so
/usr/lib/libreoffice/program/libemboleobj.so
/usr/lib/libreoffice/program/libevtattlo.so
/usr/lib/libreoffice/program/libexpwraplo.so
/usr/lib/libreoffice/program/libfilelo.so
/usr/lib/libreoffice/program/libforlo.so
/usr/lib/libreoffice/program/libforuilo.so
/usr/lib/libreoffice/program/libfps_officelo.so
/usr/lib/libreoffice/program/libfrmlo.so
/usr/lib/libreoffice/program/libfwllo.so
/usr/lib/libreoffice/program/libfwmlo.so
/usr/lib/libreoffice/program/libgielo.so
/usr/lib/libreoffice/program/libguesslanglo.so
/usr/lib/libreoffice/program/libhyphenlo.so
/usr/lib/libreoffice/program/libi18nlangtag.so
/usr/lib/libreoffice/program/libi18nsearchlo.so
/usr/lib/libreoffice/program/libicglo.so
/usr/lib/libreoffice/program/libindex_data.so
/usr/lib/libreoffice/program/libldapbe2lo.so
/usr/lib/libreoffice/program/liblnthlo.so
/usr/lib/libreoffice/program/liblocaledata_en.so
/usr/lib/libreoffice/program/liblocaledata_es.so
/usr/lib/libreoffice/program/liblocaledata_euro.so
/usr/lib/libreoffice/program/liblocaledata_others.so
/usr/lib/libreoffice/program/libloglo.so
/usr/lib/libreoffice/program/libmergedlo.so
/usr/lib/libreoffice/program/libmigrationoo2lo.so
/usr/lib/libreoffice/program/libmigrationoo3lo.so
/usr/lib/libreoffice/program/libmorklo.so
/usr/lib/libreoffice/program/libmozbootstraplo.so
/usr/lib/libreoffice/program/libmsformslo.so
/usr/lib/libreoffice/program/libmtfrendererlo.so
/usr/lib/libreoffice/program/libodfflatxmllo.so
/usr/lib/libreoffice/program/liboffacclo.so
/usr/lib/libreoffice/program/liboglcanvaslo.so
/usr/lib/libreoffice/program/libooxlo.so
/usr/lib/libreoffice/program/libopencllo.so
/usr/lib/libreoffice/program/libpasswordcontainerlo.so
/usr/lib/libreoffice/program/libpcrlo.so
/usr/lib/libreoffice/program/libpdffilterlo.so
/usr/lib/libreoffice/program/libprotocolhandlerlo.so
/usr/lib/libreoffice/program/librecentfile.so
/usr/lib/libreoffice/program/libreslo.so
/usr/lib/libreoffice/program/libsaxlo.so
/usr/lib/libreoffice/program/libscnlo.so
/usr/lib/libreoffice/program/libscriptframe.so
/usr/lib/libreoffice/program/libsdbtlo.so
/usr/lib/libreoffice/program/libsduilo.so
/usr/lib/libreoffice/program/libsimplecanvaslo.so
/usr/lib/libreoffice/program/libspelllo.so
/usr/lib/libreoffice/program/libsrtrs1.so
/usr/lib/libreoffice/program/libstoragefdlo.so
/usr/lib/libreoffice/program/libstringresourcelo.so
/usr/lib/libreoffice/program/libsvgiolo.so
/usr/lib/libreoffice/program/libsysshlo.so
/usr/lib/libreoffice/program/libtextconv_dict.so
/usr/lib/libreoffice/program/libtextconversiondlgslo.so
/usr/lib/libreoffice/program/libtextfdlo.so
/usr/lib/libreoffice/program/libucbhelper.so
/usr/lib/libreoffice/program/libucpchelp1.so
/usr/lib/libreoffice/program/libucpcmis1lo.so
/usr/lib/libreoffice/program/libucpdav1.so
/usr/lib/libreoffice/program/libucpextlo.so
/usr/lib/libreoffice/program/libucpftp1.so
/usr/lib/libreoffice/program/libucphier1.so
/usr/lib/libreoffice/program/libucpimagelo.so
/usr/lib/libreoffice/program/libucppkg1.so
/usr/lib/libreoffice/program/libucptdoc1lo.so
/usr/lib/libreoffice/program/libunopkgapp.so
/usr/lib/libreoffice/program/libunordflo.so
/usr/lib/libreoffice/program/libupdatefeedlo.so
/usr/lib/libreoffice/program/libvbaeventslo.so
/usr/lib/libreoffice/program/libvbahelperlo.so
/usr/lib/libreoffice/program/libvclcanvaslo.so
/usr/lib/libreoffice/program/libvclplug_genlo.so
/usr/lib/libreoffice/program/libwriterperfectlo.so
/usr/lib/libreoffice/program/libxmlfalo.so
/usr/lib/libreoffice/program/libxmlfdlo.so
/usr/lib/libreoffice/program/libxmlsecurity.so
/usr/lib/libreoffice/program/libxoflo.so
/usr/lib/libreoffice/program/libxsec_fw.so
/usr/lib/libreoffice/program/libxsec_xmlsec.so
/usr/lib/libreoffice/program/libxsltdlglo.so
/usr/lib/libreoffice/program/libxsltfilterlo.so
/usr/lib/libreoffice/program/oosplash
/usr/lib/libreoffice/program/soffice.bin
/usr/lib/libreoffice/program/unopkg.bin
/usr/lib/libreoffice/program/uri-encode
/usr/lib/libreoffice/share/uno_packages/cache
/usr/share/bug/libreoffice-core/control
/usr/share/bug/libreoffice-core/presubj
/usr/share/bug/libreoffice-core/script
/usr/share/doc/libreoffice-core/README.gz
/usr/share/doc/libreoffice-core/changelog.Debian.gz
/usr/share/doc/libreoffice-core/copyright
/usr/share/lintian/overrides/libreoffice-core

Changelog

2016-04-05 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.2-0ubuntu1) xenial; urgency=medium
* new upstream bugfix release
* remove xmloff patch again for better upstream fix
2016-03-31 - Matthias Klose <doko@ubuntu.com>
libreoffice (1:5.1.1-0ubuntu3) xenial; urgency=medium
* Fix build failure in xmloff.
2016-03-31 - Matthias Klose <doko@ubuntu.com>
libreoffice (1:5.1.1-0ubuntu2) xenial; urgency=medium
* libreoffice-subsequentcheckbase: Depend on default-jdk.
2016-03-18 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.1-0ubuntu1) xenial; urgency=medium
* upstream released an rc3 = final
* allow libreoffice-style-elementary as alternative for -breeze in libreoffice-gtk (LP: #1483914)
* fix File>Templates>Manage executes wrong action in unity (LP: #1559135)
2016-02-29 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.1~rc2-0ubuntu1) xenial; urgency=medium
* new upstream rc
* update patches, remove upstreamed ones
* reenable unity-default-breeze, which wasnt reenabled on 5.1 yet (LP: #1506544)
* update Ubuntu palette, add main colors to standard palette (LP: #753627)
2016-02-21 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.0-0ubuntu1) xenial; urgency=medium
* finalize version, rc3 = 5.1.0
* depend on libreoffice-sdbc-hsqldb from libreoffice-subsequentcheckbase for
autopkgtests
* add libreoffice-style-elementary from upstream (LP: #1483914)
* continue building libreoffice-gtk3, but dont default-deploy (yet)
* use system ucpp instead of bundling (LP: #1524638)
* add google drive bits (LP: #1389936)
* update indic fonts package names (LP: #958345)
2016-02-10 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.0~rc3-0ubuntu2) xenial; urgency=medium
* update autopkgtest runner patch, removing unhelpful build system deps for
out-of-tree integration testing
2016-02-04 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.0~rc3-0ubuntu1) xenial; urgency=medium
* bump to rc3
* backport fix for ppc64el ftbfs
2016-02-03 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.0~rc2-0ubuntu2) xenial; urgency=medium
* use system mwaw, libwp*, lpsolve
2016-01-20 - Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
libreoffice (1:5.1.0~rc2-0ubuntu1) xenial; urgency=medium
* bump to rc2 and enable l10n

See Also

Package Description
libreoffice-dev-doc_5.1.2-0ubuntu1_all.deb office productivity suite -- SDK documentation
libreoffice-dev_5.1.2-0ubuntu1_amd64.deb office productivity suite -- SDK
libreoffice-draw_5.1.2-0ubuntu1_amd64.deb office productivity suite -- drawing
libreoffice-gnome_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GNOME integration
libreoffice-gtk3_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GTK+ 3.0 integration
libreoffice-gtk_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GTK+ integration
libreoffice-help-ca_5.1.2-0ubuntu1_all.deb office productivity suite -- Catalan help
libreoffice-help-cs_5.1.2-0ubuntu1_all.deb office productivity suite -- Czech help
libreoffice-help-da_5.1.2-0ubuntu1_all.deb office productivity suite -- Danish help
libreoffice-help-de_5.1.2-0ubuntu1_all.deb office productivity suite -- German help
libreoffice-help-dz_5.1.2-0ubuntu1_all.deb office productivity suite -- Dzongkha help
libreoffice-help-el_5.1.2-0ubuntu1_all.deb office productivity suite -- Greek help
libreoffice-help-en-gb_5.1.2-0ubuntu1_all.deb office productivity suite -- English_british help
libreoffice-help-en-us_5.1.2-0ubuntu1_all.deb office productivity suite -- English_american help
libreoffice-help-es_5.1.2-0ubuntu1_all.deb office productivity suite -- Spanish help
Advertisement
Advertisement