libref-array-dev_0.5.0-1_amd64.deb


Advertisement

Description

libref-array-dev - Development files for refcounted array for C

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libref-array-dev_0.5.0-1_amd64.deb
Package name libref-array-dev
Package version 0.5.0
Package release 1
Package architecture amd64
Package type deb
Category libdevel
Homepage https://fedorahosted.org/sssd/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.30 KB
Installed size 38.00 KB
A dynamically-growing, reference-counted array. Development files.
This package is part of the ding-libs, libraries that are required for the
proper functioning of SSSD, the System Security Services Daemon.

Alternatives

Package Version Architecture Repository
libref-array-dev_0.5.0-1_i386.deb 0.5.0 i386 Ubuntu Main
libref-array-dev - - -

Requires

Name Value
libref-array1 = 0.5.0-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libref-array-dev_0.5.0-1_amd64.deb
Source Package ding-libs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libref-array-dev deb package:
    # sudo apt-get install libref-array-dev

Files

Path
/usr/include/ref_array.h
/usr/lib/x86_64-linux-gnu/libref_array.a
/usr/lib/x86_64-linux-gnu/libref_array.so
/usr/lib/x86_64-linux-gnu/pkgconfig/ref_array.pc
/usr/share/doc/libref-array-dev/README.ref_array
/usr/share/doc/libref-array-dev/changelog.Debian.gz
/usr/share/doc/libref-array-dev/copyright

Changelog

2015-08-16 - Timo Aaltonen <tjaalton@debian.org>
ding-libs (0.5.0-1) unstable; urgency=medium
* New upstream release.
* libini-config-dev.install: Add ini_configmod.h.
* libcollection4.symbols, libini-config5.symbols: Updated.
* control: Bump policy to 3.9.6, no changes.
2014-07-15 - Timo Aaltonen <tjaalton@debian.org>
ding-libs (0.4.0-1) unstable; urgency=medium
* New upstream release.
* Drop automake_warning.patch, upstream.
* Update symbols, bump sonames for libcollection and libini-config.
* control: Bump policy to 3.9.5.
* control: Update my email.
* control: Drop C/R/P's, they're obsolete and harmful by now.
2014-01-02 - Daniel T Chen <crimsun@ubuntu.com>
ding-libs (0.3.0.1-4) unstable; urgency=low
* Use dh-autoreconf, resolving FTBFS on newer arches.
- Quiet automake warning;
- Add missing lib to link.
2013-11-15 - Timo Aaltonen <tjaalton@ubuntu.com>
ding-libs (0.3.0.1-3) unstable; urgency=low
* copyright: Updated.
2013-11-06 - Timo Aaltonen <tjaalton@ubuntu.com>
ding-libs (0.3.0.1-2) unstable; urgency=low
* rules, *-dev.install: Build static libs again, include in respective
-dev packages. (LP: #1183490)
* Cherry-pick 7a2eb259b2e22: Trim trailing spaces. (LP: #1248087)
2013-05-22 - Timo Aaltonen <tjaalton@ubuntu.com>
ding-libs (0.3.0.1-1) unstable; urgency=low
* New upstream release.
* rules: Use --fail-missing for dh_install.
* Add packaging for libbasicobjects.
* Bump soname for libini-config to 3.
* Rename *.docs files to actually do something.
* rules: Build using --disable-static.
* rules: Remove .la files.
* libini-config-dev: Add new headers.
* control: Wrap Depends.
* control: Update policy to 3.9.4, no changes.
* control: libini-config-dev needs to depend on libbasicobjects-dev and
libref-array-dev.
* Added symbols files.
* control: Added check, pkg-config to build-depends, run full test suite
on build.
2013-01-07 - Timo Aaltonen <tjaalton@ubuntu.com>
ding-libs (0.1.3-2) unstable; urgency=low
* Add missing Depends on libcollection-dev for libini-config-dev.
Thanks to Asbjørn Sloth Tønnesen <asbjorn@asbjorn.biz> (Closes: #697186)
2012-03-19 - Timo Aaltonen <tjaalton@ubuntu.com>
ding-libs (0.1.3-1) unstable; urgency=low
* Initial release (Closes: #637594)
- Fix library package names.
- Build using multiarch.
- Switch to source format 1.0.
- Bump the build-dep on debhelper to >= 9.
- Bump Standards-Version to 3.9.3, no changes.
- control: Update the maintainer address and repo location.
2011-05-30 - Michael Jeanson <mjeanson@rlnx.com>
ding-libs (0.1.2-0ubuntu1) oneiric; urgency=low
* Initial upload (LP:#790362)
[ Fabrice Coutadeur ]
* Initial packaging from PPA.

See Also

Package Description
libref-array1_0.5.0-1_amd64.deb refcounted array for C
libreiser4-dev_1.1.0-1.1_amd64.deb Reiser4's filesystem access and manipulation library. Devel files
libreoffice-avmedia-backend-gstreamer_5.1.2-0ubuntu1_amd64.deb GStreamer backend for LibreOffice
libreoffice-base-core_5.1.2-0ubuntu1_amd64.deb office productivity suite -- shared library
libreoffice-base-drivers_5.1.2-0ubuntu1_amd64.deb Database connectivity drivers for LibreOffice
libreoffice-base_5.1.2-0ubuntu1_amd64.deb office productivity suite -- database
libreoffice-calc_5.1.2-0ubuntu1_amd64.deb office productivity suite -- spreadsheet
libreoffice-common_5.1.2-0ubuntu1_all.deb office productivity suite -- arch-independent files
libreoffice-core_5.1.2-0ubuntu1_amd64.deb office productivity suite -- arch-dependent files
libreoffice-dev-doc_5.1.2-0ubuntu1_all.deb office productivity suite -- SDK documentation
libreoffice-dev_5.1.2-0ubuntu1_amd64.deb office productivity suite -- SDK
libreoffice-draw_5.1.2-0ubuntu1_amd64.deb office productivity suite -- drawing
libreoffice-gnome_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GNOME integration
libreoffice-gtk3_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GTK+ 3.0 integration
libreoffice-gtk_5.1.2-0ubuntu1_amd64.deb office productivity suite -- GTK+ integration
Advertisement
Advertisement