libqt5svg5_5.5.1-2build1_amd64.deb


Advertisement

Description

libqt5svg5 - Qt 5 SVG module

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libqt5svg5_5.5.1-2build1_amd64.deb
Package name libqt5svg5
Package version 5.5.1
Package release 2build1
Package architecture amd64
Package type deb
Category libs
Homepage http://qt-project.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 124.60 KB
Installed size 456.00 KB
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
The QtSvg module provides classes for displaying the contents of SVG files.
Scalable Vector Graphics (SVG) is a language for describing two-dimensional
graphics and graphical applications in XML.

Alternatives

Package Version Architecture Repository
libqt5svg5_5.6.1-2build1~~xenialoverlay1~1_i386.deb 5.6.1 i386 Kubuntu Backports
libqt5svg5_5.6.1-2build1~~xenialoverlay1~1_amd64.deb 5.6.1 amd64 Kubuntu Backports
libqt5svg5_5.5.1-2build1_i386.deb 5.5.1 i386 Ubuntu Main
libqt5svg5 - - -

Requires

Name Value
dpkg >= 1.15.6~
libc6 >= 2.14
libqt5core5a >= 5.5.0
libqt5gui5 >= 5.3.0
libqt5gui5-gles >= 5.3.0
libqt5widgets5 >= 5.3.0
libstdc++6 >= 4.1.1
qtbase-abi-5-5-1 -
zlib1g >= 1:1.1.4

Provides

Name Value
qtsvg-abi-5-4-0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libqt5svg5_5.5.1-2build1_amd64.deb
Source Package qtsvg-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5svg5 deb package:
    # sudo apt-get install libqt5svg5

Files

Path
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.5
/usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.5.1
/usr/lib/x86_64-linux-gnu/qt5/plugins/iconengines/libqsvgicon.so
/usr/lib/x86_64-linux-gnu/qt5/plugins/imageformats/libqsvg.so
/usr/share/doc/libqt5svg5/changelog.Debian.gz
/usr/share/doc/libqt5svg5/copyright

Changelog

2015-11-30 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtsvg-opensource-src (5.5.1-2build1) xenial; urgency=medium
* Rebuild against Qt 5.5.1.
2015-10-21 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtsvg-opensource-src (5.5.1-2) unstable; urgency=medium
* Upload to unstable.
2015-10-18 - Dmitry Shachnev <mitya57@debian.org>
qtsvg-opensource-src (5.5.1-1) experimental; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Remove libqt5svg5-private-dev. Nothing in the stack is using it and
according to dak there are no rdeps (Closes: #790769).
[ Dmitry Shachnev ]
* Move private headers to a temporary directory so that we can really
mark them (based on code in qtmultimedia).
* New upstream release.
* Bump Qt build-dependencies to 5.5.1.
* Make BSD-3-clause license text match upstream header.BSD more closely.
2015-08-27 - Dmitry Shachnev <mitya57@debian.org>
qtsvg-opensource-src (5.5.0-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.5.0.
* Update debian/copyright.
* Do not run tests during arch-indep builds.
* Remove symbols that are missing with GCC 5.
2015-08-27 - Dmitry Shachnev <mitya57@debian.org>
qtsvg-opensource-src (5.4.2-3) unstable; urgency=medium
* Remove symbols that are missing with GCC 5 (to fix a build
failure).
2015-06-24 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtsvg-opensource-src (5.4.2-2) unstable; urgency=medium
* Upload to unstable.
2015-06-03 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtsvg-opensource-src (5.4.2-1) experimental; urgency=medium
[ Timo Jyrinki ]
* Update debian/copyright.
[ Lisandro Damián Nicanor Pérez Meyer ]
* New upstream release.
- Bump Qt build dependencies.
* Clear up the list in Uploaders removing people who hasn't committed to the
repo in more than a year. They can re add themselves whenever they want
(and we really hope to see you back really soon!).
* Use pkgkde-mark-private-symbols from pkg-kde-tools' 0.15.17.
- Remove relevant debian/copyright entry.
* Expose HTML documentation (Closes: #751184).
2015-03-04 - Timo Jyrinki <timo@debian.org>
qtsvg-opensource-src (5.4.1-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.4.1.
* Update watch file to qt.io
* Mark symbols missing with GCC 5 as optional (Closes: #778094).
* debian/mark-private-symbols.sh:
- Strip trailing colon from symbols names.
- Unmark private symbols before processing them.
2014-12-26 - Dmitry Shachnev <mitya57@debian.org>
qtsvg-opensource-src (5.4.0-1) experimental; urgency=medium
[ Dmitry Shachnev ]
* New upstream release.
* Bump Qt build-dependencies to 5.4.0.
* Build-depend on qtbase5-doc-html, for linking docs.
* Update debian/copyright.
* Bump Standards-Version to 3.9.6, no changes needed.
* Update Vcs-Browser field to use cgit interface.
* Update ABI version (qtsvg-abi-5-4-0).
* Re-enable running tests during build.
* Add myself to Uploaders.
[ Timo Jyrinki ]
* Update libqt5svg5.symbols.
2014-09-23 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtsvg-opensource-src (5.3.2-2) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
libqt5test5_5.5.1+dfsg-16ubuntu7_amd64.deb Qt 5 test module
libqt5versit5_5.0~git20140515~29475884-0ubuntu20_amd64.deb Qt PIM module, Versit library
libqt5versitorganizer5_5.0~git20140515~29475884-0ubuntu20_amd64.deb Qt PIM module, Versit Organizer library
libqt5webkit5-dev_5.5.1+dfsg-2ubuntu1_amd64.deb Web content engine library for Qt - development files
libqt5webkit5_5.5.1+dfsg-2ubuntu1_amd64.deb Web content engine library for Qt
libqt5widgets5_5.5.1+dfsg-16ubuntu7_amd64.deb Qt 5 widgets module
libqt5xml5_5.5.1+dfsg-16ubuntu7_amd64.deb Qt 5 XML module
libqt5xmlpatterns5-dev_5.5.1-2build1_amd64.deb Qt 5 XML patterns development files
libqt5xmlpatterns5-private-dev_5.5.1-2build1_amd64.deb Qt 5 XML patterns private development files
libqt5xmlpatterns5_5.5.1-2build1_amd64.deb Qt 5 XML patterns module
libqtcore4_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 core module
libqtdbus4_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 D-Bus module library
libqtgui4_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 GUI module
libquadmath0_5.3.1-14ubuntu2_amd64.deb GCC Quad-Precision Math Library
libquorum-dev_2.3.5-3ubuntu1_amd64.deb cluster engine Quorum library development
Advertisement
Advertisement