libqpdf-dev_6.0.0-2_amd64.deb


Advertisement

Description

libqpdf-dev - development files for PDF transformation/inspection library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libqpdf-dev_6.0.0-2_amd64.deb
Package name libqpdf-dev
Package version 6.0.0
Package release 2
Package architecture amd64
Package type deb
Category libdevel
Homepage http://qpdf.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 350.43 KB
Installed size 1.97 MB
QPDF is a program that can be used to linearize (web-optimize),
encrypt (password-protect), decrypt, and inspect PDF files from the
command-line.  It does these and other structural, content-preserving
transformations on PDF files, reading a PDF file as input and
creating a new one as output.  It also provides many useful
capabilities to developers of PDF-producing software or for people
who just want to look at the innards of a PDF file to learn more
about how they work.
QPDF understands PDF files that use compressed object streams
(supported by newer PDF applications) and can convert such files into
those that can be read with older viewers.  It can also be used for
checking PDF files for structural errors, inspecting stream contents,
or extracting objects from PDF files.  QPDF is not PDF content
creation or viewing software -- it does not have the capability to
create PDF files from scratch or to display PDF files.
This package includes all development files needed to compile
applications that use the qpdf library.

Alternatives

Package Version Architecture Repository
libqpdf-dev_8.0.2-3~16.04.1_amd64.deb 8.0.2 amd64 Ubuntu Updates Main
libqpdf-dev_8.0.2-3~16.04.1_i386.deb 8.0.2 i386 Ubuntu Updates Main
libqpdf-dev_6.0.0-2_i386.deb 6.0.0 i386 Ubuntu Main
libqpdf-dev - - -

Requires

Name Value
libpcre3-dev -
libqpdf17 = 6.0.0-2
zlib1g-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libqpdf-dev_6.0.0-2_amd64.deb
Source Package qpdf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqpdf-dev deb package:
    # sudo apt-get install libqpdf-dev

Files

Path
/usr/include/qpdf/Buffer.hh
/usr/include/qpdf/BufferInputSource.hh
/usr/include/qpdf/Constants.h
/usr/include/qpdf/DLL.h
/usr/include/qpdf/FileInputSource.hh
/usr/include/qpdf/InputSource.hh
/usr/include/qpdf/Pipeline.hh
/usr/include/qpdf/Pl_Buffer.hh
/usr/include/qpdf/Pl_Concatenate.hh
/usr/include/qpdf/Pl_Count.hh
/usr/include/qpdf/Pl_Discard.hh
/usr/include/qpdf/Pl_Flate.hh
/usr/include/qpdf/Pl_StdioFile.hh
/usr/include/qpdf/PointerHolder.hh
/usr/include/qpdf/QPDF.hh
/usr/include/qpdf/QPDFExc.hh
/usr/include/qpdf/QPDFObjGen.hh
/usr/include/qpdf/QPDFObject.hh
/usr/include/qpdf/QPDFObjectHandle.hh
/usr/include/qpdf/QPDFTokenizer.hh
/usr/include/qpdf/QPDFWriter.hh
/usr/include/qpdf/QPDFXRefEntry.hh
/usr/include/qpdf/QTC.hh
/usr/include/qpdf/QUtil.hh
/usr/include/qpdf/RandomDataProvider.hh
/usr/include/qpdf/Types.h
/usr/include/qpdf/qpdf-c.h
/usr/lib/x86_64-linux-gnu/libqpdf.a
/usr/lib/x86_64-linux-gnu/libqpdf.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libqpdf.pc
/usr/share/doc/libqpdf-dev/README.gz
/usr/share/doc/libqpdf-dev/TODO.gz
/usr/share/doc/libqpdf-dev/changelog.Debian.gz
/usr/share/doc/libqpdf-dev/copyright

Changelog

2015-11-16 - Jay Berkenbilt <qjb@debian.org>
qpdf (6.0.0-2) unstable; urgency=medium
* Upload to unstable.
2015-11-10 - Jay Berkenbilt <qjb@debian.org>
qpdf (6.0.0-1) experimental; urgency=medium
* New upstream release. Includes soname bump.
2015-11-10 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.2.0-2) unstable; urgency=medium
* Revert ABI change. This is reverts the deterministic ID change
introduced in 5.2.0 but retains the other fix. 6.0.0 will be released
imminently with the new functionality. This version is compatible with
5.1.3. (Closes: #804706)
2015-11-01 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.2.0-1) unstable; urgency=medium
* New upstream release.
2015-09-06 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.3-3) unstable; urgency=high
* Update copyright to include a few files that had separate copyrights
from the rest of the software. (Closes: #794555)
2015-08-03 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.3-2) unstable; urgency=medium
* Upload for gcc5 transition. Rename libqpdf13 to libqpdf13v5.
(Closes: #791255)
2015-05-24 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.3-1) unstable; urgency=medium
* New upstream release. Includes all previous patches.
* Update standards to 3.9.6. No changes required.
* Fix typo in package description. (Closes: #779192)
2014-12-29 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.2-3) experimental; urgency=medium
* Handle broken PDF files with missing /Type keys in their page
dictionary nodes. (Uploaded to experimental during debian freeze --
this is production-ready.)
2014-11-14 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.2-2) unstable; urgency=medium
* Properly handle pages with no /Content in the page dictionary,
enabling printing of files with blank pages as produced by some
software. (Closes: #769599)
2014-06-07 - Jay Berkenbilt <qjb@debian.org>
qpdf (5.1.2-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
libqpdf17_6.0.0-2_amd64.deb runtime library for PDF transformation/inspection software
libqqwing-dev_1.3.4-1_amd64.deb tool for generating and solving Sudoku puzzles (development)
libqqwing2v5_1.3.4-1_amd64.deb tool for generating and solving Sudoku puzzles (library)
libqt4-dbus_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 D-Bus module
libqt4-declarative-gestures_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 gestures QML plugin
libqt4-declarative-particles_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 particles QML plugin
libqt4-declarative_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 Declarative module
libqt4-designer_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 designer module
libqt4-dev-bin_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 development programs
libqt4-dev_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 development files
libqt4-help_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 help module
libqt4-network_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 network module
libqt4-opengl-dev_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 OpenGL library development files
libqt4-opengl_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 OpenGL module
libqt4-qt3support_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 3 compatibility library for Qt 4
Advertisement
Advertisement