libpython3.5_3.5.1-10_amd64.deb


Advertisement

Description

libpython3.5 - Shared Python runtime library (version 3.5)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpython3.5_3.5.1-10_amd64.deb
Package name libpython3.5
Package version 3.5.1
Package release 10
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.30 MB
Installed size 4.41 MB
Python is a high-level, interactive, object-oriented language. Its 3.5 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
This package contains the shared runtime library, normally not needed
for programs using the statically linked interpreter.

Alternatives

Package Version Architecture Repository
libpython3.5_3.5.2-2ubuntu0~16.04.9_amd64.deb 3.5.2 amd64 Ubuntu Updates Main
libpython3.5_3.5.2-2ubuntu0~16.04.9_i386.deb 3.5.2 i386 Ubuntu Updates Main
libpython3.5_3.5.1-10_i386.deb 3.5.1 i386 Ubuntu Main
libpython3.5 - - -

Requires

Name Value
libc6 >= 2.17
libexpat1 >= 2.1~beta3
libpython3.5-stdlib = 3.5.1-10
zlib1g >= 1:1.2.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpython3.5_3.5.1-10_amd64.deb
Source Package python3.5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpython3.5 deb package:
    # sudo apt-get install libpython3.5

Files

Path
/usr/lib/python3.5/config-3.5m-x86_64-linux-gnu/libpython3.5.so
/usr/lib/python3.5/config-3.5m-x86_64-linux-gnu/libpython3.5m.so
/usr/lib/x86_64-linux-gnu/libpython3.5m.so.1
/usr/lib/x86_64-linux-gnu/libpython3.5m.so.1.0
/usr/share/doc/libpython3.5
/usr/share/lintian/overrides/libpython3.5

Changelog

2016-03-31 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-10) unstable; urgency=medium
* Update to 20160330 from the 3.5 branch.
2016-03-23 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-9) unstable; urgency=medium
* Update to 20160323 from the 3.5 branch.
* Always build _math.o with -fPIC.
2016-03-18 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-8) unstable; urgency=medium
* Update to 20160318 from the 3.5 branch.
* Fix python3-venv with updated python-pip packages (Barry Warsaw).
Closes: #815014, #815864.
* Fix generating devhelp documentation (Simon McVittie).
Closes: #816299. LP: #1553633.
2016-02-24 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-7) unstable; urgency=medium
* Update to 20160224 from the 3.5 branch.
* python3.5-venv: Drop the dependency on python-setuptools-whl,
depend on python-pip-whl (>= 8.0.2-7).
* Don't run the test_socket test, hangs on some buildds.
2016-02-22 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-6) unstable; urgency=medium
* Update to 20160221 from the 3.5 branch.
2016-01-13 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-5) unstable; urgency=medium
* Update to 20160113 from the 3.5 branch.
2016-01-11 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-4) unstable; urgency=medium
* Update to 20160111 from the 3.5 branch.
2016-01-05 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-3) unstable; urgency=medium
* Update to 20160105 from the 3.5 branch.
* Fix maintainer scripts with findutils 4.6. Closes: #809079.
2015-12-10 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-2) unstable; urgency=medium
* Disable LTO on Debian/s390x.
* Don't run test_signal on alpha, currently breaks the testsuite.
2015-12-07 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-1) unstable; urgency=medium
* Python 3.5.1 release.
* Fix building architecture independent packages only. Closes: #806870.
* Update symbols files for i386.
* d/p/fix-sslv3-test.diff: properly handle Ubuntu's openssl having OP_NO_SSLv3
forced on by default (Marc Deslauriers).

See Also

Package Description
libqb-dev_0.17.2.real-6ubuntu1_amd64.deb high performance client server features library (devel files)
libqb-doc_0.17.2.real-6ubuntu1_all.deb high performance client server features library (API docs)
libqb0_0.17.2.real-6ubuntu1_amd64.deb high performance client server features library
libqgsttools-p1_5.5.1-4ubuntu2_amd64.deb GStreamer tools for Qt 5 Multimedia module
libqmi-glib-dev_1.12.6-1_amd64.deb Header files for adding QMI support to applications that use glib
libqmi-glib-doc_1.12.6-1_all.deb API documentation for libqmi-glib
libqmi-glib1_1.12.6-1_amd64.deb Support library to use the Qualcomm MSM Interface (QMI) protocol
libqmi-proxy_1.12.6-1_amd64.deb Proxy to communicate with QMI ports
libqpdf-dev_6.0.0-2_amd64.deb development files for PDF transformation/inspection library
libqpdf17_6.0.0-2_amd64.deb runtime library for PDF transformation/inspection software
libqqwing-dev_1.3.4-1_amd64.deb tool for generating and solving Sudoku puzzles (development)
libqqwing2v5_1.3.4-1_amd64.deb tool for generating and solving Sudoku puzzles (library)
libqt4-dbus_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 D-Bus module
libqt4-declarative-gestures_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 gestures QML plugin
libqt4-declarative-particles_4.8.7+dfsg-5ubuntu2_amd64.deb Qt 4 particles QML plugin
Advertisement
Advertisement