libpopt0_1.16-10_amd64.deb


Advertisement

Description

libpopt0 - lib for parsing cmdline parameters

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpopt0_1.16-10_amd64.deb
Package name libpopt0
Package version 1.16
Package release 10
Package architecture amd64
Package type deb
Category libs
Homepage http://rpm5.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 25.41 KB
Installed size 128.00 KB
Popt was heavily influenced by the getopt() and getopt_long() functions,
but it allows more powerful argument expansion. It can parse arbitrary
argv[] style arrays and automatically set variables based on command
line arguments. It also allows command line arguments to be aliased via
configuration files and includes utility functions for parsing arbitrary
strings into argv[] arrays using shell-like rules.
This package contains the runtime library and locale data.

Alternatives

Package Version Architecture Repository
libpopt0_1.16-10_i386.deb 1.16 i386 Ubuntu Main
libpopt0 - - -

Requires

Name Value
libc6 >= 2.17
multiarch-support -

Conflicts

Name Value
libpopt-dev <= 1.4-1
popt -
rpm <= 4.0.2-3

Replaces

Name Value
popt -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpopt0_1.16-10_amd64.deb
Source Package popt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpopt0 deb package:
    # sudo apt-get install libpopt0

Files

Path
/lib/x86_64-linux-gnu/libpopt.so.0
/lib/x86_64-linux-gnu/libpopt.so.0.0.0
/usr/share/doc/libpopt0/README
/usr/share/doc/libpopt0/changelog.Debian.gz
/usr/share/doc/libpopt0/copyright

Changelog

2014-08-25 - Paul Martin <pm@debian.org>
popt (1.16-10) unstable; urgency=low
* debian/rules: move dependency on target autoreconf-stamp from 
configure (which isn't called) to configure-deb-stamp and 
configure-udeb-stamp.
* Patches: 757935-autoreconf.patch: add change to Makefile.am of 
testit.sh path.
* That'll teach me to try to be too clever! (Closes: #757935)
2014-08-25 - Paul Martin <pm@debian.org>
popt (1.16-9) unstable; urgency=low
* Patches:
+ 728596-secure-getenv.patch: update to change #elseif (not recognised
by gcc) to #elif.
+ 757935-autoreconf.patch: remove AM_C_PROTOTYPES from configure.ac
* Add dependency on dh-autoreconf, and use that in debian/rules instead
of directly using the rules from autotools-dev. (Closes: #757935)
* Update to standards version 3.9.5 (no changes)
2013-11-03 - Paul Martin <pm@debian.org>
popt (1.16-8) unstable; urgency=low
* Remove build dependency on quilt. (Closes: #709541)
* Fix renamed __secure_getenv() function for building with glibc 2.17
and later. (Closes: #728596)
* Use dh_autotools-dev_updateconfig and dh_autotools-dev_restoreconfig
to keep config.sub and config.guess up to date.
Build-depend on autotools-dev.
2012-05-30 - Paul Martin <pm@debian.org>
popt (1.16-7) unstable; urgency=low
* Fix install directory for the pkgconfig file. (Closes: #658663)
Thanks to Christoph Biedl for spotting the oddity.
dh_install strikes again!
2012-05-29 - Paul Martin <pm@debian.org>
popt (1.16-6) unstable; urgency=low
* Change dependency on gettext to a version that has a msgfmt that
always builds little endian .mo files. (Closes: #670023)
2012-05-14 - Paul Martin <pm@debian.org>
popt (1.16-5) unstable; urgency=low
* Enabled hardened build flags. (Closes: #672835)
2012-05-02 - Paul Martin <pm@debian.org>
popt (1.16-4) unstable; urgency=low
* Multiarch build cleanup take 2. (Closes: #670022)
* Ignoring localizations binary endianness versus multiarch problem.
That's something for gettext to fix. Thanks for the advice, vorlon.
(Ignoring: #670023)
* Update to debhelper 9.
* Update to standards version 3.9.2
* Updated copyright file and converted to machine readable format.
2011-12-20 - Paul Martin <pm@debian.org>
popt (1.16-3) unstable; urgency=low
* Multiarch build cleanup. Thanks to Jakub Wilk. (Closes: #638447)
2011-12-19 - Paul Martin <pm@debian.org>
popt (1.16-2) unstable; urgency=low
* Update to standards version 3.9.2
+ Comply with new build-arch/build-indep requirements.
+ Note that libtool .la files are deprecated under Debian policy 3.9.1,
but continute to include libpopt.la under the "historical" exception.
* Package upstream's libpopt.pc (Closes: #421575)
* Add multiarch support. Thanks to Steve Langasek for patch.
(Closes: #638447)
* Update debian/compat to 8.
* Add a debian/symbols file. (Closes: #551437)
2010-05-13 - Paul Martin <pm@debian.org>
popt (1.16-1) unstable; urgency=low
* New upstream release (Closes: #581439)
* Switch to dpkg-source 3.0 (quilt) format
* Add a watch file.
* Update to standards version 3.8.4 (no changes)

See Also

Package Description
libportaudio2_19+svn20140130-1build1_amd64.deb Portable audio I/O - shared library
libportaudiocpp0_19+svn20140130-1build1_amd64.deb Portable audio I/O C++ bindings - shared library
libpotrace-dev_1.13-2_amd64.deb development files for potrace library
libpotrace0_1.13-2_amd64.deb library for tracing bitmaps
libpq-dev_9.5.2-1_amd64.deb header files for libpq5 (PostgreSQL library)
libpq5_9.5.2-1_amd64.deb PostgreSQL C client library
libpresage-data_0.9.1-1.1ubuntu2_all.deb intelligent predictive text entry platform (data files)
libpresage-dev_0.9.1-1.1ubuntu2_amd64.deb intelligent predictive text entry platform (development files)
libpresage-doc_0.9.1-1.1ubuntu2_all.deb intelligent predictive text entry platform (documentation)
libpresage1v5_0.9.1-1.1ubuntu2_amd64.deb intelligent predictive text entry platform (shared library)
libproc-waitstat-perl_1.00-4.2_all.deb interpret and act on wait() status values
libprocess-cpp-dev_3.0.1-0ubuntu2_amd64.deb C++11 library for handling processes - dev headers and libraries
libprocess-cpp-doc_3.0.1-0ubuntu2_all.deb Documentation files for libprocess-cpp-dev
libprocess-cpp3_3.0.1-0ubuntu2_amd64.deb C++11 library for handling processes - runtime library
libprocps4-dev_3.3.10-4ubuntu2_amd64.deb library for accessing process information from /proc
Advertisement
Advertisement