libpolkit-gobject-1-0_0.105-14.1_amd64.deb


Advertisement

Description

libpolkit-gobject-1-0 - PolicyKit Authorization API

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpolkit-gobject-1-0_0.105-14.1_amd64.deb
Package name libpolkit-gobject-1-0
Package version 0.105
Package release 14.1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.freedesktop.org/wiki/Software/polkit/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 35.28 KB
Installed size 141.00 KB
PolicyKit is a toolkit for defining and handling the policy that
allows unprivileged processes to speak to privileged processes.
This package contains a library for accessing PolicyKit.

Alternatives

Package Version Architecture Repository
libpolkit-gobject-1-0_0.105-14.1ubuntu0.5_amd64.deb 0.105 amd64 Ubuntu Updates Main
libpolkit-gobject-1-0_0.105-14.1ubuntu0.5_i386.deb 0.105 i386 Ubuntu Updates Main
libpolkit-gobject-1-0_0.105-14.1_i386.deb 0.105 i386 Ubuntu Main
libpolkit-gobject-1-0 - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.37.3
libsystemd0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpolkit-gobject-1-0_0.105-14.1_amd64.deb
Source Package policykit-1

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpolkit-gobject-1-0 deb package:
    # sudo apt-get install libpolkit-gobject-1-0

Files

Path
/usr/lib/x86_64-linux-gnu/libpolkit-gobject-1.so.0
/usr/lib/x86_64-linux-gnu/libpolkit-gobject-1.so.0.0.0
/usr/share/doc/libpolkit-gobject-1-0/changelog.Debian.gz
/usr/share/doc/libpolkit-gobject-1-0/copyright

Changelog

2016-01-14 - Adam Borowski <kilobyte@angband.pl>
policykit-1 (0.105-14.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS on non-linux/non-systemd. (Closes: #798769)
2015-11-23 - Martin Pitt <mpitt@debian.org>
policykit-1 (0.105-14) unstable; urgency=medium
* debian/policykit-1.preinst: Use systemctl unmask instead of direct symlink
removal for consistency.
* Fix handling of multi-line helper output. Thanks Dariusz Gadomski! Patch
backported from upstream master. (LP: #1510824)
2015-10-21 - Martin Pitt <mpitt@debian.org>
policykit-1 (0.105-13) unstable; urgency=medium
* debian/policykit-1.{pre,pos}inst: Temporarily mask polkitd.service while
policykit-1 is unpackaged but not yet configured. During that time we
don't yet have our D-Bus policy in /etc so that polkitd cannot work yet.
This can be dropped once the D-Bus policy moves to /usr.
(Closes: #794723, LP: #1447654)
2015-09-11 - Simon McVittie <smcv@debian.org>
policykit-1 (0.105-12) unstable; urgency=medium
* Team upload
* Replace 03_complete_session.patch with a change from upstream
which seems like a more correct solution for LP#445303, LP#649939
* 05_revert-admin-identities-unix-group-wheel.patch: remove confusing
staff -> desktop_admin_r change in a man page (desktop_admin_r looks
vaguely like a SELinux role but is actually being used as a group);
keep only the actual functional change. This matches the syntactically
different but functionally similar change in experimental.
* 09_pam_environment.patch: replace with the version that went upstream.
* Annotate remaining patches with a bit more information.
They are:
- 00git_fix_memleak.patch, 00git_invalid_object_paths.patch,
00git_type_registration.patch, 04_get_cwd.patch,
07_set-XAUTHORITY-environment-variable-if-unset.patch,
08_deprecate_racy_APIs.patch, 09_pam_environment.patch,
cve-2013-4288.patch: either backports from upstream, or already
applied upstream, and not discussed further here.
- 01_pam_polkit.patch: use Debian's common-* infrastructure,
plus pam_env to get the global environment and locale.
Debian-specific.
- 02_gettext.patch: Use gettext to translate .policy files at
runtime, allowing for Ubuntu-style language packs.
Debian-specific (mainly for Ubuntu's benefit, really).
- 05_revert-admin-identities-unix-group-wheel.patch: Debian does
not use the "wheel" group like Red Hat derivatives do;
treat uid 0 as the administrative identity instead.
Debian-specific.
- 06_systemd-service.patch: hook up the systemd service in
debian/polkitd.service.
Not forwarded: obsoleted by an upstream change in 0.106,
commit 2995085.
* Re-order patch series to put upstream changes first, sorted by version
in which they went upstream, and put them in subdirectories by version
* Add patches from 0.113 to fix heap corruption CVE-2015-3255
(Closes: #766860) and local authenticated denial of service
CVE-2015-4625 (Closes: #796134)
* Add numerous other bug-fix patches from 0.113
- work around bugs in older versions of libpam-systemd when using
su or similar (Closes: #772125)
- treat background processes as part of the same uid's active GUI
session if they have one (Closes: #779988)
- fix some memory leaks (Closes: #775158, LP: #1417637)
* Add backported public API polkit_system_bus_name_get_user_sync() to
symbols file
* Fix FTBFS with dpkg-buildpackage -A by only installing files into
policykit-1 in per-arch builds
* Run tests with a session bus pretending to be the system bus,
so they can pass in a buildd environment

See Also

Package Description
libpolkit-gobject-1-dev_0.105-14.1_amd64.deb PolicyKit Authorization API - development files
libpoppler-cpp-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- development files (CPP interface)
libpoppler-cpp0_0.41.0-0ubuntu1_amd64.deb PDF rendering library (CPP shared library)
libpoppler-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- development files
libpoppler-glib-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- development files (GLib interface)
libpoppler-glib-doc_0.41.0-0ubuntu1_all.deb PDF rendering library -- documentation for the GLib interface
libpoppler-glib8_0.41.0-0ubuntu1_amd64.deb PDF rendering library (GLib-based shared library)
libpoppler-private-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- private development files
libpoppler-qt4-4_0.41.0-0ubuntu1_amd64.deb PDF rendering library (Qt 4 based shared library)
libpoppler-qt4-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- development files (Qt 4 interface)
libpoppler-qt5-1_0.41.0-0ubuntu1_amd64.deb PDF rendering library (Qt 5 based shared library)
libpoppler-qt5-dev_0.41.0-0ubuntu1_amd64.deb PDF rendering library -- development files (Qt 5 interface)
libpoppler58_0.41.0-0ubuntu1_amd64.deb PDF rendering library
libpopt-dev_1.16-10_amd64.deb lib for parsing cmdline parameters - development files
libpopt0_1.16-10_amd64.deb lib for parsing cmdline parameters
Advertisement
Advertisement