libplist++3v5_1.12-3.1_amd64.deb


Advertisement

Description

libplist++3v5 - Library for handling Apple binary and XML property lists

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libplist++3v5_1.12-3.1_amd64.deb
Package name libplist++3v5
Package version 1.12
Package release 3.1
Package architecture amd64
Package type deb
Category libs
Homepage http://www.libimobiledevice.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 20.14 KB
Installed size 93.00 KB
libplist is a library for reading and writing the Apple binary and XML
property lists format. It's part of the libimobiledevice stack, providing
access to iDevices (iPod, iPhone, iPad ...).
This library is the C++ implementation of the libplist API.

Alternatives

Package Version Architecture Repository
libplist++3v5_1.12-3.1ubuntu0.16.04.1_i386.deb 1.12 i386 Ubuntu Updates Main
libplist++3v5_1.12-3.1ubuntu0.16.04.1_amd64.deb 1.12 amd64 Ubuntu Updates Main
libplist++3v5_1.12-3.1_i386.deb 1.12 i386 Ubuntu Main
libplist++3v5 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libplist3 >= 1.11
libstdc++6 >= 5.2

Conflicts

Name Value
libplist++3 -

Replaces

Name Value
libplist++3 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libplist++3v5_1.12-3.1_amd64.deb
Source Package libplist

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplist++3v5 deb package:
    # sudo apt-get install libplist++3v5

Files

Path
/usr/lib/x86_64-linux-gnu/libplist++.so.3
/usr/lib/x86_64-linux-gnu/libplist++.so.3.0.0
/usr/share/doc/libplist++3v5/changelog.Debian.gz
/usr/share/doc/libplist++3v5/copyright
/usr/share/lintian/overrides/libplist++3v5

Changelog

2015-08-26 - Simon McVittie <smcv@debian.org>
libplist (1.12-3.1) unstable; urgency=medium
* Non-maintainer upload.
[ Steve Langasek ]
* Rename library packages for g++5 ABI transition. (Closes: #791155)
2015-06-02 - Chow Loong Jin <hyperair@debian.org>
libplist (1.12-3) unstable; urgency=medium
* Team upload
* [a2bf55a] Fix up libplist++3.symbols for uint64_t ambiguities.
Depending on arch, uint64_t can be either unsigned long or unsigned long
long.
2015-05-24 - Chow Loong Jin <hyperair@debian.org>
libplist (1.12-2) unstable; urgency=low
* Team upload
* Reupload to unstable
* [eb09c93] Call dh_link without arguments as well.
Apparently, dh_link doesn't make the symlinks from the .links files when
called with arguments.
2014-10-16 - Chow Loong Jin <hyperair@debian.org>
libplist (1.12-1) unstable; urgency=medium
* Team upload
* [7d22cff] Imported Upstream version 1.12
* [2b51b73] Rename packages for new ABI
* [51557d7] Update libplist3.symbols
* [63cc293] Update libplist++3.symbols
* [50d24a8] Drop 02-fix-endian.patch (upstreamed)
* [098bd08] Fix copyright-format 1.0 errors.
We need dedicated license paragraphs when more than one file paragraph uses
the same license.
* [8ffd5cc] Fix invalid-short-name-in-dep5-copyright
* [62c733e] Update Standards-Version to 3.9.6 (no change)
2014-03-29 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-3) unstable; urgency=medium
* [516e84a] Patch to fix endian detection (Closes: #742673)
* [df245be] Fix typo in libplist-doc description (Closes: #732766)
2014-03-26 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-2) unstable; urgency=medium
* Team upload
* [f625f06] Re-add .pxd file to python-plist.install.
Looks like it's needed by python-imobiledevice.
2014-03-25 - Chow Loong Jin <hyperair@debian.org>
libplist (1.11-1) unstable; urgency=medium
* Team upload
* [02a25b6] Imported Upstream version 1.11
* [a308129] Adapt packaging to use autotools
* [1e2ef46] Bump Standards-Version to 3.9.5 (no changes required)
* [cbdbd1a] Drop 03-remove-rpath.patch.
We don't need a patch to avoid rpath linkage with the new autotools build
system.
* [608a31e] Refresh 01-libs.private.patch
* [c0e674f] Build-dep on pkg-config
* [a5f8276] Rename libplist and libplist++ for SONAME bump
* [47cb416] Drop libplist++2.shlibs
* [406fb90] Call dpkg-gensymbols with -c4
* [8490574] Update install files for SONAME change and drop .pxd
* [cc8efd7] Drop *.la and *.a prior to dh_install
* [6fa64b7] Update .symbols files
2013-09-16 - Chow Loong Jin <hyperair@debian.org>
libplist (1.10-1) unstable; urgency=low
[ Julien Lavergne ]
* New upstream release (Closes: #706378)
* debian/rules:
- Remove workaround for moving plutil utils, since the name change
completely.
* debian/libplist++-dev.install:
- Install new files.
* debian/libplist1.symbols:
- Update symbols.
* debian/control:
- Update VCS fields.
- Update Standards-Version to 3.9.4.
- Remove dm-upload-allowed.
* debian/libplist++1.shlibs:
- Add a shlibs file, since symbols file is too unstable.
[ Chow Loong Jin ]
* debian/{control,rules}: Multiarchify things
* debian/control:
- Mark lib packages as multi-arch same
- Add dpkg-dev build-dep for default.mk include
* debian/libplist*1.install: Update paths in install files for multiarch
* debian/plistutils.manpages: Rename manpage to match binary rename
* debian/rules: Update LDFLAGS handling and drop CFLAGS override
* debian/lintian-overrides:
- Add lintian-overrides for hardening-no-fortify-functions

See Also

Package Description
libplist-dev_1.12-3.1_amd64.deb Library for handling Apple binary and XML property lists
libplist-doc_1.12-3.1_all.deb Library for handling Apple binary and XML property lists - docs
libplist3_1.12-3.1_amd64.deb Library for handling Apple binary and XML property lists
libplumb2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- libplumb2
libplumb2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- libplumb2
libplumbgpl2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- libplumbgpl2
libplumbgpl2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- libplumbgpl2
libplymouth-dev_0.9.2-3ubuntu13_amd64.deb graphical boot animation and logger - development files
libplymouth4_0.9.2-3ubuntu13_amd64.deb graphical boot animation and logger - shared libraries
libpng12-0_1.2.54-1ubuntu1_amd64.deb PNG library - runtime
libpng12-dev_1.2.54-1ubuntu1_amd64.deb PNG library - development
libpolkit-agent-1-0_0.105-14.1_amd64.deb PolicyKit Authentication Agent API
libpolkit-agent-1-dev_0.105-14.1_amd64.deb PolicyKit Authentication Agent API - development files
libpolkit-backend-1-0_0.105-14.1_amd64.deb PolicyKit backend API
libpolkit-backend-1-dev_0.105-14.1_amd64.deb PolicyKit backend API - development files
Advertisement
Advertisement