libpfm4_4.7.0-4_amd64.deb


Advertisement

Description

libpfm4 - Library to program the performance monitoring events

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename libpfm4_4.7.0-4_amd64.deb
Package name libpfm4
Package version 4.7.0
Package release 4
Package architecture amd64
Package type deb
Category libs
Homepage http://perfmon2.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 177.90 KB
Installed size 1.50 MB
Libpfm4 helps convert from an event name, expressed as a string, to
the event encoding. The encoding can then be used with specific OS
interfaces. Libpfm4 also provides OS-specific interfaces to directly
setup OS-specific data structures to be passed to the kernel. The
current libpfm4, for instance, provides support for the perf_events
interface which was introduced in Linux v2.6.31.
This package provides the shared library.

Alternatives

Package Version Architecture Repository
libpfm4_4.7.0-4_i386.deb 4.7.0 i386 Ubuntu Main
libpfm4 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpfm4_4.7.0-4_amd64.deb
Source Package libpfm4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpfm4 deb package:
    # sudo apt-get install libpfm4

Files

Path
/usr/lib/x86_64-linux-gnu/libpfm.so.4
/usr/lib/x86_64-linux-gnu/libpfm.so.4.7.0
/usr/share/doc/libpfm4/README.gz
/usr/share/doc/libpfm4/changelog.Debian.gz
/usr/share/doc/libpfm4/copyright

Changelog

2016-02-25 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.7.0-4) unstable; urgency=medium
* Cherry-pick umask encoding fixes.
* use-LDFLAGS-when-linking.patch: Remove, fixed upstream.
* typos.patch: Fix some more typos.
2016-02-15 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.7.0-3) unstable; urgency=medium
* [x32] Use the same symbols as amd64.
* d/copyright: Refresh copyright list from upstream git commit history.
2016-02-15 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.7.0-2) unstable; urgency=medium
* Restrict to Architecture: linux-any.
* [powerpc] Add new symbols from 4.7.0.
* [x32] x32.patch: New, fix printing __time_t.
2016-02-15 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.7.0-1) unstable; urgency=medium
* New upstream release.  (Closes: #811924)
* Add new symbols from 4.7.0.
* Drop libpfm4-dbg package in favor of autogenerated -dbgsyms packages.
* man-sections.patch, typos.patch: New, fix some issues found by Lintian.
* Bump Standards-Version to 3.9.7. No changes needed.
* Update Vcs-* URLs.
2015-06-03 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.6.0-4) unstable; urgency=medium
* Cherry-pick Haswell EP RAPL support, Broadwell FPARITH and some bug fixes.
2015-04-27 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.6.0-3) unstable; urgency=medium
* Cherry-pick Broadwell, Airmont support and memory leak fixes.
* Fix hyphenation errors in manpages.
* Upload to unstable.
2015-02-13 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.6.0-2) experimental; urgency=medium
* [mips64, mips64el] Use the same symbols as mips(el).  (Closes: #775836)
* Cherry-pick missing MEM_LOAD_UOPS_RETIRED:L1_MISS for IvyBridge, typo
fixes and cgroup fix.
2015-01-08 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.6.0-1) experimental; urgency=medium
* New upstream release.
* Add new symbols from 4.6.0.
* Add Build-Depends: dh-python.
* Cherry-pick missing ICACHE:IFETCH_STALLS for Haswell and SandyBridge.
* Upload to experimental.
2014-10-16 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.5.0+git38-g1ca1338-2) unstable; urgency=medium
* dpkg-gensymbols: Raise check level to 4 - fail on any symbol change.
* [armhf, arm64] Factor out common symbols to .symbols.arm.common.
* [armhf, powerpc] Add new symbols from 4.5.0.
* [armhf, arm64] Add new symbols.
* [arm64] Add a separate symbols file.
* [armel] Use the same symbols as armhf.
* [ppc64, ppc64el] Use the same symbols as powerpc.
* [sparc64] Use the same symbols as sparc.
* d/copyright: Refresh copyright list from upstream git commit history.
2014-10-15 - Andreas Beckmann <anbe@debian.org>
libpfm4 (4.5.0+git38-g1ca1338-1) unstable; urgency=medium
* New upstream GIT snapshot.
* [amd64] Add new symbols.
* Bump Standards-Version to 3.9.6. No changes needed.

See Also

Package Description
libpgtypes3_9.5.2-1_amd64.deb shared library libpgtypes for PostgreSQL 9.5
libphobos-5-dev_5.3.1-14ubuntu2_amd64.deb Phobos D standard library
libphobos-dev_5.3.1-1ubuntu1_amd64.deb Phobos D standard library
libpils2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- libpils2
libpils2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- libpils2
libpipeline-dev_1.4.1-2_amd64.deb pipeline manipulation library (development files)
libpipeline1_1.4.1-2_amd64.deb pipeline manipulation library
libpixman-1-0_0.33.6-1_amd64.deb pixel-manipulation library for X and cairo
libpixman-1-dev_0.33.6-1_amd64.deb pixel-manipulation library for X and cairo (development files)
libpkcs11-helper1-dev_1.11-5_amd64.deb library that simplifies the interaction with PKCS#11
libpkcs11-helper1_1.11-5_amd64.deb library that simplifies the interaction with PKCS#11
libplist++-dev_1.12-3.1_amd64.deb Library for handling Apple binary and XML property lists
libplist++3v5_1.12-3.1_amd64.deb Library for handling Apple binary and XML property lists
libplist-dev_1.12-3.1_amd64.deb Library for handling Apple binary and XML property lists
libplist-doc_1.12-3.1_all.deb Library for handling Apple binary and XML property lists - docs
Advertisement
Advertisement